• Issues enabling WiFi


    I am trying to enable WiFi from my built-in PCI:

    02:00.0 Network controller: Intel Corporation Dual Band Wireless-AC 3165 Plus Bluetooth (rev 99) 

    I downloaded my drivers from here: https://www.intel.com/content/www/us/en/support/articles/000005511/network-and-i-o/wireless-networking.html
    Extracted and copied to /lib/firmware and rebooted. Doesn’t work.

    I tried taking my interface up:

    ip link set wlp2s0 up

    Didn’t report any issue and didn’t help either.


    dmesg | grep iwl
    [    2.991609] iwlwifi 0000:02:00.0: loaded firmware version 29.610311.0 op_mode iwlmvm                                                                                                                                                                                        
    [    3.052860] iwlwifi 0000:02:00.0: Detected Intel(R) Dual Band Wireless AC 3165, REV=0x210                                                                                                                                                                                   
    [    3.081186] iwlwifi 0000:02:00.0: base HW address: ac:ed:5c:52:57:dd                                                                                                                                                                                                        
    [    3.149412] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'                                                                                                                                                                                                    
    [    3.153824] iwlwifi 0000:02:00.0 wlp2s0: renamed from wlan0     

    And I tried connecting a USB adapter, but it didn’t work either, no notification that something is connected and a green light on the USB device, didn’t work.

    I know this must be very common issue for newbies but I couldn’t find any solution that works for me. Any suggestion?

  • @ahassoun try that:

    modprobe -r iwlmvm iwlwifi

    get info about driver options:

    modinfo -p iwlwifi

    try loading without 11n support:

    modprobe iwlwifi 11n_disable=1

    check this:

    systool -v -m iwlwifi

    if it works, make it permanent:

    sudo nano /etc/modprobe.d/iwlwifi.conf
    and add this inside this new file:

    options iwlwifi 11n_disable=1
    options iwlwifi swcrypto=1

    Save with [Ctrl+X]

  • Thanks Joe,

    Unfortunately it didn’t fix, here’s output of info commands:

    [[email protected] ahassoun]# modinfo -p iwlwifi
    debug:debug output mask (uint)
    swcrypto:using crypto in software (default 0 [hardware]) (int)
    11n_disable:disable 11n functionality, bitmap: 1: full, 2: disable agg TX, 4: disable agg RX, 8 enable agg TX (uint)
    amsdu_size:amsdu size 0: 12K for multi Rx queue devices, 4K for other devices 1:4K 2:8K 3:12K (default 0) (int)
    fw_restart:restart firmware in case of error (default true) (bool)
    antenna_coupling:specify antenna coupling in dB (default: 0 dB) (int)
    nvm_file:NVM file name (charp)
    d0i3_disable:disable d0i3 functionality (default: Y) (bool)
    lar_disable:disable LAR functionality (default: N) (bool)
    uapsd_disable:disable U-APSD functionality bitmap 1: BSS 2: P2P Client (default: 3) (uint)
    bt_coex_active:enable wifi/bt co-exist (default: enable) (bool)
    led_mode:0=system default, 1=On(RF On)/Off(RF Off), 2=blinking, 3=Off (default: 0) (int)
    power_save:enable WiFi power management (default: disable) (bool)
    power_level:default power save level (range from 1 - 5, default: 1) (int)
    fw_monitor:firmware monitor - to debug FW (default: false - needs lots of memory) (bool)
    d0i3_timeout:Timeout to D0i3 entry when idle (ms) (uint)
    disable_11ac:Disable VHT capabilities (default: false) (bool)
    [[email protected] ahassoun]# modprobe iwlwifi 11n_disable=1
    Module = "iwlwifi"
        coresize            = "315392"
        initsize            = "0"
        initstate           = "live"
        refcnt              = "1"
        srcversion          = "CFFF5C162A83F2977E03473"                                                                                                                                                                                                                            
        taint               = ""                                                                                                                                                                                                                                                   
        uevent              = <store method only>                                                                                                                                                                                                                                  
        11n_disable         = "1"                                                                                                                                                                                     
        amsdu_size          = "0"                                                                                                                                                                                     
        antenna_coupling    = "0"                                                                                                                                                                                     
        bt_coex_active      = "Y"                                                                                                                                                                                     
        d0i3_disable        = "Y"                                                                                                                                                                                     
        d0i3_timeout        = "1000"                                                                                                                                                                                  
        debug               = "0"                                                                                                                                                                                     
        disable_11ac        = "N"                                                                                                                                                                                     
        fw_monitor          = "N"                                                                                                                                                                                     
        fw_restart          = "Y"                                                                                                                                                                                     
        lar_disable         = "N"                                                                                                                                                                                     
        led_mode            = "0"                                                                                                                                                                                     
        nvm_file            = "(null)"                                                                                                                                                                                
        power_level         = "0"                                                                                                                                                                                     
        power_save          = "N"                                                                                                                                                                                     
        swcrypto            = "0"                                                                                                                                                                                     
        uapsd_disable       = "3"                                                                                                                                                                                     
        .altinstr_replacement= "0x0000000048453024"
        .altinstructions    = "0x0000000076b1faa3"
        .bss                = "0x00000000c856564d"
        .data.once          = "0x0000000058e3dd9b"
        .data               = "0x00000000c24eadb8"
        .exit.text          = "0x000000005a8ed0f6"
        .gnu.linkonce.this_module= "0x000000009d0e1105"
        .init.text          = "0x000000000f96400d"
        .note.gnu.build-id  = "0x00000000a78d386f"
        .orc_unwind         = "0x000000001083f141"
        .orc_unwind_ip      = "0x000000001b7f5720"
        .parainstructions   = "0x00000000a5a5311c"
        .ref.data           = "0x000000007e1bdd03"
        .rodata.str1.1      = "0x000000009eba2238"
        .rodata.str1.8      = "0x0000000064162221"
        .rodata             = "0x00000000203a13f0"
        .smp_locks          = "0x0000000023c56800"
        .strtab             = "0x00000000ec4c9067"
        .symtab             = "0x00000000b13e57d1"
        .text               = "0x0000000025591987"
        __bug_table         = "0x000000001e8e040e"
        __jump_table        = "0x00000000ea00455e"
        __kcrctab           = "0x00000000d2811339"
        __kcrctab_gpl       = "0x00000000e4424fba"
        __ksymtab_gpl       = "0x000000003a555e11"
        __ksymtab_strings   = "0x00000000726ce24d"
        __ksymtab           = "0x000000008db1779b"
        __mcount_loc        = "0x00000000228fd33e"
        __param             = "0x000000003eca404f"
        __tracepoints_ptrs  = "0x00000000a127abd6"
        __tracepoints       = "0x000000008b6f0800"
        __tracepoints_strings= "0x00000000567e5852"
        _ftrace_events      = "0x000000005125bfbf"
  • there are known issues with getting firmware for this device, may you need to check the firmware …

    May also try the LTS Kernel instead of the current one!

  • I am in LTS now. I repeated steps for modeprob and nothing changes.

    How about the external USB wifi adapter? Could it work? Or my hardware won’t like Antergos?

  • Solved :) by editing modprobe.d/blacklist.conf

    And added

    blacklist ideapad_laptop

    I now can see available wifi networks. Although I am still unable to access web but could be issue with my network. Will troubleshoot this later but at least I can see the networks now

  • Thats nice to see you get it working! where do you find the hint?

  • This is what got my Kali to work! (Same laptop, I came from Kali)

    I didn’t try it on first time because you suggested this command which I assumed are similar.

    modprobe iwlwifi 11n_disable=1
wifi151 network15 Posts 9Views 976
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.