• Unable to boot after fresh install


    Hello, there!

    First day with Antergos and I need some help.

    UEFI mode. Secure boot is disabled.

    The installer reported a warning that the booter may not exist.

    I can’t find Antergos entry in the boot menu. Although I am (kind of sure) that the system is installed because of the 12 GB used in the partition.

    0_1523397292818_Screenshot from 2018-04-10 21-48-29.png

    This is what I have tried and didn’t work:

    [[email protected] ~]$ sudo su
    [[email protected] antergos]# mount /dev/nvme0n1p4 /mnt
    [[email protected] antergos]# mount /dev/nvme0n1p4 /mnt/boot
    [[email protected] antergos]# arch-chroot /mnt
    [[email protected] /]# grub-install /dev/nvme0n1p4 
    Installing for x86_64-efi platform.
    grub-install: error: cannot find EFI directory.
    [[email protected] /]#  
    

    Dual drives. SSD and HDD. Windows installed on SSD (and Kali Linux was previously installed on the SSD as well). Intel RST is disabled (This makes Windows unable to boot, but makes Linux able to see my SSD, and I don’t mind being unable to boot to Windows).

    Could someone guide me please?

  • @ahassoun
    The error here is obvious:
    In the installation process and while partitioning your HD you didn’t precise and mount the \boot\efi partition which is the 260 MB Windows/Fat32 partition in your image.

  • @ahassoun

    grub-install /dev/nvme0n1p4

    You are using UEFI, not BIOS legacy, so the grub-install needs to be used accordingly. You need to mount the ESP partition (/dev/nvme0n1p1) and put Antergos EFI files there with grub-install.

    https://wiki.archlinux.org/index.php/GRUB#Installation_2

    System info commands:
    lsblk -fm
    lspci
    sudo blkid
    sudo fdisk -l

  • Thanks, I didn’t expect such quick response!

    Okay so according to my understanding of your replies I did this:

    [[email protected] /]# mount /dev/nvme0n1p1 /boot    
    [[email protected] /]# grub-install --target=x86_64-efi --efi-directory=/boot --bootloader-id=antergos_grub
    Installing for x86_64-efi platform.
    Installation finished. No error reported.
    [[email protected] /]#
    

    By the way, initially I tried /boot/efi but it didn’t work:

    [[email protected] /]# mount /dev/nvme0n1p1 /boot/efi
    mount: /boot/efi: mount point does not exist.
    

    Rebooting now, hope it works

  • OK now when I boot, it takes me to GNU GRUB version 2.02 command line interface.

    When I went to check bios option I can now see my new entry

    What’s next?

  • @ahassoun
    Could you show us the output you have when trying to boot?

    System info commands:
    lsblk -fm
    lspci
    sudo blkid
    sudo fdisk -l

  • By the way, did you command:

    grub-mkconfig -o /boot/grub/grub.cfg
    

    after running grub-install (in the chroot mode)?

    System info commands:
    lsblk -fm
    lspci
    sudo blkid
    sudo fdisk -l

  • This post is deleted!
  • This post is deleted!
  • @manuel said in Unable to boot after fresh install:

    By the way, did you command:

    grub-mkconfig -o /boot/grub/grub.cfg
    

    after running grub-install (in the chroot mode)?

    No, I didn’t see this command, will do it now. (Edit: My bad! I didn’t see the rest of the Wiki)

    For the output, I get GRUB command line, similar to this:
    alt text

    Edit again:

    [[email protected] ~]$ sudo su
    [[email protected] antergos]# grub-mkconfig -o /boot/grub/grub.cfg
    /usr/bin/grub-probe: error: failed to get canonical path of `root-image'.
    [[email protected] antergos]# mount /dev/nvme0n1p1 /boot
    [[email protected] antergos]# grub-install --target=x86_64-efi --efi-directory=/boot --bootloader-id=antergos_grub
    Installing for x86_64-efi platform.
    Installation finished. No error reported.
    [[email protected] antergos]# grub-mkconfig -o /boot/grub/grub.cfg
    /usr/bin/grub-probe: error: failed to get canonical path of `root-image'.
    [[email protected] antergos]# arch-chroot /boot
    mount: /boot/proc: mount point does not exist.
    ==> ERROR: failed to setup chroot /boot
    umount: bad usage
    Try 'umount --help' for more information.
    
  • @ahassoun
    Now you need to be extra careful where you set the mount points.

    And sorry, I’m in a hurry now, so I’ll be brief.

    You should mount the p4 partition to /mnt and arch-chroot to that.
    Then you can check the /boot/efi and see if it is mounted to the p1 ESP partition.
    Then you can do that grub-mkconfig thing.

    Hope this helps, I’ll be away for a couple of hours, cheers!

    System info commands:
    lsblk -fm
    lspci
    sudo blkid
    sudo fdisk -l

  • @ahassoun said in Unable to boot after fresh install:

    [[email protected] /]# mount /dev/nvme0n1p1 /boot

    the efi partition needs to be mounted under /boot/efi !!!

    https://antergos.com/wiki/de/miscellaneous/how-to-fix-grub-with-efi-boot/

    sudo su
    mount /dev/nvme0n1p4 /mnt
    mount /dev/nvme0n1p1 /mnt/boot/efi
    arch-chroot /mnt
    grub-mkconfig -o /boot/grub/grub.cfg
    grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Antergos-grub
    

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • Thank you so much Joe and m anuel for your time and patience. Really appreciated.

     mount /dev/nvme0n1p1 /mnt/boot/efi
    

    This line didn’t work. Mount point doesn’t exist or something like this. So I tried:

    mount /dev/nvme0n1p4 /mnt
    arch-chroot /mnt
    mount /dev/nvme0n1p1 /boot/efi
    grub-mkconfig and grub-install (with different bootloader ID)
    

    All executed without errors.

    The new boot entry takes me to the Antergos GUI (not the usb-installer one), but then it fails and takes me to Emergency Mode. With FAILED /boot/efi not found

    At least it takes me to the actual Antergos now

  • Hm, Looks like you do not have the mount entry for /boot/efi inside /etc/fstab and may also the directory itself is not created.
    When you execute to mount the EFI partition from inside chroot it gives out any error?

    Can you boot again to live iso, and show the /etc/fstab from your Antergos installation?
    You can chroot again like before, or search the file with filebrowser

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad said in Unable to boot after fresh install:

    When you execute to mount the EFI partition from inside chroot it gives out any error?

    Yes, it gave me error ‘mount point doesn’t exist’, then I ch-rooted to /mnt and from there I mounted without issues.

    The mentioned file exists and here is its content

    # /etc/fstab: static file system information.
    #
    # Use 'blkid' to print the universally unique identifier for a
    # device; this may be used with UUID= as a more robust way to name devices
    # that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    #
    UUID=B48CB4358CB3F04A /boot/efi vfat defaults,relatime 0 0
    UUID=5d6f90d0-7948-4063-8af7-624b605ac93e / ext4 defaults,relatime,data=ordered 0 1
    
  • I don’t know why I am unable to edit my replies.

    From inside chroot: No errors.

    And the file above is from the actual installation using filebrowser

  • Next I would check if uuids inside fstab are correct, and repeat installing grub with the options from my previous post…

    lsblk -f
    

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • Should I mount, and ch-root again?

  • This is without ch-rooting:

    0_1523453339289_Screenshot from 2018-04-11 13-28-31.png

  • @ahassoun
    Hello again and sorry for the delay (I had to do other things…).
    And thanks @joekamprad for joining!

    mount /dev/nvme0n1p1 /mnt/boot/efi

    I think just before that command (of what joe already presented) you need to do:

    mkdir -p /mnt/boot/efi
    

    to make sure the directory you use as mountpoint exists.

    And another problem in /etc/fstab:

    UUID=B48CB4358CB3F04A /boot/efi vfat defaults,relatime 0 0
    

    has wrong UUID value, should be 46B3-980A.

    System info commands:
    lsblk -fm
    lspci
    sudo blkid
    sudo fdisk -l

boot221 unable51 fresh29 Posts 28Views 201
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.