• libsecret dependency issue


    I’ve recently been getting the following errors for the libsecret
    package, and I’m not sure how to best resolve:

    Making package: lib32-libsecret 0.18.6-1 (Fri Apr  6 13:15:40 EDT 2018)
    ==> Checking runtime dependencies...
    ==> Missing dependencies:
      -> libsecret=0.18.6
    

    Or this variation with pacman:

    error: failed to prepare transaction (could not satisfy dependencies)
    :: lib32-libsecret: installing libsecret (0.18.6-1) breaks dependency
    'libsecret=0.18.5+14+g9980655'
    

    Any help is greatly appreciated!

  • @trey said in libsecret dependency issue:

    libsecret

    this is an issue with an AUR PKGBUILD : lib32-libsecret you get…
    what for do you need to build this package?

  • @joekamprad I’m not sure. How can I tell? I looked at ‘man pacman’ and saw the ‘owns’ flag (-o) but not sure how to use it.

    When I had previously tried to remove libsecret, it said is was needed by pacman

  • I have removed lib32-libsecret (which had some optional dependencies for wine) and all is well now.

dependency22 libsecret1 Posts 4Views 342
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.