• GRUB issue with mixed UEFI/BIOS and Windows


    Oh, and the Antergos EFI files probably need to be removed from the UEFI (vfat) partition.

  • @manuel OK thanks I’ll give that a try. But I want to make it clear that I refuse to touch my Windows drive. I can’t afford to mess anything up - so please, stop suggesting I put GRUB on my Windows SSD. I would rather never use Linux for the rest of my life than lose what I have on there. So a “rescue disk” isn’t good enough for me. That’s the whole reason I want them on separate drives!

  • @sinadoom
    Hmmm… I really don’t understand why you are so reluctant to make generally wise things like a rescue disk - it has nothing to do with Linux and everything to do with Windows. But that’s your choice, of course.

    I just hope you have good and reliably working backups of your personal data.

    So: before installing Antergos, shut down the machine and physically unplug your Windows SSD.
    Then proceed as discussed above, chrooting and stuff.
    After that, check that Antergos boots in BIOS mode. If not, then reinstall Antergos in BIOS mode, and check that it boots OK in BIOS mode.

    Now, if Antergos boots in BIOS mode without problems, shutdown the machine again and plug in the Windows SSD. Then make the machine boot to Antergos SSD in BIOS mode.

    Now, in Antergos, run command:

    sudo grub-mkconfig -o /boot/grub/grub.cfg
    

    That should recognize also the Windows SSD. Now reboot and check that both systems boot in BIOS mode OK.

  • @manuel Sigh, why does everyone assume not wanting to lose stuff necessarily means “personal data”? I don’t want to have to reapply the years of customisations and software I’ve installed, as Windows (especially Windows 10) is horrible out of the box. I hope we can stop discussing anything to do with my Windows setup in this thread (and your determinance to have me delete my Windows partition - no, I don’t hate Microsoft and I won’t stop using Windows because of Xbox and games), since clearly the issue is not Windows but Antergos/GRUB not playing nicely with BIOS.

    Anyways, back to the real topic at hand. As previously mentioned the issue is that Antergos boots into “emergency mode” after exactly 1 min 30 second countdown. I have tried re-installing GRUB on the Linux drive and it still isn’t booting normally. I have tried the mount and it didn’t work "saying something about the drive being busy). Also arch-chroot command is not found.

    At this point I think your earlier suggestion to re-install makes sense. The whole reason I didn’t want to go down that root is because I didn’t want to have to re-download Antergos onto my USB but if I have to do that to follow this fix then may as well re-install completely in BIOS mode. That said I don’t even recall having been given the option to choose between BIOS and EFI when I first installed it, so I’m not sure if that will work either.

  • BTW there are free tools to convert MBR disks to GPT (without loosing data) like the old minitool partition wizard 9.1 iso recovery.
    Why you didn’t try that to convert your Windows 10 MS-DOS partition:
    https://www.windowscentral.com/how-convert-mbr-disk-gpt-move-bios-uefi-windows-10
    I had a similar dual boot system last week: Windows 10 on a 128 GB SSD disk2 and Antergros on a 60 GB partition in 1 TB sata disk1. All in UEFI and it worked great.
    The only thing in my opinion that Antergros team should advise users is to not use Windows partition image softwares to backup Antergros installation. I have tried them all, especially Macrium give very bad results on GRUB and I do understand that CloneZilla lead to similar issues concernind GRUB/dual booting.
    The partition image to use for linux and this should be ticked at the top descriptions is: Gnome DISKS. This one work perfect 100% for linux partitions backups.
    Even a single resize on a external NTFS partition by an external tool tool like Minitool PW has bad effects on GRUB.
    Finally I want to congratulate Antergros team for this great Arch Linux distro, it’s the first linux distro that convinced me to drop forever windows 10. I’m especially happy with the clean professional interface with no advertising for anything.

  • @ben_h I don’t want to touch my Windows drive. I want to convert Antergos EFI to BIOS, not other way round.

  • I had issues with UEFI booting on my PC, as I am using an SSD, an HDD, and an external HDD all containing several Linux installations, and GRUB was not helping. Finally, I could solve the problem by installing REFIND. Now I do not have to change the boot order in the UEFI bios to allow a specific distro to boot, as REFIND takes care.

    On my old laptop, I could not install REFIND, as it does not support UEFI. I have an SSD with Siduction and Antergos installed. Although the GRUB list in Siduction showed Antergos, it would lead to kernel panic every time I selected Antergos for booting up. On comparing with REFIND boot entries, I found that Siduction was pointing to intel-ucode.img, while the correct img for Antergos was initramfs-linux.img, located in the Antergo boot folder.
    I have now deleted the intel-ucode.img and made a copy of initramfs-linux.img, and renamed that to intel-ucode.img. Now, Antergos boots up fine from Siduction Grub. Only problem, I have to repeat the renaming of the img files every time Antergos has a kernel update.

  • @kunal open a new post with your issue and do not try take over old one please !

    closing

grub109 windows58 mixed2 uefibios1 Posts 28Views 1373
Locked
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.