• Having issues with lockscreen

    Running Antergos on Razer Blade Stealth.


    • On boot, I can log in and work just fine.
    • If I close my lid, the login screen comes up.
    • After logging in, about 20 seconds later the screen will dim and lock
    • Only fixable on reboot.

    It can be reproduced infinitely. I have tried swapping lightdm with gdm, to no avail. My guess is that the timer for the lockscreen is somehow being shortened, but I’m not sure.

  • what DE (GNOME KDE e.t.c.) ?

  • I also had several issues with Lock-Screen, Shutdown, Log-Out, etc…

    The setup which is working best for me is GNOME on Xorg + GDM.

  • @schmunk willkommen!

    GDM+GNOME on xorg is a stable duo!
    But GDM is hungry.

    I am on lightdm+slick-greeter working well with i3+GNOME but it’s a Desktop system.

    If you have GNOME on mobile device the most simple working solution is to use GDM.

  • @joekamprad Sorry for the late reply. I’m on GNOME. I’ve also been logging in with Xorg if that helps.

  • You are sure GDM is up and running?

    HOWTO: https://antergos.com/wiki/desktops/installing-display-managers/

    If yes, go to gnome-control-center and do setup for Display and energy related things.

    Take a look inside ~/.config/autostart if you are not familar with stuff like this:
    post the output of this command from a terminal:

    ls ~/.config/autostart
    There mayby some disturbing stuff autostarting …

  • @joekamprad Alright I’ve tried a few things to narrow down the issue.

    First, here’s the output

     > ls .config/autostart/
    cnchi.desktop  first-boot-hotfix.desktop  tilda.desktop

    Second, I’ve swapped over to GDM for a few days and here are my findings.

    • GDM bugs out way more than lightdm does (locks sooner and more aggressively) when closing the lid.
    • GDM does NOT bug out when left to suspend on it’s own (leaving it alone until it locks, but not closing the lid).
    • Still requires reboot to fix behaviour.
  • @nanda1123 said in Having issues with lockscreen:

    cnchi.desktop first-boot-hotfix.desktop

    this two files can safely removed…

  • @joekamprad I deleted the two files, but the issue still persists.

    Another finding that may be helpful

    • If I initiate suspend (through say, the power button) then close the lid, the issue doesn’t happen.
  • My response was not related to you issue, the two files was caus of a installer bug only…

    The onmly thing comes to my mind is to try to uninstall lioghtdm (needs uninstalling antergos-gnome-meta with sudo pacman -R antergos-gnome-meta first) This was helping here on problems with gdm before…

  • I believe I have fixed this issue.

    • Firstly, I don’t think uninstalling lightdm was the proper fix, but I did it anyways to try. So I uninstalled lightdm and all it’s dependencies.
    • The detail was actually found in this repo. Under the Suspend Loop section, I followed the steps and edited grub.conf. I wasn’t able to restart grub with sudo update-grub so I needed to use sudo grub-mkconfig -o /boot/grub/grub.cfg.
    • After rebooting, I have been able to close the lid to my laptop multiple times and have had no issue with suspend loops.

    Thank you to those that helped!

  • Update-Grub is from Debian based…

    Nice to see you are solving the issue!
    May we put this to wiki.

  • @joekamprad I would recommend putting this on the wiki, it took a lot of digging to fix this.

lightdm137 gdm49 lockscreen15 razer3 Posts 13Views 1173
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.