• system boots ok then black screen with cursor flashing in top left


    It’s a lenovo ideapad Z710 laptop with 12MB memory. Have been running Antergos on it for at least 6 months as replacement for Windows 10 very successfully. This has been going on for about 3 weeks but this is the first chance to try to get it sorted.
    Running Linux 4.15.13-1-ARCH and same thing happens with the LTS version. Haven’t changed the hardware, so my theory is that something has come through in terms of a change which has not been handled well by this combination of hardware.
    System seems to boot normally, then Chromium browser works fine, terminal works fine, all updates working do fully up to date.

    Then after a period of time perhaps half an hour to an hour but always when I’m not there, I’ll come back and there’s the blank screen, no error messages, and a horizontal underline cursor in the top left corner.

  • Here’s an inxi -G:

    Card-1: Intel 4th Gen Core Processor Integrated Graphics driver: i915
    v: kernel
    Card-2: NVIDIA GM108M [GeForce 840M] driver: nouveau v: kernel
    Display Server: x11 (X.Org 1.19.6) driver: modesetting
    unloaded: fbdev,intel,nouveau,nv,vesa resolution: 1920x1080~60Hz
    OpenGL: renderer: Mesa DRI Intel Haswell Mobile v: 4.5 Mesa 17.3.7

  • @boogy said in system boots ok then black screen with cursor flashing in top left:

    lenovo ideapad Z710



    I will not force you to install bumblebee, but as it may is related to a graphics issue…

    May possible also to disable nvidia card inside bios

  • @joekamprad thanks for those, will look into them.

    After I booted up OK, I used the system for about 2 hours, as I have never seen the system go down, only the blank screen that’s left after whatever event takes place. But in that time the system worked perfectly.

    I have a theory that something has changed recently in the way the system goes to sleep.

    I have an old Thinkpad R61 running Antergos, which after a reboot this morning now goes to sleep (the moon symbol shows above the keyboard) which it has never done before, and when the power button is briefly pressed the system comes back to live but in doing so a blank screen shows with a cursor in the top left.

    I eventually left the lenovo after it had worked perfectly for 2 hours, then went back after 30 minutes or so and the problem had happened - blank screen.

    I suspect that something is going wrong with either going into sleep or suspended mode or whatever it is called, or coming out of it. Can you give me any info on how to diagnose this or how to prevent the system going into sleep mode or does this ring any bells on what is going wrong?


  • I tried to put my theory into practice by removing light locker and screen saver from startup applications, and in light locker settings set screensaver to never and enable light locker to off, plus in power settings automatic suspend off.

    About 3 hours later and the system is still running.

    I may have a workaround.

    If anyone can give me hints and tips I can try to diagnose further.

    Many thanks.

  • This post is deleted!
  • @dshankar689
    This is a community forum, where we try to help each other out on Antergos related problems, keep your clickbait to yourself.

  • This post is deleted!
system146 black84 cursor22 boots13 Posts 8Views 1121
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.