• [KDE Plasma] Meta Key Stopped Working but Alt+F1 Works Fine?


    My meta key on my keyboard worked completely fine up until about 20 minutes ago. I was able to use it just fine to open the Application Dashboard from Latte, but then upon reboot it stopped working. Alt+F1 works completely fine to activate it, but not the meta key. Any threads I’ve seen online are either still unresolved or setting Alt+F1 as the shortcut fixes their issue. I’ve seen people saying that they had to modify some KDE config file, but I don’t know what to edit. For those curious, the Application Dashboard meta key shortcut still doesn’t work when placed outside of the Latte Dock.

    The Meta key does not work anywhere on my desktop aside from Meta+Tab. Meta+` is a shortcut for Latte which is meant to open a dock that is set to autohide, and this shortcut does not work. The Meta+Tab shortcut is the only meta key shortcut that works.

    Can someone please give some guidance? Not being able to press my superkey and open the application dashboard is really frustrating. I’ve been used to this since Ubuntu 14.04, and I don’t want to change the habit of a lifetime to work around what I imagine is going to be a bug or my own user-error.

    Thanks!

    Never settle.

  • Hi @felinefowl. I just ran into this problem yesterday, myself. I found an answer (somewhere) that told me to do the following (and, make sure you make a backup of this file first in case anything goes bad).

    • Make sure you can see Hidden Files/Folders

    • Go into the .config folder

    • Find the file: kglobalshortcutsrc

    • Look for the following lines:
      activate widget 47=Alt+F1,none,Activate Unknown Widget
      activate widget 78=none,none,Activate Application Launcher Widget

    • Edit those two lines to read like this:
      activate widget 47=none,none,Activate Unknown Widget
      activate widget 78=Alt+F1,none,Activate Application Launcher Widget

    • Save the file, log out and log back in.

    It worked perfectly for me, too. I would set this correctly for each session in the Settings Manager, but they would get over written when I would restart.

    By the way, if you can’t get/keep Ctrl+Alt+t to open Konsole, this is the same file to edit. Look for:

    {1c2db381-7d3b-4422-a8be-91098dd40b77}=none,none,Run Konsole

    and change it to:

    {1c2db381-7d3b-4422-a8be-91098dd40b77}=Ctrl+Alt+T,none,Run Konsole

    It’s been working perfectly for me. Hope this helps.

    Just remember; if anything buggers up, use your backup file!

  • @adam-worth Thank you for the response. Unfortunately, it did not fix my problem. However it did point me in the direction of this configuration file, which I am currently looking around in to see if I can find anything. I didn’t have the exact same lines as you; instead, my line was under “[lattedock]” and it was “activate widget 13=none,none,Activate Application Dashboard Widget”. This has since changed to Widget 14, but I suspect that was because after it not working initially I removed the widget from the latte dock and added another Application Dashboard widget back. I tried adding “Alt+F1” as the shortcut for the Application Dashboard, and indeed Alt+F1 worked but not the Meta key. I even tried switching to the Application Launcher just to check if it was a bug perhaps with the Application Dashboard, but no luck. After changing the type to Application Launcher, then going back to Application Dashboard, the Widget number has changed to “16” now, in case that’s relevant at all.

    I did not have a line like “activate widget 47=none,none,Activate Unknown Widget” in my kglobalshortcutsrc file. Alt+F1 does not appear anywhere else in the file. Ctrl+Alt+T still works for me as normal.

    I’ll keep looking around and seeing if I can fix it. If anyone else has any suggestions please let me know. Thanks!

    Never settle.

  • @felinefowl Sorry that didn’t work. I hope you find your answer.

  • I “resolved” this issue by using a workaround. I installed a program called KSuperKey, which most places I found online said to avoid because Plasma supposedly has this built in now. I believe it tells Plasma that Alt+F1 was pressed when the meta key is pressed. I believe you can also configure what signal it sends and in what situation, so for instance it could send a different signal when the meta key is pressed in combination with another key such as the backtick for Latte Dock. However I have not looked into this myself.

    KSuperKey no longer seems to be in the official Arch repositories, however it’s in the AUR and as of posting it was updating in December 2017, which is recent enough for me. It was also the only package available through Pamac. I was able to run KSuperKey by running “ksuperkey” in Terminal. Then my meta key started working again like magic!

    To get KSuperKey to run at startup, I had to add it as an application. Right click on the Application Dashboard icon (by default, it’s the KDE “K” in a gear), and select “Edit Applications”. Then make a new item (I put mine in the “Utilities” category), give it a name like KSuperKey, set whatever description, comment and icon you want, and set the command as “ksuperkey” exactly like that; all lower case. Then go to Plasma settings, and look for “Startup and Shutdown.” Click on the “Add Program…” button, which should bring up a dialogue listing all of the applications and their categories. Look for wherever you saved the KSuperKey program (in my case, this was in Utilities > KSuperKey), and double click on it. Make sure under the “status” column that the checkbox says “Enabled.” It may also say “startup” under the “Run On” column, but this does not always appear for me, so don’t worry if it’s not there. Now ksuperkey is enabled and will run on startup!

    Bit of a hacky solution, but hopefully in a later version of Plasma this meta key issue is resolved once and for all.

    Never settle.

  • @felinefowl Congratulations! I tried that once, and it didn’t work for me. So, I went for another solution. I don’t use Latte Dock, so that might be part of what I experienced. Glad this worked for you, though. 🙂

  • @felinefowl You dont need any external applications in order to make META to work with Latte. You dont even need to use the Alt+F1 trick. You needs to happen is KWin to informed where to forward the META event.
    To do that you can read at: https://github.com/psifidotos/Latte-Dock/wiki/F.A.Q.#q-can-i-use-my-super-key-to-open-the-app-launcher

    The above is needed ONLY for the single META event. If you want to activate the rest META+… events of Latte you should go at
    Plasma System Settings -> Shortcuts -> Global Shortcuts -> Latte Dock and activate them if they arent already (they can be deactivated if they are already used by another application)

kde172 shortcuts11 latte-dock3 plasma 52 Posts 7Views 897
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.