I am using XFCE and I want it to always use Thunar as the file manager, but all my open/save dialogs in all programs (e.g. libreoffice, firefox, audacity) still come up with nautilus despite having removed nautilus. At one point I had budgie-desktop and nautilus installed. I have tried:

pacman -Rs nautilus budgie-desktop gnome-desktop
gio mime inode/directory Thunar.desktop 
xdg-mime default Thunar.desktop inode/directory 

Going into preferred applications and making sure it’s set to Thunar (including reinstalling nautilus, setting it to that, setting it back to thunar and removing nautilus again)

Editing the inode/directory lines of:
/home/matt/.local/share/applications/mimeinfo.cache
/usr/share/applications/mimeinfo.cache
/home/matt/.config/mimeapps.list
/home/matt/.local/share/applications/mimeapps.list
to inode/directory=Thunar.desktop;

setting /usr/share/dbus-1/services/org.freedesktop.FileManager1.service Exec line to /usr/bin/Thunar

That’s exhausted everything i could find by googling. Can anyone please tell me what to do?

Many Thanks