• Major problems with update to GNOME 3.28


    Hi!
    When I run the latest update, several applications will no longer start:

    [[email protected] ~]$ nautilus
    nautilus: symbol lookup error: /usr/lib/libpangoft2-1.0.so.0: undefined symbol: FcWeightFromOpenTypeDouble
    [[email protected] ~]$ gedit
    gedit: symbol lookup error: /usr/lib/libpangoft2-1.0.so.0: undefined symbol: FcWeightFromOpenTypeDouble
    [[email protected] ~]$ gnome-terminal
    gnome-terminal: symbol lookup error: /usr/lib/libpangoft2-1.0.so.0: undefined symbol: FcWeightFromOpenTypeDouble
    

    The same error appears with with other programs like geary and gnome-calendar.

    Downgrading pango to v 1.40.14-2 fixes this issue, but leaves me with several other errors:

    1. Certain applications won’t run due to other errors:
    [[email protected] ~]$ gnome-calendar
    GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message recipient disconnected from message bus without replying
    [[email protected] ~]$ deja-dup
    Speicherzugriffsfehler (Speicherabzug geschrieben) #"Memory access error"
    
    1. Several settings like system icons and the window size of Nautilus are changed

    And lastly: When I reboot, LightDM will either not start at all, or if it starts I’m unable to log in (will return to login screen).

    Other things I tried:

    • Excluding kernel and nvidia drivers from update
    • Switching to GDM, when LightDM would not load

    Any suggestions?

  • There are a few problems reported on this forum also on Gnome but the first thing you maybe need to do, like me, is to update now.
    On the update program, first “refresh databases” and then it will show the latest updates.
    I’ve had a few problems too, like settings and other programs not working and also update was not working, if you did not update databases manually or on the terminal with “pacman -Syyu”

  • I should also mention, that the package glib was installed and some of my problems with application startup were resolved by switching to glib2.

    @casquinhasjr
    I tried “sudo pacman -Syyu” before, but I thought it couldn’t hurt to try again.
    This time I also updated my mirrorlists and then ran the update.
    It seems to have resolved my issues.

    Thanks!

  • @dispi4 said in Major problems with update to GNOME 3.28:

    symbol lookup error: /usr/lib/libpangoft2-1.0.so.0: undefined symbol: FcWeightFromOpenTypeDouble

    i would check mirrors, may update is done fully… may one of your mirros is faulty, not synced correctly:

    to get the best archlinux mirrors use rankmirrors or fetchmirrors, for antergos mirrors you can use reflector-antergos script from manuel:

    pacman -U http://antergos.kamprad.net/antergos-packages/reflector-antergos-1.26-1-any.pkg.tar

    sudo fetchmirrors -q -s 16 -c DE 
    sudo reflector-antergos 
    yaourt -Syyua
    

    DE needs to be replaced with the short for your country!

    sudo pacman -U http://antergos.kamprad.net/antergos-packages/fetchmirrors-0.5-3-any.pkg.tar
    If you do not want to build from AUR

  • @joekamprad
    About reflector-antergos: nowadays it should be called like

    sudo reflector-antergos > /etc/pacman.d/antergos-mirrorlist
    

    since the new releases (since 1.22) no more support directing the output to the correct file.

    By the way, release 1.27 is out. :)

gnome327 3.287 major5 Posts 5Views 658
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.