• Others language such as Bangla, Arabi, Hindi etc. in all browser.


    I can not see the others language such as Bangla, Arabi, Hindi etc. in all browser.
    my locale info is below:

    [####@#### ~]$ locale
    LANG=C
    LC_CTYPE=“C”
    LC_NUMERIC=“C”
    LC_TIME=“C”
    LC_COLLATE=en_US.UTF-8
    LC_MONETARY=“C”
    LC_MESSAGES=“C”
    LC_PAPER=“C”
    LC_NAME=“C”
    LC_ADDRESS=“C”
    LC_TELEPHONE=“C”
    LC_MEASUREMENT=“C”
    LC_IDENTIFICATION=“C”
    LC_ALL=

    locale-gen :

    [####@#### ~]$ sudo locale-gen
    [sudo] password for rony:
    Generating locales…
    en_US.UTF-8… done
    bn_BD.UTF-8… done
    en_US.UTF-8… done
    Generation complete.
    0_1522256486634_language.png

  • https://wiki.archlinux.org/index.php/locale#Generating_locales

    Same on all sides or only this one?

    view-source:https://www.digitaloy.com/courses/all/

    source shows <!DOCTYPE html><html lang="en-US"

  • @joekamprad
    If you are using Chromium:

    • For Arabian/Persian/Turk language support:

    Option 1

    • Install via Add/Remove softwares the following fonts:
      gnu-free-fonts 20120503-4 (always good to have these fonts in linux)
      ttf-x2 1.0-1 (Arab, Perse, Kurd, Turk fonts …)

    • Type the following in your browser:
      chrome://settings/fonts
      Then change
      Standard font -> XB Niloofar
      Serif font -> XB Niloofar
      Sans-serif font -> FreeSans

    Option 2.
    Install via Add/Remove softwares the following fonts:
    ttf-ms-fonts 2.0-10 (Core ttf fonts from Microsoft)
    Then Chromium has a natural predisposition to use automatically MS Times New Roman which take care a lot of international languages (they are good for Arabic but not as good as ttf-x2 which are build for this language)

    Japanese / Chinese /Korean … etc Chromium language:
    Go to Add/Remove Softwares application and search for all packages starting with adobe-source and install everything.
    You will have full support in Chromium for these Asian Languages.

  • @ben_h ? it was not me asking here …

  • @joekamprad
    sorry for the inconvenience. I know you are the moderator here, but it was the mouse click on the last reply button that did it.

  • @ben_h o.k. no problem, and thanks come up with helping!

language33 others2 bangla1 arabi1 Posts 6Views 515
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.