• \[SOLVED\] Missing antergos.gpg


    I tried to find an answer to this but i’m stumped. I can’t seem to install anything or upgrade my system so i did this and get the following errors. How can I fix this? Thanks.

    [[email protected] ~]$ sudo pacman-key --init
    [sudo] password for chazdg50:
    [[email protected] ~]$ sudo pacman-key --populate archlinux antergos
    ==> ERROR: The keyring file /usr/share/pacman/keyrings/antergos.gpg does not exist.
    [[email protected] ~]$ sudo pacman-key --refresh
    gpg: refreshing 4 keys from hkp://pool.sks-keyservers.net
    gpg: requesting key 7AF1688B from hkp server pool.sks-keyservers.net
    gpg: requesting key 653C3094 from hkp server pool.sks-keyservers.net
    gpg: requesting key 7EDF681F from hkp server pool.sks-keyservers.net
    gpg: requesting key 4FA415FA from hkp server pool.sks-keyservers.net
    gpgkeys: key 9E7A1FB78EC5CD23E6F1B3AFC6CC33007AF1688B not found on keyserver
    gpg: key 653C3094: “Vi0L0 <[email protected]>” not changed
    gpg: key 7EDF681F: “Tobias Powalowski <[email protected]>” not changed
    gpg: key 4FA415FA: “Jan Alexander Steffens (heftig) <[email protected]>” not changed
    gpg: Total number processed: 3
    gpg: unchanged: 3
    [[email protected] ~]$ sudo pacman -Syyu
    :: Synchronizing package databases…
    core 110.7 KiB 1758K/s 00:00 [######################] 100%
    extra 1743.3 KiB 2.12M/s 00:01 [######################] 100%
    community 2.2 MiB 2.13M/s 00:01 [######################] 100%
    antergos 252.0 KiB 1457K/s 00:00 [######################] 100%
    catalyst 11.1 KiB 10.8M/s 00:00 [######################] 100%
    catalyst.sig 287.0 B 0.00B/s 00:00 [######################] 100%
    :: Starting full system upgrade…
    warning: antergos-mirrorlist: local (20140702-1) is newer than antergos (20140607-1)
    warning: numix-icon-theme: local (0.r159.7f88cbe-1) is newer than antergos (0.r157.d60c446-1)
    warning: numix-icon-theme-square: local (2014.07.02-1) is newer than antergos (2014.05.31-1)
    warning: package-query: local (1.4-1) is newer than antergos (1.3-1)
    warning: pacmanxg4: local (4.15.1-3) is newer than antergos (4.14.22-6)
    warning: ssx: local (2.1-1) is newer than antergos (1.8-1)
    warning: yaourt: local (1.5-1) is newer than antergos (1.4-1)
    resolving dependencies…
    looking for inter-conflicts…

    Packages (2): pixman-0.32.6-1 sysfsutils-2.1.0-9

    Total Installed Size: 0.88 MiB
    Net Upgrade Size: -0.04 MiB

    :: Proceed with installation? [Y/n] y
    (2/2) checking keys in keyring [######################] 100%
    downloading required keys…
    :: Import PGP key 2048R/, “Andreas Radke <[email protected]>”, created: 2011-05-14? [Y/n] y
    error: key “Andreas Radke <[email protected]>” could not be imported
    error: required key missing from keyring
    error: failed to commit transaction (unexpected error)
    Errors occurred, no packages were upgraded.
    [[email protected] ~]$

  • I tried to find an answer to this but i’m stumped. I can’t seem to install anything or upgrade my system so i did this and get the following errors. How can I fix this? Thanks.

    [[email protected] ~]$ sudo pacman-key --init
    [sudo] password for chazdg50:
    [[email protected] ~]$ sudo pacman-key --populate archlinux antergos
    ==> ERROR: The keyring file /usr/share/pacman/keyrings/antergos.gpg does not exist.
    [[email protected] ~]$ sudo pacman-key --refresh
    gpg: refreshing 4 keys from hkp://pool.sks-keyservers.net
    gpg: requesting key 7AF1688B from hkp server pool.sks-keyservers.net
    gpg: requesting key 653C3094 from hkp server pool.sks-keyservers.net
    gpg: requesting key 7EDF681F from hkp server pool.sks-keyservers.net
    gpg: requesting key 4FA415FA from hkp server pool.sks-keyservers.net
    gpgkeys: key 9E7A1FB78EC5CD23E6F1B3AFC6CC33007AF1688B not found on keyserver
    gpg: key 653C3094: “Vi0L0 <[email protected]>” not changed
    gpg: key 7EDF681F: “Tobias Powalowski <[email protected]>” not changed
    gpg: key 4FA415FA: “Jan Alexander Steffens (heftig) <[email protected]>” not changed
    gpg: Total number processed: 3
    gpg: unchanged: 3
    [[email protected] ~]$ sudo pacman -Syyu
    :: Synchronizing package databases…
    core 110.7 KiB 1758K/s 00:00 [######################] 100%
    extra 1743.3 KiB 2.12M/s 00:01 [######################] 100%
    community 2.2 MiB 2.13M/s 00:01 [######################] 100%
    antergos 252.0 KiB 1457K/s 00:00 [######################] 100%
    catalyst 11.1 KiB 10.8M/s 00:00 [######################] 100%
    catalyst.sig 287.0 B 0.00B/s 00:00 [######################] 100%
    :: Starting full system upgrade…
    warning: antergos-mirrorlist: local (20140702-1) is newer than antergos (20140607-1)
    warning: numix-icon-theme: local (0.r159.7f88cbe-1) is newer than antergos (0.r157.d60c446-1)
    warning: numix-icon-theme-square: local (2014.07.02-1) is newer than antergos (2014.05.31-1)
    warning: package-query: local (1.4-1) is newer than antergos (1.3-1)
    warning: pacmanxg4: local (4.15.1-3) is newer than antergos (4.14.22-6)
    warning: ssx: local (2.1-1) is newer than antergos (1.8-1)
    warning: yaourt: local (1.5-1) is newer than antergos (1.4-1)
    resolving dependencies…
    looking for inter-conflicts…

    Packages (2): pixman-0.32.6-1 sysfsutils-2.1.0-9

    Total Installed Size: 0.88 MiB
    Net Upgrade Size: -0.04 MiB

    :: Proceed with installation? [Y/n] y
    (2/2) checking keys in keyring [######################] 100%
    downloading required keys…
    :: Import PGP key 2048R/, “Andreas Radke <[email protected]>”, created: 2011-05-14? [Y/n] y
    error: key “Andreas Radke <[email protected]>” could not be imported
    error: required key missing from keyring
    error: failed to commit transaction (unexpected error)
    Errors occurred, no packages were upgraded.
    [[email protected] ~]$

  • Hi,

    Did you remove the “antergos-keyring” package? It appears you might have. Reinstall it and then reinitialize the keyring like you did previously and it should work like normal.

    sudo pacman -U http://repo.antergos.info/antergos/x86\_64/antergos-keyring-20130427-1-any.pkg.tar.xz
    

    Cheers!

  • @“lots.0.logs”:1128st0p said:

    Hi,

    Did you remove the “antergos-keyring” package? It appears you might have. Reinstall it and then reinitialize the keyring like you did previously and it should work like normal.

    sudo pacman -U http://repo.antergos.info/antergos/x86\_64/antergos-keyring-20130427-1-any.pkg.tar.xz
    

    Cheers![/quote:1128st0p]
    When you say ‘reinitialize’ the keyring, what does that mean? And you correct, I removed that keyring. I must say this is a very friendly Forum. Opensuse & Chakra can learn a lot from you guys.

  • Thanks
    sudo pacman-key --populate archlinux antergos[/code:344ftkby]

    Cheers!

  • @“lots.0.logs”:2gh4v4i3 said:

    Thanks

     sudo pacman-key --init
    )[/quote:2gh4v4i3]
    
    Rrrrrrrespeeeeeeect!!!!  
    

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 18.04 64bit Gnome
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @“lots.0.logs”:2hwa1i8n said:

    Thanks
    sudo pacman-key --populate archlinux antergos[/code:2hwa1i8n]

    Cheers!
    sudo pacman-key --init
    [[email protected] ~]$ sudo pacman-key --populate archlinux antergos
    ==> ERROR: The keyring file /usr/share/pacman/keyrings/antergos.gpg does not exist.
    [[email protected] ~]$ sudo pacman -U [http://repo.antergos.info/antergos/x86_64/antergos-keyring-20130427-1-any.pkg.tar.xz][0]">[http://repo.antergos.info/antergos/x86_][1] … pkg.tar.xz
    loading packages…
    error: ‘/var/cache/pacman/pkg/antergos-keyring-20130427-1-any.pkg.tar.xz’: invalid or corrupted package (PGP signature)
    [[email protected] ~]$

    I tried a few variations, but still seem stumped.

    [0]: <a href=
    [1]: http://repo.antergos.info/antergos/x86_

  • You need to install the keyring package before running the commands to initialize it. Its probably best to download the package first and then install it like this:

    wget http://repo.antergos.info/antergos/x86\_64/antergos-keyring-20130427-1-any.pkg.tar.xz  
    sudo pacman -U antergos-keyring-20130427-1-any.pkg.tar.xz  
    sudo pacman-key --init  
    sudo pacman --populate archlinux antergos
    

    Let me know if that solves it

    Cheers!

  • @“lots.0.logs”:1qwxkmgv said:

    You need to install the keyring package before running the commands to initialize it. Its probably best to download the package first and then install it like this:

    wget http://repo.antergos.info/antergos/x86\_64/antergos-keyring-20130427-1-any.pkg.tar.xz  
    > sudo pacman -U antergos-keyring-20130427-1-any.pkg.tar.xz  
    > sudo pacman-key --init  
    > sudo pacman --populate archlinux antergos
    

    Let me know if that solves it

    Cheers![/quote:1qwxkmgv]
    The first command wget… is not known. Yikes.

  • @“lots.0.logs”:3qnhsxni said:

    :lol: You can download it with your browser just [[b:3qnhsxni]CLICK HERE[/b:3qnhsxni][/url:3qnhsxni][/quote:3qnhsxni]
    Hmmm, I suspect that link isn’t working at the moment…

    Edit: I guess it’s too soon to talk about font rendering…

  • Hmm… It works fine for me?

    Okay, [THIS ONE[/url:33o91wne] or THIS ONE[/url:33o91wne]]0

  • @“lots.0.logs”:32f4oeu7 said:

    Hmm… It works fine for me?

    Okay, [THIS ONE[/url:32f4oeu7] or [THIS ONE[/url:32f4oeu7][/quote:32f4oeu7]
    Downloaded and got the following (I guess you can tell i know next to nothing about the ‘Arch Way’)!

    [[email protected] Downloads]$ sudo pacman -U antergos-keyring-20130427-1-any.pkg.tar.xz
    [sudo] password for chazdg50:
    loading packages…
    resolving dependencies…
    looking for inter-conflicts…

    Packages (1): antergos-keyring-20130427-1

    Total Installed Size: 0.02 MiB

    :: Proceed with installation? [Y/n] y
    (1/1) checking keys in keyring [######################] 100%
    (1/1) checking package integrity [######################] 100%
    (1/1) loading package files [######################] 100%
    (1/1) checking for file conflicts [######################] 100%
    (1/1) checking available disk space [######################] 100%
    (1/1) installing antergos-keyring [######################] 100%
    ==> Appending keys from antergos.gpg…
    ==> Locally signing trusted keys in keyring…
    -> Locally signing key EC3B5CE8FE98DFDF51B705536D6DDA3D2A45C7B4…
    ==> Importing owner trust values…
    gpg: inserting ownertrust of 4
    ==> Updating trust database…
    gpg: 3 marginal(s) needed, 1 complete(s) needed, PGP trust model
    gpg: depth: 0 valid: 1 signed: 1 trust: 0-, 0q, 0n, 0m, 0f, 1u
    gpg: depth: 1 valid: 1 signed: 0 trust: 0-, 0q, 0n, 1m, 0f, 0u
    [[email protected] Downloads]$ sudo pacman-key --init
    [[email protected] Downloads]$ sudo pacman --populate archlinux antergos
    pacman: unrecognized option ‘–populate’
    [[email protected] Downloads]$

    Edit: [b:32f4oeu7][u:32f4oeu7]sudo pacman -h gives me the following options:[/u:32f4oeu7][/b:32f4oeu7]

    sudo pacman -h
    usage: pacman <operation> […]
    operations:
    pacman {-h --help}
    pacman {-V --version}
    pacman {-D --database} <options> <package(s)>
    pacman {-Q --query} [options] [package(s)]
    pacman {-R --remove} [options] <package(s)>
    pacman {-S --sync} [options] [package(s)]
    pacman {-T --deptest} [options] [package(s)]
    pacman {-U --upgrade} [options] <file(s)>

    use ‘pacman {-h --help}’ with an operation for available options]1]0

  • The last command you entered was incorrect. its pacman-key (not pacman):

    sudo pacman-key --populate archlinux antergos
    

    CHeers!

    EDIT**

    PS> I see that it was my typo that you were copy pasting from. In my defense I did type it correctly the first two times

  • @“lots.0.logs”:tc8c4gd8 said:

    The last command you entered was incorrect. its pacman-key (not pacman):

    sudo pacman-key --populate archlinux antergos
    

    CHeers!

    EDIT**

    PS> I see that it was my typo that you were copy pasting from. In my defense I did type it correctly the first two times
    Thanks for your help! I should noticed that. When checking for updates I did get this in my Terminal:

    (3/5) upgrading pacman-mirrorlist [######################] 100%
    warning: /etc/pacman.d/mirrorlist installed as /etc/pacman.d/mirrorlist.pacnew

    I assume this reflects the Antergos keyring I just installed, otherwise, I assume everything is ok.

    Do you guys want me to mark threads as solved?

  • That is not from anything you did. Whenever a package has a config file that changed pacman will save it as .pacnew so you can review the changes and keep your current version if you want

    Cheers!

  • @“lots.0.logs”:59z601cp said:

    That is not from anything you did. Whenever a package has a config file that changed pacman will save it as .pacnew so you can review the changes and keep your current version if you want

    Cheers![/quote:59z601cp]
    Thank you for all your help. I love this community.

Posts 17Views 6294
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.