• NVIDIA Issues


    I’ve never used a dedicated GPU before. My friend insisted on gifting me a GTX 760. I’m having issues with screen tearing. I installed drivers from the wiki: https://antergos.com/wiki/hardware/graphics/antergos-nvidia-installer-2/

    [[email protected] ~]$ lspci -k | grep -A 2 -E "(VGA|3D)"
    00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06)
    	Subsystem: Gigabyte Technology Co., Ltd Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller
    	Kernel driver in use: i915
    --
    01:00.0 VGA compatible controller: NVIDIA Corporation GK104 [GeForce GTX 760] (rev a1)
    	Subsystem: eVga.com. Corp. GK104 [GeForce GTX 760]
    	Kernel driver in use: nvidia
    
    

    and

    [[email protected] ~]$ glxinfo | grep OpenGL
    OpenGL vendor string: NVIDIA Corporation
    OpenGL renderer string: GeForce GTX 760/PCIe/SSE2
    OpenGL core profile version string: 4.5.0 NVIDIA 390.42
    OpenGL core profile shading language version string: 4.50 NVIDIA
    OpenGL core profile context flags: (none)
    OpenGL core profile profile mask: core profile
    OpenGL core profile extensions:
    OpenGL version string: 4.6.0 NVIDIA 390.42
    OpenGL shading language version string: 4.60 NVIDIA
    OpenGL context flags: (none)
    OpenGL profile mask: (none)
    OpenGL extensions:
    OpenGL ES profile version string: OpenGL ES 3.2 NVIDIA 390.42
    OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
    OpenGL ES profile extensions:
    
    

    This is my /etc/X11/xorg.conf.d/20-nvidia.conf

    Section "Device"
        Identifier "Nvidia Card"
        Driver "nvidia"
        VendorName "NVIDIA Corporation"
        Option "NoLogo" "true"
    EndSection
    

    I have nvidia-settings GUI installed. I’m trying to fix the screen tearing issue with

    Option         "metamodes" "nvidia-auto-select +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}"
    

    If i place this line under ‘Screen’ in either the 20-nvidia.conf file or the nvidia-settings save and generate xorg.conf file, i end up logging into a blank screen and mouse pointer. I’m forced to drop into a TTY and comment out the above in order to boot into my XFCE graphical environment.
    Here is my /etc/X11/xorg.conf

    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig:  version 390.42  ([email protected])  Sat Mar  3 04:40:24 PST 2018
    
    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings:  version 390.42  ([email protected])  Thu Mar 15 01:55:17 CET 2018
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
        Option         "Xinerama" "0"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "BenQ GL2460"
        HorizSync       30.0 - 83.0
        VertRefresh     50.0 - 76.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce GTX 760"
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "Stereo" "0"
    #   Option         "metamodes" "nvidia-auto-select +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}"
        Option         "SLI" "Off"
        Option         "MultiGPU" "Off"
        Option         "BaseMosaic" "off"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    
    

    I have been able to fix the screen tearing by setting up a Session Startup command in XFCE, but this seems like a kluge. I would prefer to have this in a .conf file.

    Issue #2: I’m also have significant freezing while playing Team Fortress on Steam. I have a Haswell i3-4370, 8G RAM, and a EVGA 550 Supernova G2, powering 3 SSD, and a keyboard/mouse. Do I have a large enough PS and hardware spec to play this basic 3D game? I don’t know. I’m new to gaming/GPU stuff. 2D stuff plays fine.

  • NVIDIA says the minimum spec PS for the GTX 760 is 500W.

  • @triode13 said in NVIDIA Issues:

    /etc/X11/xorg.conf

    better use conf files under /etc/X11/xorg.conf.d …

    i have this inside my /etc/X11/xorg.conf.d/20-nvidia.conf

    Section "Device"
        Identifier "Nvidia Card"
        Driver "nvidia"
        VendorName "NVIDIA Corporation"
        Option "NoLogo" "true"
    EndSection
    
    Section "Screen"
            Identifier      "nvidia"
            Option         "metamodes" "nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"
    
            Option          "TripleBuffer"                  "on"
            Option          "AllowIndirectGLXProtocol"      "off"
    EndSection
    
    

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • a full xorg.conf is not needed and can cause more problems then solving

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • I changed my /etc/X11/xorg.conf.d/20-nvidia.conf to the same and i still get a blank screen with a mouse.

    My /etc/X11 folder contains a xinit and xorg.conf.d subfolders. Am i missing anything?

    My xorg.conf.d folder has 00-keyboard.conf, 20-nvidia.conf, 50-synaptics.conf, and 99killX.conf. Am I missing anything?

  • and /etc/X11/xorg.conf is removed?

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • cat /var/log/Xorg.0.log | curl -F [email protected] https://ptpb.pw/?u=1
    

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad yes. removed.

    [[email protected] ~]$ cat /var/log/Xorg.0.log | curl -F [email protected] https://ptpb.pw/?u=1
    https://ptpb.pw/r6V5
    [[email protected] ~]$ 
    
    
  • @triode13 said in NVIDIA Issues:

    https://ptpb.pw/r6V5

    6 displays? …

    shows only BenQ GL2460 (DFP-3): as connected …

    Do not look like that your 20-nvidia.conf is used at all…

    I get this:

     cat /var/log/Xorg.0.log | grep ForceFullCompositionPipeline
    [   288.787] (**) NVIDIA(0): Option "MetaModes" "nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"
    [   288.859] (II) NVIDIA(0):     "nvidia-auto-select+0+0{ForceFullCompositionPipeline=On}"
    [   288.894] (II) NVIDIA(0): Setting mode "nvidia-auto-select+0+0{ForceFullCompositionPipeline=On}"
    [   289.203] (II) NVIDIA(0): Setting mode "VGA-0: nvidia-auto-select @1280x1024 +0+48 {ViewPortIn=1280x1024, ViewPortOut=1280x1024+0+0, ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}"
    [   289.286] (II) NVIDIA(0): Setting mode "VGA-0: nvidia-auto-select @1280x1024 +0+48 {ViewPortIn=1280x1024, ViewPortOut=1280x1024+0+0, ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}, HDMI-0: nvidia-auto-select @1920x1080 +1280+0 {ViewPortIn=1920x1080, ViewPortOut=1920x1080+0+0, ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}"
    

    Black_screen_on_systems_with_Intel_integrated_GPU

    Do you have taken a look at the EFI/BIOS settings? may you have an option to disable intergrated GPU or follow up what the wiki say about blacklisting inteldriver

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • here’s my /etc/modprobe.d/blacklist.conf

    install i915 /usr/bin/false
    install intel_agp /usr/bin/false
    install viafb /usr/bin/false
    
    
    

    i’ll check BIOS.

  • disabled Intel Integrated Graphics in EFI/BIOS and still getting black screen. And still getting

    [[email protected] ~]$ cat /var/log/Xorg.0.log | curl -F [email protected] https://ptpb.pw/?u=1
    https://ptpb.pw/r6V5
    [[email protected] ~]$ 
    
  • @triode13 said in NVIDIA Issues:

    disabled Intel Integrated Graphics in EFI/BIOS and still getting black screen. And still getting

    [[email protected] ~]$ cat /var/log/Xorg.0.log | curl -F [email protected] https://ptpb.pw/?u=1
    https://ptpb.pw/r6V5
    [[email protected] ~]$ 
    

    cat /var/log/Xorg.0.log to see the log inside your terminal

    cat /var/log/Xorg.0.log | curl -F [email protected] https://ptpb.pw/?u=1upload the log to a pastebin, and the url is a link to it …

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad said in NVIDIA Issues:

    cat /var/log/Xorg.0.log | curl -F [email protected] https://ptpb.pw/?u=1

    Here you go: https://ptpb.pw/9vm5

  • https://wiki.archlinux.org/index.php/NVIDIA/Troubleshooting#Blackscreen_at_X_startup_.2F_Machine_poweroff_at_X_shutdown
    So i amended my kernel parameters with rcutree.rcu_idle_gp_delay=1. It only worked for one reboot, but if I leave “metamodes” “nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }” commented inside 20-nvidia.conf and run the command in Session and Startup, I am able to boot into my XFCE DE. Before any configuration failed unless the “metamodes…” was uncommented.

    Team Fortress doesn’t require much GPU. In fact, my wimpy laptop with integrated Intel graphics plays it just fine and on a Steam game server connected via wifi. I still have some freezing on my desktop/NVIDIA, but not nearly as bad. I still don’t believe my NVIDIA is working 100%, but better.

    It appears I’m not the only one having this problem. Even one guy using Arch and XFCE is have the identical problem (post #11): https://devtalk.nvidia.com/default/topic/1029381/linux/black-screen-at-desktop-login-gtx-750-ti-390-25-/post/5239770/

    Also, how do I correctly add the nvidia module to mkinitcpio.conf? The wiki isn’t clear to me if i need to throw a command after editing the file.

    Thanks for everyone’s help!

  • As far as I know adding Nvidia to modules inside mkinitcpio.conf is not needed anymore, but if you do changes inside this file you need to rebuild with the command: mkinitcpio - p linux

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • Should be mkinitcpio -p linux

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @judd said in NVIDIA Issues:

    0_1522515967115_kkkkkk.png

    I am not sure if this is useful… As Nvidia mostly updates together with kernel.

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

nvidia138 issues79 Posts 22Views 901
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.