• key repeats and an unresponsive wayland


    In the last few days I’ve noticed unexpected key repeats. For instance, I focus the location bar in Firefox and type ‘a’, there’s a brief delay, then some milliseconds later I have twenty 'a’s. This is not from holding the key down, but just a single key press and quick release. In journalctl I see messages like these:

    Mar 26 21:59:14 tpy org.gnome.Shell.desktop[6017]: Key repeat discarded, Wayland compositor doesn't seem to be processing events fast enough!
    Mar 26 21:59:14 tpy org.gnome.Shell.desktop[6017]: Key repeat discarded, Wayland compositor doesn't seem to be processing events fast enough!
    Mar 26 21:59:14 tpy org.gnome.Shell.desktop[6017]: Key repeat discarded, Wayland compositor doesn't seem to be processing events fast enough!
    Mar 26 21:59:14 tpy org.gnome.Shell.desktop[6017]: libinput error: client bug: timer event8 keyboard: offset negative (-205ms)
    Mar 26 21:59:14 tpy org.gnome.Shell.desktop[6017]: libinput error: client bug: timer event8 keyboard: offset negative (-107ms)
    

    Worse, Wayland has become completely unresponsive due to this (I presume). Mouse cursor wouldn’t move; I couldn’t even switch to another TTY. After a hardware reset, journalctl reported hundreds of those Key repeat discarded messages before the hard reset. It appears to be the same as this bug (which is now closed): https://bugs.archlinux.org/task/52969. Unlike some commenters there, I was not typing Japanese at the time.

    I’m having some other issues, like parts of my home directory being mounted read-only occasionally, so perhaps there’s something more systemic. But otherwise, where else can I look for possible causes?

  • @goodman-m-w
    Let’s set your /home direcectory with the correct permissions first.
    chmod -R 0755 /home/goodman-m-w/
    Secondly, I take it you were looking / reading this page
    link text

  • Oops. Never mind about the link. I see that you posted it already in your initial post.

    are you experiencing crashes like some of the posters in that thread?

  • Thanks. Actually my home directory is usually set with the right permissions. It seems to be an intermittent issue; e.g., I open up a .tex file and start typing, but when I try to save the editor complains that the file is read only, the same file I edited and saved an hour prior. I just chmod -R u+w in that directory in order to save my files, but upon restart it seems the original permissions are restored (there and elsewhere). I think this issue is unrelated to the first, but I mentioned it in case both are symptoms of a similar underlying issue.

    I have not (yet) experienced the crashes that Mike Appleby reported (i.e. where the machine automatically restarts) toward the end of the ArchLinux bug report, but I have experienced the unresponsive system that he and others reported earlier.

  • hi again. Terribly sorry for my tardy relply. I’m not always online and hence, not always here on the board.

    I’ve had a look around the net.
    Is your CPU overloaded while this happens?

    Also, just to go back to the link you provided earlier, have you considered a libinput error?

    Also, I was reading that an error similiar to yours is a symptom of the stalled system. But the question then becomes what causes the stalled system?
    High CPU? Something else perhaps?

    Sorry that I don’t have a complete or more comprehensive answer for you but the questions posed are to help weed things out.

  • Hi, thanks for following up.

    I don’t believe my CPU is overloaded. E.g., I have maybe 5 tabs open in a browser and nothing else but an idle terminal open, and when I ctrl-w to close a tab, it repeats (presumably the ‘w’) and closes all of them.

    I think a libinput error is likely, because I also notice my cursor stalling (trackpoint, touchpad, maybe also usb mouse). I see these errors in journalctl for the mouse:

    Apr 01 23:08:50 tpy org.gnome.Shell.desktop[5970]: libinput error: client bug: timer event7 trackpoint: offset negative (-54ms)
    Apr 01 23:08:50 tpy org.gnome.Shell.desktop[5970]: libinput error: client bug: timer event6 debounce: offset negative (-249ms)
    Apr 01 23:08:50 tpy org.gnome.Shell.desktop[5970]: libinput error: client bug: timer event6 debounce: offset negative (-157ms)
    Apr 01 23:08:50 tpy org.gnome.Shell.desktop[5970]: libinput error: client bug: timer event6 debounce short: offset negative (-170ms)
    

    and

    Apr 01 23:11:44 tpy kernel: psmouse serio1: Touchpad at isa0060/serio1/input0 lost sync at byte 6
    Apr 01 23:11:44 tpy kernel: psmouse serio1: issuing reconnect request
    

    An additional data point, if it matters: some of the commenters on the link said they were typing Japanese at the time. I wasn’t typing Japanese, but I did try to install ibus-mozc, then later fcitx, but I couldn’t get either working and gave up for the time being. I wonder if any lingering IME config is interfering with input?

    Also, it seems to happen mostly when I execute a keyboard shortcut, like ctrl-tab (switch tab) or ctrl-alt-T (open terminal), or when i switch to a text input (e.g., ctrl-L to jump to the address bar, then the next key I type sometimes repeats ~10-20 times. I don’t notice it while typing normally (e.g., this reply).

  • Hi again @goodman-m-w
    I had a look at the secondary link from the primary link you gave earlier.
    This one here link text

    Specifically this comment here

    “Physical buttons experience wear-and-tear with usage…This effect
    can cause the button to send multiple events within a short time frame,…Note that libinput’s debouncing intended to correct hardware damage…”

    but I don’t know if this is always relevant. that is, that hardware wear and tear is always the primary culprit.
    It might or might not be the case with your situation.

    So have you recieved an update to libinput, then on your computer?
    I would think that you may have.

  • Thanks for looking into it further.

    I was concerned about hardware issues, too, but (1) the laptop isn’t that old; (2) I don’t see repeated keypresses in all contexts (mostly on keyboard shortcuts and after keyboard shortcuts); (3) it also affects the mouse; and (4) it also affects my bluetooth and usb keyboards.

    Is there a way to ensure that my libinput configuration is clean, or are there any other packages I should/should-not have installed?

  • This post is deleted!
  • Hi again. If your laptop is new then no further worries then.
    About your libinput config, your system ensures it’s sett up properly and cleanly.
    If your really interest, the Arch wiki has a page on libinput.
    I didn’t see anything in man g settings. Unless you want to try the reset option.
    I doubt that’s of any help though.

  • As for additional packages. Nope.
    libinput is for hardware input.

    question. is it still acting strangely?

  • @modisc said in key repeats and an unresponsive wayland:

    As for additional packages. Nope.
    libinput is for hardware input.

    question. is it still acting strangely?

    Thanks for the suggestions. It is still acting strangely. I’m not sure what else to try, so I’m going to back up my stuff and do a full re-install, as this problem is more than just annoying. I don’t want to live in fear that closing a single tab in a browser will close all of them and cause me to lose work.

    Unless others say it affects them, too, maybe we can consider this an isolated incident? But I shouldn’t speak too soon; I may be back here after the re-install.

    Cheers

  • I installed Pop!_OS and the problem has gone away. This way is not very scientific; re-installing Antergos would help determine if the issue came up in the base config or if it was due to changes I made, but at least I know it’s not a hardware issue.

    I kinda miss the bleeding edge Arch repos, but I need something a bit more stable for now so I can get my work done.

    Thanks again for the help!

  • Hi again @goodman-m-w
    I’m terribly sorry for my tardy reply as I’m not always online here on the forums.

    If the Ubuntu based system works for you rather than the arch based then most certainly it would be a better fit for you over Antergos 🙂

  • No need to apologize, @Modisc. I appreciate your help. I used and contributed to Arch for a couple years, mostly happily, and Antergos was also nice (and the community is generally more friendly than with Arch).

    Pop!_OS isn’t without its problems (I’ve already filed a bug), but so far the problems aren’t as disruptive as the key-repeat one, so I think this will work for me for now.

  • Apart from switching to Xorg or changing distro, is there any clue as to how to solve the issue?

wayland48 key18 unresponsive4 repeats1 Posts 16Views 879
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.