• Setting will not open


    Clean install on Gnome Antergos. Lots installed. Settings will not open. The mouse just spins.

  • I have the same issue. I guess it happened today when I update all the gnome packages.
    If I give the command “gnome-control-center” from the terminal I get this error:

    Failed to register: Timeout was reached
    

    after 30 seconds and the application does not start.

  • wayland or x11?

    echo $XDG_SESSION_TYPE
    

    [updates once a week] = [90% less problems]
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    help development: donate antergos

  • I am using wayland and I am actually thinking that is the cause.
    However, I have automatic login and at the moment I do not know how to switch to Xorg if not passing through the GDM login screen.

  • Just go to your account settings (the one where you can also change your avatar) and uncheck automatic log in.
    Reboot and choose Gnome on Xorg in the GDM menu.

    KDE/XFCE/i3-WM

    Everybody is a genius, but if you judge a fish by its ability to climb a tree, it will live its whole life believing its stupid.

  • 0_1522138327124_Bildschirmfoto vom 2018-03-27 10-11-38.png

    [updates once a week] = [90% less problems]
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    help development: donate antergos

  • @bryanpwo

    This is exactly the issue: I cannot open the settings app. Thus, this means I cannot neither go to my account settings to disable the autologin.

  • I had the same problem and have looked to Win10 already ;-).
    I have solved it by using a second account (fortunately there was one already). Open the settings in the second account, close it. After that the settings were accessible on the first account also.

    Good luck…!

    (But that should not happen - access to the settings is quite important…)

  • @Garret
    You can try the following in the terminal:

    sudo nano /etc/gdm/custom.conf

    Then go to the line:

    AutomaticLoginEnable=true

    and change that one in:

    AutomaticLoginEnable=false

    Close and reboot.

    KDE/XFCE/i3-WM

    Everybody is a genius, but if you judge a fish by its ability to climb a tree, it will live its whole life believing its stupid.

  • I will try this later when I am at home. However, I would like to understand why this happens and if it is a bug of gnome.

    It is not normal as @kahlo said that one cannot access the settings.

    @kahlo, unfortunately I do not have another account and still not have access to the login screen anyways.

  • It might have to do with the new Gnome update that’s been released two days ago in Arch.

    KDE/XFCE/i3-WM

    Everybody is a genius, but if you judge a fish by its ability to climb a tree, it will live its whole life believing its stupid.

  • @bryanpwo I managed to disable the autologin as you wrote. However, even by logging with Gnome on Xorg, the control center does not open:

    [[email protected] ~]$ gnome-control-center 
    Failed to register: Timeout was reached
    [[email protected] ~]$ 
    
  • @garret said in Setting will not open:

    gnome-control-center

    gnome-control-center -v will be more verbose on output

    [updates once a week] = [90% less problems]
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    help development: donate antergos

  • https://bbs.archlinux.org/viewtopic.php?id=235651

    [updates once a week] = [90% less problems]
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    help development: donate antergos

  • You can type in the terminal

    kilall gnome-control-center

    then start it again.

    KDE/XFCE/i3-WM

    Everybody is a genius, but if you judge a fish by its ability to climb a tree, it will live its whole life believing its stupid.

  • It’s

    killall gnome-control-center

    made a typo

    KDE/XFCE/i3-WM

    Everybody is a genius, but if you judge a fish by its ability to climb a tree, it will live its whole life believing its stupid.

  • i just install 3 optional dependencies for gnome-control-center + reinstall itself, and it starts without lagging

    sudo pacman -S vino rygel gnome-user-share gnome-control-center

    [updates once a week] = [90% less problems]
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    help development: donate antergos

  • –mark as duplicate now–
    go here to have disussion at one place:

    https://forum.antergos.com/topic/9545/gnome-3-28-settings-manager-bug/5

    –closing–

    [updates once a week] = [90% less problems]
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    help development: donate antergos

Posts 18Views 970
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.