• Bluetooth stop working


    Mär 25 21:22:18 empowered64 systemd-coredump[21160]: Process 328 (bluetoothd) of user 0 dumped core.
                                                          
                                                          Stack trace of thread 328:
                                                          #0  0x0000555f6c9befd0 btd_adv_manager_refresh (bluetoothd)
                                                          #1  0x0000555f6c9cb6c4 n/a (bluetoothd)
                                                          #2  0x0000555f6c9fc049 n/a (bluetoothd)
                                                          #3  0x0000555f6c9fcb9e n/a (bluetoothd)
                                                          #4  0x0000555f6ca095c3 n/a (bluetoothd)
                                                          #5  0x00007f0700ad42c6 g_main_context_dispatch (libglib-2.0.so.0)
                                                          #6  0x00007f0700ad46a1 n/a (libglib-2.0.so.0)
                                                          #7  0x00007f0700ad49d2 g_main_loop_run (libglib-2.0.so.0)
                                                          #8  0x0000555f6c978709 n/a (bluetoothd)
                                                          #9  0x00007f06ffda5f4a __libc_start_main (libc.so.6)
                                                          #10 0x0000555f6c97904a n/a (bluetoothd)
    

    this haapens if i want to open bluetooth configuration from Gnome.

    Bluetooth crashed immediately also after try to restart it:

    ● bluetooth.service - Bluetooth service
       Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: disabled)
       Active: failed (Result: core-dump) since Sun 2018-03-25 21:22:18 CEST; 2min 4s ago
         Docs: man:bluetoothd(8)
      Process: 328 ExecStart=/usr/lib/bluetooth/bluetoothd (code=dumped, signal=SEGV)
     Main PID: 328 (code=dumped, signal=SEGV)
       Status: "Running"
    
    Mär 25 20:35:14 empowered64 systemd[1]: Starting Bluetooth service...
    Mär 25 20:35:14 empowered64 bluetoothd[328]: Bluetooth daemon 5.49
    Mär 25 20:35:14 empowered64 systemd[1]: Started Bluetooth service.
    Mär 25 20:35:14 empowered64 bluetoothd[328]: Starting SDP server
    Mär 25 20:35:14 empowered64 bluetoothd[328]: Bluetooth management interface 1.14 initialized
    Mär 25 20:37:19 empowered64 bluetoothd[328]: Endpoint registered: sender=:1.62 path=/MediaEndpoint/A2DPSource
    Mär 25 20:37:19 empowered64 bluetoothd[328]: Endpoint registered: sender=:1.62 path=/MediaEndpoint/A2DPSink
    Mär 25 21:22:18 empowered64 systemd[1]: bluetooth.service: Main process exited, code=dumped, status=11/SEGV
    Mär 25 21:22:18 empowered64 systemd[1]: bluetooth.service: Failed with result 'core-dump'.
    

    a bug report is there already:

    https://bugs.archlinux.org/task/57939?string=bluez&project=1&type[0]=&sev[0]=&pri[0]=&due[0]=&reported[0]=&cat[0]=&status[0]=open&percent[0]=&opened=&dev=&closed=&duedatefrom=&duedateto=&changedfrom=&changedto=&openedfrom=&openedto=&closedfrom=&closedto=

    I got this on most of my dongles.

    Someone too???

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad said in Bluetooth stop working:

    Someone too???

    Negative, sir.

    Normally, I’m using my tablet’s detacbable bluetooth keyboard with most of laptops here (it has all layouts I use most frequently).

    I’m typing in this text on this bluetooth keyboard right now, in Antergos Gnome 3.28, without a problem.

    To test Gnome 3.28 Bluetooth further, I disconnected the external keybaord, and paired the laptop with external bluetooth audio system. And now enjoying the lovely Elegy by Jethro Tull from Gnome 3.28 via Bluetooth on it. It’s a serious, powerfull audio system, not a laptop’s beeper.

    So far, there are no problems with Bluetooth here. Bluetooth continues to work normally.

  • [ 5879.022512] Bluetooth: hci0: last event is not cmd complete (0x0f)
    [ 5879.040046] bluetoothd[5053]: segfault at 8 ip 000055bbdcd72fd0 sp 00007fff3a75f3a8 error 4 in bluetoothd[55bbdcd0f000+f8000]

    I for once could see my laptop but then not anymore. In the laptop I cannot see my phone. And BT is enabled because I see it ON and I have a blue light on the laptop. But not working.

  • Just noticed on systemctl:

    ● bluetooth.service loaded failed failed Bluetooth service

    ps: yes, it’s me, casquinhas… had to create another account because of the mail

  • @just said in Bluetooth stop working:

    Gnome 3.28

    My Bluetooth headphone are working fine here with Gnome 3.28

  • seems to happen to some sorts of chipsets only.
    I have 3 here and one of them working, only pushing
    Bluetooth: hci0: last event is not cmd complete (0x0f)repeatly onto journal

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad said in Bluetooth stop working:

    i want to open bluetooth configuration from Gnome.

    On my Acer:
    [ 7654.967000] bluetoothd[7282]: segfault at 8 ip 0000558692043fd0 sp 00007ffdb68cab58 error 4 in bluetoothd[558691fe0000+f8000]
    [[email protected] Documents]# bluetoothctl
    Waiting to connect to bluetoothd…

    Bluetooth not working. Then I tried it on my Toshiba, running Xfce and it works. Both with full updates, one Gnome other Xfce.

  • seems also related to gnome-bluetooth “stack” on xfce you can use blueman or blueberry…

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • I feel for you the problem seems to related to the fact that Bluetooth is constantly scanning for more Bluetooth devices…
    If i open the setting panel using Gnome desktop while listening to music and click on the Bluetooth setting the sound goes really bad pops and interference.
    On closing the setting panel sound goes back to normal.
    I reinstall Antergos Grome from Antergos Deepin just for this very reason. I could not stop sound interference with Bluetooth using the Deepin desktop, was like the setting panel would never close on Deepin. (sorry not much help)

  • I found this on MX linux forum maybe could be a help to someone…

    We have had a few reports of problems with enabling bluetooth, and would like anyone experiencing that to try two possible solutions, one at a time. Report back in this thread.

    DO THIS FIRST: Update and change a setting in tlp

    1. Use MX Package Installer > Full App Catalog > Debian Backports to install two packages: {This software is available on antergos as well.}

    tlp
    tlp-rdw

    1. Navigate to /etc/default/ and right-click the file tlp > Edit as Root

    2. Search and find the line

    Code: Select all
    USB_BLACKLIST_BTUSB=0
    and change it to

    Code: Select all
    USB_BLACKLIST_BTUSB=1

    1. Save the file and reboot the computer.

    2. Test BT functionality. Might want to start with Bluetooth Manager, searching for and pairing with hardware as needed.

    3. Occasionally one finds some people saying they needed to remove tlp completely before the problem was solved.


    DO THIS SECOND, IF NECESSARY: Insert exact device ID

    1. Open a console and enter

    Code: Select all
    lsusb | grep -i bluetooth
    . You will see something like this:

    $ lsusb|grep -i bluetooth
    Bus 003 Device 002: ID 0a5c:2198 Broadcom Corp. Bluetooth 3.0 Device
    
    1. Navigate to /etc/bluetooth/ and open as root the file main.conf

    2. Locate the following stanza (lines 27-31):

    Code: Select all

    Use vendor id source (assigner), vendor, product and version information for

    DID profile support. The values are separated by “:” and assigner, VID, PID

    and version.

    Possible vendor id source values: bluetooth, usb (defaults to usb)

    #DeviceID = bluetooth🔢5678:abcd
    That last line could be uncommented with the correct values substituted from lsusb output

    1. Delete the commenting mark (#) and substitute what you found in step 1) --what I bolded above. In my case, this would give:

    Code: Select all
    DeviceID = bluetooth:0a5c:2198 Broadcom Corp. Bluetooth 3.0 Device

    1. Save and reboot, then test.
  • I had bluetooth issues on both of my laptops which started after bluez was updated to 5.49-2 I downgraded the package to the previous version using
    "sudo pacman -U /var/cache/pacman/pkg/bluez-5.48-2-x86_64.pkg.tar.xz".

    Bluetooth now works again.
    HTH

  • @ozy said in Bluetooth stop working:

    lsusb|grep -i bluetooth

    I am suffering through this, and have been since Gnome 3.26 technically.

    Output:

    
        [[email protected] ~]$ systemctl status bluetooth.service
        ● bluetooth.service - Bluetooth service
           Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: disabled)
           Active: active (running) since Sun 2018-04-08 16:12:10 CDT; 7h ago
             Docs: man:bluetoothd(8)
         Main PID: 723 (bluetoothd)
           Status: "Running"
            Tasks: 1 (limit: 4915)
           Memory: 1.2M
           CGroup: /system.slice/bluetooth.service
                   └─723 /usr/lib/bluetooth/bluetoothd
        
        Apr 08 18:52:19 aahmad-pc bluetoothd[723]: Endpoint registered: sender=:1.43 path=/MediaEndpoint/A2DPSource
        Apr 08 18:52:19 aahmad-pc bluetoothd[723]: Endpoint registered: sender=:1.43 path=/MediaEndpoint/A2DPSink
        Apr 08 18:52:19 aahmad-pc bluetoothd[723]: Endpoint registered: sender=:1.63 path=/MediaEndpoint/A2DPSource
        Apr 08 18:52:19 aahmad-pc bluetoothd[723]: Endpoint registered: sender=:1.63 path=/MediaEndpoint/A2DPSink
        Apr 08 18:52:20 aahmad-pc bluetoothd[723]: Failed to set mode: Blocked through rfkill (0x12)
        Apr 08 18:52:20 aahmad-pc bluetoothd[723]: Failed to set mode: Blocked through rfkill (0x12)
        Apr 08 18:55:11 aahmad-pc bluetoothd[723]: Endpoint unregistered: sender=:1.43 path=/MediaEndpoint/A2DPSource
        Apr 08 18:55:11 aahmad-pc bluetoothd[723]: Endpoint unregistered: sender=:1.43 path=/MediaEndpoint/A2DPSink
        Apr 08 18:55:11 aahmad-pc bluetoothd[723]: Endpoint unregistered: sender=:1.63 path=/MediaEndpoint/A2DPSource
        Apr 08 18:55:11 aahmad-pc bluetoothd[723]: Endpoint unregistered: sender=:1.63 path=/MediaEndpoint/A2DPSink
        [[email protected] ~]$ 
    

    Any assistance would be greatly appreciated. Thanks in advance!

  • @a4orce84 said in Bluetooth stop working:

    systemctl status bluetooth.service

    here is mine with fully working BT:

    ● bluetooth.service - Bluetooth service
       Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: disabled)
       Active: active (running) since Tue 2018-04-10 06:44:04 CEST; 8min ago
         Docs: man:bluetoothd(8)
     Main PID: 328 (bluetoothd)
       Status: "Running"
        Tasks: 1 (limit: 4915)
       Memory: 3.6M
       CGroup: /system.slice/bluetooth.service
               └─328 /usr/lib/bluetooth/bluetoothd
    
    Apr 10 06:44:03 empowered64 systemd[1]: Starting Bluetooth service...
    Apr 10 06:44:04 empowered64 bluetoothd[328]: Bluetooth daemon 5.49
    Apr 10 06:44:04 empowered64 bluetoothd[328]: Starting SDP server
    Apr 10 06:44:04 empowered64 bluetoothd[328]: Bluetooth management interface 1.14 initialized
    Apr 10 06:44:04 empowered64 systemd[1]: Started Bluetooth service.
    Apr 10 06:44:30 empowered64 bluetoothd[328]: Endpoint registered: sender=:1.49 path=/MediaEndpoint/A2DPSource
    Apr 10 06:44:30 empowered64 bluetoothd[328]: Endpoint registered: sender=:1.49 path=/MediaEndpoint/A2DPSink
    

    But GNOME config still do not work, use blueman instead!

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • Interesting, I was trying to do it through Gnome. Is this the best wiki to set everything up for Blueman:
    https://wiki.archlinux.org/index.php/Blueman

    Thanks!

  • @a4orce84 no need for extra configuration… install and run… 😉

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • Hey @joekamprad,

    It appears that blue-manager application is NOT working for me under Gnome 3.28 for some reason.

    Screenshot:
    https://imgur.com/a/rGxoy

    You can see most of the options are grey’d out (unavailable).

    Output:

    [[email protected] ~]$ blueman-manager 
    _________
    Load (/usr/lib/python3.6/site-packages/blueman/main/PluginManager.py:60)
    ['Services', 'PulseAudioProfile'] 
    _________
    __load_plugin (/usr/lib/python3.6/site-packages/blueman/main/PluginManager.py:133)
    loading <class 'blueman.plugins.manager.Services.Services'> 
    _________
    __load_plugin (/usr/lib/python3.6/site-packages/blueman/main/PluginManager.py:133)
    loading <class 'blueman.plugins.manager.PulseAudioProfile.PulseAudioProfile'> 
    _________
    pa_context_event (/usr/lib/python3.6/site-packages/blueman/main/PulseAudioUtils.py:341)
    1 
    blueman-manager version 2.0.5 starting
    Stale PID, overwriting
    _________
    pa_context_event (/usr/lib/python3.6/site-packages/blueman/main/PulseAudioUtils.py:341)
    2 
    _________
    on_bluez_name_owner_changed (/usr/bin/blueman-manager:96)
    org.bluez owner changed to  :1.24 
    _________
    get_interface_version (/usr/lib/python3.6/site-packages/blueman/bluez/BlueZInterface.py:13)
    Detected BlueZ 5 
    _________
    SetAdapter (/usr/lib/python3.6/site-packages/blueman/gui/DeviceList.py:271)
     
    _________
    SetAdapter (/usr/lib/python3.6/site-packages/blueman/gui/DeviceList.py:271)
    No such adapter 
    _________
    on_adapter_changed (/usr/lib/python3.6/site-packages/blueman/gui/manager/ManagerToolbar.py:83)
    toolbar adapter None 
    _________
    pa_context_event (/usr/lib/python3.6/site-packages/blueman/main/PulseAudioUtils.py:341)
    3 
    _________
    pa_context_event (/usr/lib/python3.6/site-packages/blueman/main/PulseAudioUtils.py:341)
    4 
    _________
    on_pa_ready (/usr/lib/python3.6/site-packages/blueman/plugins/manager/PulseAudioProfile.py:29)
    connected 
    _________
    <lambda> (/usr/lib/python3.6/site-packages/blueman/main/PulseAudioUtils.py:353)
    1
    

    Is there something I am missing here? Thanks in advance for all of your time and help, it is greatly appreciated!

    Thanks,
    Asif

  • to get the tray visible you may need to install TopiconsPlus shell extension directly from here: https://extensions.gnome.org/extension/1031/topicons/

    And may reboot to get all services started blueman needs…

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • So, it appears that the blueman GUI application worked once, and only once for some reason. I rebooted and the blueman GUI started working and I was able to scan and find my bluetooth headphones correctly. However, since then the GUI has remained how I showed it in the screenshot above:
    https://imgur.com/a/rGxoy

    For some reason, it is NOT consistent and I am unable to readily connect to my bluetooth headphones and other devices. No matter if I reboot again, put the machine to sleep and boot back in, I am unable to recreate a working blueman GUI experience.

    Is there any tricks / configuration tweaks I need to run for things to work properly? Thanks in advance for everyone’s time and help, it is super appreciated.

    Thanks,
    Asif

  • They are problems with devices do not wake up after suspended, this can be solved by creating rules to handle.
    But I need to check about, as I do not remember exactly now.

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • sudo nano /etc/default/tlp
    

    and set this:

    USB_BLACKLIST_BTUSB=1
    

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

bluetooth39 stop12 Posts 24Views 457
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.