• Add a delay before connecting to bluetooth device ?


    Hello

    I have a very little problem, I have a ‘JBL GO’ bluetooth audio device, it’s working perfectetly.
    The thing is that when i switch the device on, it connects to my computer but the audio profile is set to off, probably because the ‘JBL GO’ takes a a few seconds to initialize.
    In order to make it work, i have to disconnect and reconnect the device, or i can also set manually the audio profile to A2DP.
    It’s a bit annoying and i was wondering if there would be a workaround, like waiting a few seconds before the pairing process.
    How could i do that ? Also, I’m running kde plasma.

    Thank you !

  • hi. I’m not sure if my help will ad a solution to this issue, but do you have pavucontrol installed.
    If so, you can try to relegate a solution there from one of the drop down menus offered.
    You start pavucontrol via your terminal.
    And from there, you would probably have to configure your bluetooth device from the tabs "Playback, Output devices, and Configuration"
    Can try “set as fallback”.
    That may or may not help.
    It should connect without delay.
    But your wanting a delay, is this correct?

    that’s about the only solution I can offer.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • @modisc Actually yes i just want my computer to wait 2 seconds before connecting to the audio device but thank you anyway 🙂

  • hi @siarfnopmop
    Ya, I’m sorry then. Hoping that someone more knowledgeable than me on something like this will come.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • @siarfnopmop

    may enable the switch-on-connect module from Pulseaudio help as i do not know any way to delay the connection request, there is no such option for bluetooth (afaik):
    This helps here to get bluetooth audio *phones work here.

    sudo nano /etc/pulse/default.pa
    

    put this two lines to the end:

    # automatically switch to newly-connected devices 
    load-module module-switch-on-connect
    

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad already done ! well i guess there is no proper solution, thank you

bluetooth43 device20 connecting7 delay6 Posts 6Views 203
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.