• nautilus Open with admin not working and setting menu backgrounds

    After today’s update open with admin in nautilus has stopped working.
    Edit with admin is working.
    sudo nautilus is working.
    Tried uninstalling and reinstalling nautilus-admin 1.1.3-1 still not working.

    The setting menu screen is not working as well with backgrounds won,t open the background folder.

    Any help Thanks Antergos Gnome

  • I do not use such graphical rooted apps, but this is may caused by GNOME upgrades to 3.28?

  • Yep looks that way…
    pamac won’t update to from as well…


  • here just update system, but not out of GNOME… and no reboot so far, but i get all updates …

  • Using Wayland?
    Wayland doesn’t allow graphical applications to be run under root.

  • @ozy said in nautilus Open with admin not working and setting menu backgrounds:


    journal say:

    org.gnome.Nautilus[524]: unknown option --no-desktop


    	def _nautilus_run(self, menu, file):
    		"""'Open as Administrator' menu item callback."""
    		uri = file.get_uri()
    		admin_uri = uri.replace("file://", "admin://")
    		subprocess.Popen([NAUTILUS_PATH, "--no-desktop", admin_uri])
  • I fixed the issues with pamac downloaded from repo and updated manually Fixed. pamac-6.2.5-2-x86_64.pkg.tar.xz

  • @joekamprad Thanks for the report

  • @joekamprad

    Open as Administrator has now be Fixed with new release…Updated from terminal Please mark as solved

    link text

    Thanks brunonova & joekamprad for your help

  • Your topic your turn ;)
    0_1522016869410_Bildschirmfoto vom 2018-03-26 00-25-42.png

menu48 nautilus27 backgrounds3 admin3 Posts 11Views 692
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.