• Tips about the sound in Kde


    Hello, the other day I was watching a video on youtube and I noticed that [b:3scywkux]the sound on the rest of the system is turned off.[/size:3scywkux][/b:3scywkux] Well I started researching a bit and found that I share this with you:

    “If you are using flashplugin from the multilib repository, you need to install alsa-plugins-lib32 and lib32-libcanberra-pulse to use the mixer, otherwise, you can not have simultaneous sound in an application and flashplugin”

    [b:3scywkux]Info in spanish:[/b:3scywkux]

    [https://wiki.archlinux.org/index.php/PulseAudio_(Español)#Flashplugin_.28solo_x86_64.29][0]">[https://wiki.archlinux.org/index.php/Pu][1] … _x86_64.29

    Well I installed these packages and now I can play flashplugin simultaneous with other applications such as skype or spotify.

    \# Pacman -S lib32-alsa-plugins lib32-libcanberra-pulse
    

    [b:3scywkux]Info in english:[/b:3scywkux]

    [https://wiki.archlinux.org/index.php/PulseAudio#Flash_content][0]">[https://wiki.archlinux.org/index.php/Pu][1] … sh_content

    Moreover I also observed with respect to the [b:3scywkux]Sound (volume)[/b:3scywkux][/size:3scywkux] of the following:

    The sound output is always at 66% and even change it up for example 66% to 80%,restarting the system returns to 66%,as I began to investigate and well if we want the sound to 100% after each reboot.

    Need to edit the following file:

    sudo nano /home/myname/.kde4/share/config/kmixrc
    

    insert … and add this line at the [b:3scywkux]top under [Global][/b:3scywkux]

    VolumeOverdrive = true

    …Now restart kmix or just restart your computer. [b:3scywkux]Now the sound will default to 100%[/b:3scywkux].

    [https://forum.kde.org/viewtopic.php?f=66&t=98230][0]">[https://forum.kde.org/viewtopic.php?f=66&t=98230][2]

    [b:3scywkux]Also I found this one that may be of interest:[/b:3scywkux][/size:3scywkux]

    [b:3scywkux]Per-application volumes change When the Master volume is adjusted:[/b:3scywkux]

    /etc/pulse/daemon.conf

    flat-volumes = no

    [https://wiki.archlinux.org/index.php/PulseAudio#Flash_content][0]">[https://wiki.archlinux.org/index.php/Pu][1] … sh_content

    [b:3scywkux]Other relevant issues:[/size:3scywkux][/b:3scywkux]

    [b:3scywkux]For applications that do not support PulseAudio and ALSA support is recommended to install the module for PulseAudio ALSA.[/b:3scywkux]

      
    \# Pacman -S pulseaudio-alsa
    

    [b:3scywkux]To add sound to 32 bit programs on Arch x86_64 (and Wine), have to install lib32-libpulse and lib32-alsa-plugins also[/b:3scywkux]

    \# Pacman -S lib32-libpulse lib32-alsa-plugins
    

    I hope this can help you at some point…

    Best Regards

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/Pu
    [2]: https://forum.kde.org/viewtopic.php?f=66&t=98230

  • Hello, the other day I was watching a video on youtube and I noticed that [b:3scywkux]the sound on the rest of the system is turned off.[/size:3scywkux][/b:3scywkux] Well I started researching a bit and found that I share this with you:

    “If you are using flashplugin from the multilib repository, you need to install alsa-plugins-lib32 and lib32-libcanberra-pulse to use the mixer, otherwise, you can not have simultaneous sound in an application and flashplugin”

    [b:3scywkux]Info in spanish:[/b:3scywkux]

    [https://wiki.archlinux.org/index.php/PulseAudio_(Español)#Flashplugin_.28solo_x86_64.29][0]">[https://wiki.archlinux.org/index.php/Pu][1] … _x86_64.29

    Well I installed these packages and now I can play flashplugin simultaneous with other applications such as skype or spotify.

    \# Pacman -S lib32-alsa-plugins lib32-libcanberra-pulse
    

    [b:3scywkux]Info in english:[/b:3scywkux]

    [https://wiki.archlinux.org/index.php/PulseAudio#Flash_content][0]">[https://wiki.archlinux.org/index.php/Pu][1] … sh_content

    Moreover I also observed with respect to the [b:3scywkux]Sound (volume)[/b:3scywkux][/size:3scywkux] of the following:

    The sound output is always at 66% and even change it up for example 66% to 80%,restarting the system returns to 66%,as I began to investigate and well if we want the sound to 100% after each reboot.

    Need to edit the following file:

    sudo nano /home/myname/.kde4/share/config/kmixrc
    

    insert … and add this line at the [b:3scywkux]top under [Global][/b:3scywkux]

    VolumeOverdrive = true

    …Now restart kmix or just restart your computer. [b:3scywkux]Now the sound will default to 100%[/b:3scywkux].

    [https://forum.kde.org/viewtopic.php?f=66&t=98230][0]">[https://forum.kde.org/viewtopic.php?f=66&t=98230][2]

    [b:3scywkux]Also I found this one that may be of interest:[/b:3scywkux][/size:3scywkux]

    [b:3scywkux]Per-application volumes change When the Master volume is adjusted:[/b:3scywkux]

    /etc/pulse/daemon.conf

    flat-volumes = no

    [https://wiki.archlinux.org/index.php/PulseAudio#Flash_content][0]">[https://wiki.archlinux.org/index.php/Pu][1] … sh_content

    [b:3scywkux]Other relevant issues:[/size:3scywkux][/b:3scywkux]

    [b:3scywkux]For applications that do not support PulseAudio and ALSA support is recommended to install the module for PulseAudio ALSA.[/b:3scywkux]

      
    \# Pacman -S pulseaudio-alsa
    

    [b:3scywkux]To add sound to 32 bit programs on Arch x86_64 (and Wine), have to install lib32-libpulse and lib32-alsa-plugins also[/b:3scywkux]

    \# Pacman -S lib32-libpulse lib32-alsa-plugins
    

    I hope this can help you at some point…

    Best Regards

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/Pu
    [2]: https://forum.kde.org/viewtopic.php?f=66&t=98230

  • OP, Mark this post as ultra helpful and pin it to the top of forum forever, please ;D

  • thanks for the tips. ive been having some sound problems of late.

  • Especially KDE is some sound-configuration-demanding DE

    hector:

    @“hector”:1ncncej4 said:

    \# Pacman-S ...
    
    sudo nano / home/myname/...
    

    [/quote:1ncncej4]

    and few more typos. Or maybe they are not a regular typos, but some awareness checking typos? ;p

  • Sorry I have corrected the errors, i think now it’s ok-.

    Especially KDE is some sound-configuration-demanding DE

    Yes, kde sound is more complex that Gnome …

    Another issue important is highly recommended to install as sound engine:

      
    >sudo pacman -S phonon-qt4-vlc
    

    You can choose between various backends like GStreamer (phonon-gstreamer) or VLC (phonon-vlc), available in the official repositories, and MPlayer (phonon-mplayer-git), QuickTime (phonon-quicktime-git) or AVKode (phonon-avkode-git), available in the AUR.

    [b:2r1ddjtl]Most users will want VLC which has the best upstream support. GStreamer is currently not well maintained[/b:2r1ddjtl]. Note that multiple backends can be installed at once and chosen at System Settings > Multimedia > Phonon > Backend.

    [https://wiki.archlinux.org/index.php/Kde#Phonon][0]">[https://wiki.archlinux.org/index.php/Kde#Phonon][1]

    Best Regards

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/Kde#Phonon

Posts 6Views 1224
Log in to reply