• [DEB_Arch_Extra]: duplicate target


    Hi everyone,

    I searched but didn’t see this topic come up. I’m trying to upgrade but get this error message after the package manager downloads the list:

    [DEB_Arch_Extra]: duplicate target

    Any help would be appreciated. Tx!

  • @33nicolas https://mega.nz/you add this on your own to pacman.conf? to get megasync installed…

    does it work before?

  • @joekamprad Yes, perfectly well. The only thing I did in the meantime is switch DE from Deepin to Gnome.

  • the error looks like pacman finds dublicate packagenames?

    ls /var/lib/pacman/local/ | grep megasync

  • @joekamprad It used to work well before but I went over quota so it’s not activated at this moment.

    I will look at your other link below later.

    Thank for your help,

  • @joekamprad lt says no such directory. That and the VirtualBox kernel is also not starting up. Hum…

  • ls /var/lib/pacman/local/ > pacman-local.txt && sort pacman-local.txt | uniq -d
    
  • you can also take a look to the directory and search for double entries for a package…
    ls /var/lib/pacman/local/ will show all packages.

    you can also remove DEB_Arch_Extra repo from pacman.conf you can do this by uncommenting the lines with #

    #[DEB_Arch_Extra]
    #SigLevel = Optional TrustAll
    #Server = http://mega.nz/linux/MEGAsync/Arch_Extra/$arch
    

    and then try sudo pacman -Syyu

  • if this do not work:

    sudo pacman -Scc
    sudo pacman -Syyu

  • @joekamprad Yikes, no such directory?

  • @joekamprad So far it worked, although I had to use the pacman -Scc and -Syyu

    Sry, I’m not yet fluent in arch commands. I just switched over from Debian and I’m not that savvy.

  • @joekamprad said in [DEB_Arch_Extra]: duplicate target:

    pacman.conf

    I’m not sure how to access pacman.conf?

  • @joekamprad Tried it but it didn’t do anything. Still have the same.

    [DEB_Arch_Extra]: duplicate target

    It looked like it overhauled the repository but when I try to update it still gives me the same error message.

  • with a editor and root rights:

    sudo nano /etc/pacman.conf

    save the file by pressing: [Ctrl+X]

    http://www.codexpedia.com/text-editor/nano-text-editor-command-cheatsheet/

  • @joekamprad OK, thanks to your last message on how to access pacman.conf, I removed the pound signs around Mega. The databases synchronized. Updated the system.

    Still the updater UI gives me the same error: [DEB_Arch_Extra]: duplicate target. Logged out, repeated everything just haven’t rebooted so far.

  • need to update the database inside pamac or reboot ;)

  • I thought the database had been updated but obviously something is messing this system up in a major way.

    I still get the [DEB_Arch_Extra]: duplicate target

    It upgrades fine from the terminal, so I’m OK, but this is weird.

target2 duplicate2 Posts 18Views 998
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.