• CIFS erros in


    Here’s my second issue as a new Antergos user.
    When I issue this command:

    sudo journalctl -p 3 -xb
    

    I see these two errors logged:

    kernel: CIFS VFS: ioctl error in smb2_get_dfs_refer rc=-5
    CIFS VFS: Free previous auth_key.response = blahblahblah
    

    I Googled around a bit and saw some references to a kernel patch for the auth_key error. I’m at a later kernal than what was referenced in the patch yet still get these messages.
    I’ve had problems with SMB shares a bit with the ones I have setup in fstab - mostly performance. Accessing through gvfs seems faster and doesn’t seem to generate errors/warnings.
    I have SMBv1 disabled and have specified SMBv3 in my fstab.
    Any ideas on those messages for CIFS? Is something wrong or can they be safely ignored?

  • @nraygun said in CIFS erros in:

    ioctl error in smb2_get
    may smb2 is running on the other side?

  • Yes, confirmed SMBv2 on the other side.

    Any other ideas?

  • @nraygun said in CIFS erros in:

    I have SMBv1 disabled and have specified SMBv3 in my fstab.

    first try change this ?

  • @joekamprad
    Not sure I follow your comment.
    I confirmed I have SMBv2 and SMBv3 enabled on the Win10 machine. I have “vers=3.0” in my fstab on the Xubuntu client. I also tried “vers=2.1” in fstab and I still get the error/warning.

  • I changed my SMB on Win10 to SMBv1 and I don’t get errors anymore.
    Might not be optimal, but I’ll take it. For now.

cifs6 erros1 Posts 6Views 825
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.