• SANE 1.0.27 and CanoScan LIDE100


    I recently added an old scanner (Canon CanoScan LIDE100) to my computer and installed SANE 1.0.27. According to the SANE website, the scanner works with SANE. But when I scan a document, there is a dark black line running vertically down the page: https://imgur.com/a/1HKd1

    I’ve read elsewhere that this is a recurring problem with this version of SANE. I also read that downgrading to SANE 1.0.25 solves the problem for many. However, I am unable to find this version. Does anyone know where I can find this older version in order to downgrade? Thanks.

  • @walth
    Sorry, I don’t have that older version and I don’t know any official place for it (unless Arch guys store it somewhere). But I’ve used a scanner (samsung) for a long time and never had that kind of an issue.

    I’m using the simple-scan package which gets the work done, maybe want to try that?

  • @manuel No difference. I still get the black line.

  • @walth
    Ok, sounds like either a driver or sane problem. Hopefully someone has that older version of sane.
    I suppose you have tried the downgrade package to downgrade sane?

  • simple-scan is a frontend only… it uses sane to scan…

  • try out with:

    sudo pacman -U https://archive.archlinux.org/packages/s/sane/sane-1.0.25-2-x86_64.pkg.tar.xz
    and scanning still works.

  • @joekamprad That fixed it. Thanks!

  • you are welcome!

    do not forget to exclude it from updating!

    can be done inside pamac-manager settings or inside /etc/pacman.conf

    # Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
    IgnorePkg   = sane
    #IgnoreGroup =
    

    0_1522001694451_Bildschirmfoto vom 2018-03-25 20-12-55.png

  • Now that you have the version 1.0.25 installed, it should have been stored in /var/cache/pacman/pkg. That means you could also use the downgrade package always after updating sane, if the new update does not work properly.
    And if the new sane package works well, you don’t have to downgrade anymore.

  • @manuel smart way of handeling such!

sane1 canoscan1 lide1001 1.0.271 Posts 11Views 600
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.