• Idle screen blanking does not work on fresh install (general bug?)


    Hi! Long time Debian user here but new to Antergos/arch. I’m on a default Antergos install (with Lightdm and Gnome) on a Thinkpad T520. It’s been a truly promising love affair so far, but now a seemingly straightforward issue is giving me headaches: Blanking the screen when idle will not work.

    My aim: I want the screen to go into standby/poweroff after 60 seconds of idle time, and lock to be applied either 30 seconds after the screen has gone blank or immediately.

    Relevant settings are these (those directly related are highlighted) :

    • Settings -> Privacy -> Screen Lock
      • Automatic Screen Lock: On
      • Lock screen after blank for: 30 seconds (alternative: “Screen turns off”)
      • Show Notifications: On
    • Settings -> Power
      • Blank Screen: 1 minute
      • Automatic suspend: On
      • On Battery Power: On
      • Delay: 15 minutes
      • Plugged In: On
      • Delay: 30 minutes

    No changes to light-locker settings

    Expected behavior: Screen should be switched off after 60 seconds (and be locked after another 30 seconds)

    Actual behavior: Absolutely nothing. 😞

    The problem is, I don’t even know where to start debugging this, since there are no related events registered via dmesg, journalctl or /var/log/Xorg.0.log

    • What does work:
      • xset dpms force off
    • Things that also work (though not directly part of the root problem):
      • dm-tool lock
      • The lock button in the GNOME system menu (top right corner)
      • The keyboard shortcut for locking: <SUPER>-L
      • Suspend on AC and on Battery

    Since I can reproduce this in a completely fresh VM installation, I’m wondering whether it is a general bug/problem after a fresh default installation?

    I very much Hope someone can help me fix this. I often work in crowded environments where I’m easily distracted, so this basic feature is very important to me.

    Greetings,
    shane

  • Works like a charm, thank you! 🙂
    Well, that’s embarrassing: It’s not like I didn’t look for solutions quite some time before asking. Guess I should have used forum and wiki search rather than search engines 😕

    One small change to the wiki article I would suggest: If I’m not mistaken, then KDE doesn’t actually use the GNOME powersettings daemon and OnlyShowIn=KDE; is just used so that GNOME doesn’t see the desktop entry. The key for completely hiding a desktop entry is Hidden (see Desktop Entry Specification). Therefore, instead of editing, you can simply attach the new key to the desktop file with echo "Hidden=true" | sudo tee -a /etc/xdg/autostart/org.gnome.SettingsDaemon.Power.desktop

    And one addition: If like me you prefer not to interfere with global files that may be subject to update changes, you can enable the changes on a per-user basis by copying the file to the .config/autostart directory in your home dir and then add the key by doing

    $ cp /etc/xdg/autostart/org.gnome.SettingsDaemon.Power.desktop ~/.config/autostart/
    $ echo "Hidden=true" >> .config/autostart/org.gnome.SettingsDaemon.Power.desktop 
    

    Both tested and working.

    This has resolved the issue for me, so I’ve marked the thread as SOLVED.
    I still have a few questions though:

    • Since this seems to be a general problem with GNOME/Lightdm and the wiki solution works, why not make it a default for GNOME installations on Antergos? I saw that you already suggested this a while ago here last july . Have there been any objections to taking this path?
    • If GNOME is unfriendly to customizations and doesn’t play nice with other applications, even to the point of breaking basic functionality, then why is it the default desktop environment on a fresh Antergos install, which is arguably a customized system and intended to be open for customizations? (I’ve personally enjoyed using GNOME for a long time when I’m not using Openbox, but I’ve never actually tried it out in mixed environments before, so this downside is new to me)

    Please don’t get me wrong: I don’t mean to be annoying, I’m just trying to understand how things work.

    Greetings,
    shane

  • Thanks a lot for taking the time to improve this!
    I will merge this to the wiki asap!

    There is a general switch on the GNOME development, they call it ADWAITA (meaning “non-dual” in Sanskrit).

    But on the other side GNOME is a full modern Desktop with all tools needed, with a minimum of configurations needed.

    History at antergos here is : it was founded on Cinnamon, but after big problems with a GTK update they switch to GNOME.

    On implementation of the “hack” as default: it is still a hack ond not a real solution, and there will be no solution, as GNOME will follow their adwaita way.

    But i would follow you on the wish.
    If GNOME is the default Desktop, it should work on a default install.

    As you can see there is also no pamac-manager try icon visible under GNOME…as GNOME decides to remove the legacy tray completely on last update… As pamac is the antergos package manager it should be there by default.
    And there is also a solution to this but it is still not implemented.

    [updates once a week] = [90% less problems]
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    help development: donate antergos

  • Thanks for your explanations. If GNOME has stopped aiming for compatibility, with other applications, then that’s really a shame for the other reasons you mentioned (full desktop environment that works out of the box). For me, one of the base principles of Linux has always been the ability to combine different tools of choice to get the best results for your specific situation. An application that veers away from this principle is really veering away from user self-determination and thus everything that has made Linux great.

    I’ll keep my fingers crossed that Antergos will find a way to implement a fully working default Desktop nontheless in the near future. Except for this issue of one of the basic settings not working (which, simple as the issue itself may be and easily as it’s workaround solution may be applied, does constitute the difference between a fully matured distro and an enthusiast effort to me) I continue to be absolutely delighted by this distro and will definitely continue to use it!

    Thanks also for merging my suggestions with the wiki article.

  • @shane said in Idle screen blanking does not work on fresh install (general bug?):

    this principle is really veering away from user self-determination
    and thus everything that has made Linux great.

    I fully agree with the first, but not complete with second part.

    GNOME as one of the major DE’s is balancing on the narrow degree between customization possibilities and the stability and completness it will offer.
    The way users see the Desktop Environment itself are changing nowadays, it ades to the background to something like a frontend to the services the user is using.

    This is not the true for all users, but for the major group of new entrants, called “webbies” (users of services from the internet) they have no desire for special applications, or get into the deep of hardware specifications to get the best out of the hardware. they want to use services and not applications.
    Something like apple is done with their way of “marketing desktop”

    Long talk short: GNOME want to create a Desktop-Framework for the casual user, as the one alternative to MAC and Microsoft. BUT free and opensource.

    And in my opinion they do one other thing more right then all others: THE GNOME-SHELL it is a ergonomic revolution on the Desktops nowadays!

    More words 😉

    For the advanced user it is possible to change everything on linus to fit your needs, and it is not that hard:
    This is my GNOME Desktop:
    0_1522068667576_Bildschirmfoto vom 2018-03-26 14-49-49.png

    [updates once a week] = [90% less problems]
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    help development: donate antergos

gnome316 powermanagement12 fresh install7 default5 Posts 7Views 518
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.