• Networkmanager update problem


    Todays update for the Networkmanager causes problems ( at least at my systems)
    I’m talking about :
    libnm 1.10.6-2
    libnm-glib 1.10.6-2
    Both kernels fail to start the networkmanager.
    If you’re not familiar to fix it, just ignore the update. (I reverted back with timeshift)

    KDE/XFCE/i3-WM

    Everybody is a genius, but if you judge a fish by its ability to climb a tree, it will live its whole life believing its stupid.

  • @bryanpwo
    Ran into the same issue.I had to downgrade networkmanager to get my internet connection back.
    J.

  • @Jeannie____
    I saw your post on it too, you beat me by one minute in posting, at least now we know it’s a bug in the update.

    KDE/XFCE/i3-WM

    Everybody is a genius, but if you judge a fish by its ability to climb a tree, it will live its whole life believing its stupid.

  • Hi all, how can i downgrade and fix the issue?
    Thank you so much!

  • sudo downgrade libnm

    Then pick the previous version.

    KDE/XFCE/i3-WM

    Everybody is a genius, but if you judge a fish by its ability to climb a tree, it will live its whole life believing its stupid.

  • Downgrade libnm-glib also.

    KDE/XFCE/i3-WM

    Everybody is a genius, but if you judge a fish by its ability to climb a tree, it will live its whole life believing its stupid.

  • @bryanpwo
    I have installed those too, but the network seems to work without problems.

    Sorry about a dummy question, but what is the command to see if networkmanager is started?

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • @manuel systemctl status NetworkManager.service

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • Yup, networkmanager is running and network works as before.

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • @manuel
    Strange, my connection disappeared after updating it on three different machines.

    KDE/XFCE/i3-WM

    Everybody is a genius, but if you judge a fish by its ability to climb a tree, it will live its whole life believing its stupid.

  • @bryanpwo I’ll try it with a virtual machine too… just a moment.

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • No problems here on 4 different machines (wifi + cable)

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • No problem on VM either.
    So, maybe reinstalling kernel(s) or networkmanager could help? Is it now possible to reinstall anything?

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • I will try, hold on.

    KDE/XFCE/i3-WM

    Everybody is a genius, but if you judge a fish by its ability to climb a tree, it will live its whole life believing its stupid.

  • Hi,

    not working on my PC.

    [email protected] ~]$ sudo systemctl start NetworkManager
    Job for NetworkManager.service failed because the control process exited with error code.
    See “systemctl status NetworkManager.service” and “journalctl -xe” for details.

    Linux ist das beste Betriebssystem (Albert Einstein)

  • Okay, in my case reinstalling the kernel and libnm brought me the same error, but reinstalling just libnm and libnm-glib did the trick.
    On all my machines I have a working internetconnection.

    KDE/XFCE/i3-WM

    Everybody is a genius, but if you judge a fish by its ability to climb a tree, it will live its whole life believing its stupid.

  • Hi, i’ve downloaded the older version of libnm and libnm-glib versions from archive.archlinux.org.
    I installed them with

    sudo pacman -U ***.tar.xz
    

    I rebooted but still no working internet connection. 🤔

  • @ilfabri
    Have you also tried the downgrade option?

    KDE/XFCE/i3-WM

    Everybody is a genius, but if you judge a fish by its ability to climb a tree, it will live its whole life believing its stupid.

  • @bryanpwo “command not found” 😞

  • @ilfabri said in Networkmanager update problem:

    @bryanpwo “command not found” 😞

    maybe you do not have the “downgrade” package installed

    $ sudo pacman -Ss downgrade

    ???

networkmanager16 Posts 35Views 1685
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.