• Slow Boot


    Hello!

    I started my Arch experience with Manjaro KDE about 6 months ago, then added Netrunner Rolling when it came out. When I discovered that Antergos offers a KDE version, I immediately installed it and have been using it for a couple months now.

    When first installed, boot time was very fast, and I really liked (still do) the login screen with its clock and revolving images. Several weeks ago I noticed that boot time had increased significantly – I have a Netrunner Rolling partition dual-booted on this machine, and it boots as fast as ever. Also, the login screen clock only shows the minutes now – and once I enter my password, I have to manually click the arrow rather than just hit Enter, or the screen locks and I have to reboot.

    I did a search for “slow boot” on this forum and found this link: [url:1y11sn23]http://forum.antergos.com/viewtopic.php?f=22&t=1533&p=6359&hilit=slow+boot#p6359[/url:1y11sn23], where lots.O.logs suggested the following command, which he was kind enough to inspect:

    sudo journalctl -b \> ~journal
    

    I ran the code and got this: [http://www.mediafire.com/view/rmfubgj7cr5t1rg/~journal][0]">[http://www.mediafire.com/view/rmfubgj7cr5t1rg/~journal][1]

    The xorg-xauth package is already installed.

    Any suggestions on how I can reduce boot time and fix the login screen?

    Thank you!

    [0]: <a href=
    [1]: http://www.mediafire.com/view/rmfubgj7cr5t1rg/~journal

  • Hello!

    I started my Arch experience with Manjaro KDE about 6 months ago, then added Netrunner Rolling when it came out. When I discovered that Antergos offers a KDE version, I immediately installed it and have been using it for a couple months now.

    When first installed, boot time was very fast, and I really liked (still do) the login screen with its clock and revolving images. Several weeks ago I noticed that boot time had increased significantly – I have a Netrunner Rolling partition dual-booted on this machine, and it boots as fast as ever. Also, the login screen clock only shows the minutes now – and once I enter my password, I have to manually click the arrow rather than just hit Enter, or the screen locks and I have to reboot.

    I did a search for “slow boot” on this forum and found this link: [url:1y11sn23]http://forum.antergos.com/viewtopic.php?f=22&t=1533&p=6359&hilit=slow+boot#p6359[/url:1y11sn23], where lots.O.logs suggested the following command, which he was kind enough to inspect:

    sudo journalctl -b \> ~journal
    

    I ran the code and got this: [http://www.mediafire.com/view/rmfubgj7cr5t1rg/~journal][0]">[http://www.mediafire.com/view/rmfubgj7cr5t1rg/~journal][1]

    The xorg-xauth package is already installed.

    Any suggestions on how I can reduce boot time and fix the login screen?

    Thank you!

    [0]: <a href=
    [1]: http://www.mediafire.com/view/rmfubgj7cr5t1rg/~journal

  • Try editing /etc/ufw/ufw.conf change " LOGLEVEL=low" to be “LOGLEVEL=off” instead. Also you should review any changes you made to the UFW config for errors. (disregard if you have not made any changes.) Let me know if it helps.

  • Thanks for the quick reply.

    I edited according to your suggestion, and as far as I can tell, the issues I first described persist – a long lag-time before the login screen appears, clock shows only minutes, and I have to manually hit the arrow instead ENTER.

    I’m sure this is the first time I’ve edited a configuration file on my Antergos partition.

  • Try completely disabling UFW:

    systemctl disable ufw
    

    Reboot and then grab the journal log from that boot with :

    journalctl -b 0 \> ~/journal.log
    

    Cheers!

  • Thank you, Dustin.

    I ran the disable UFW command, rebooted and grabbed the journal log:
    [http://www.mediafire.com/view/pv2qocf0urp8o3v/journal.log][0]">[http://www.mediafire.com/view/pv2qocf0u][1] … ournal.log

    Boot time was prolonged as before.

    [0]: <a href=
    [1]: http://www.mediafire.com/view/pv2qocf0u

  • Hmm…what’s the output from these:

    sudo systemd-analyze blame  
    sudo systemd-analyze critical-chain
    

    Cheers!

  • $ sudo systemd-analyze blame  
      
    7.296s NetworkManager.service  
    7.101s ModemManager.service  
    5.075s polkit.service  
    4.568s accounts-daemon.service  
    1.730s udisks2.service  
    1.587s systemd-fsck-root.service  
    1.498s alsa-restore.service  
    1.447s systemd-logind.service  
    1.290s systemd-vconsole-setup.service  
    1.221s systemd-modules-load.service  
    910ms systemd-tmpfiles-setup-dev.service  
    634ms lightdm.service  
    499ms rpcbind.service  
    457ms ntpd.service  
    355ms systemd-udev-trigger.service  
    326ms dev-hugepages.mount  
    324ms sys-kernel-debug.mount  
    321ms dev-mqueue.mount  
    290ms systemd-tmpfiles-clean.service  
    232ms [email protected]  
    191ms [email protected]:dell\_backlight.service  
    166ms [email protected]  
    161ms systemd-random-seed.service  
    154ms home.mount  
    150ms systemd-update-utmp.service  
    130ms kmod-static-nodes.service  
    124ms systemd-user-sessions.service  
    110ms wpa\_supplicant.service  
    100ms systemd-remount-fs.service  
    74ms [email protected]  
    70ms systemd-sysctl.service  
    69ms systemd-journal-flush.service  
    68ms systemd-udevd.service  
    52ms systemd-tmpfiles-setup.service  
    43ms upower.service  
    39ms rtkit-daemon.service  
    2ms tmp.mount  
    2ms [email protected]:intel\_backlight.service  
    2ms sys-kernel-config.mount
    

    and

    sudo systemd-analyze critical-chain  
      
    The time after the unit is active or started is printed after the "@" character.  
    The time the unit takes to start is printed after the "+" character.  
      
    graphical.target @13.979s  
    └─multi-user.target @13.979s  
    └─ntpd.service @13.521s +457ms  
    └─network.target @13.352s  
    └─NetworkManager.service @6.056s +7.296s  
    └─basic.target @6.014s  
    └─timers.target @5.960s  
    └─systemd-tmpfiles-clean.timer @5.933s  
    └─sysinit.target @5.714s  
    └─systemd-update-utmp.service @5.562s +150ms  
    └─systemd-tmpfiles-setup.service @5.508s +52ms  
    └─local-fs.target @5.506s  
    └─home.mount @5.342s +154ms  
    └─dev-disk-by\\x2duuid-1c178ec7\\x2dd647\\x2d4f9f\\x2db3af\\x2d1a99ee459bb4.device @5.183s
    
  • Any thoughts on the output, Dustin?

  • Well, thanks for giving it a shot, Dustin – and for all that you and the other developers do here at Antergos. This is a wonderful way to dive into the Arch world, for sure.

  • Sorry for the delay. I lost track of this thread

    I recommend you look further into these:

    NetworkManager.service @6.056s +7.296s  
    systemd-tmpfiles-clean.timer @5.933s
    

    Something is not going right for Network Manager to take that long. (On my system it’s only 323ms) Same thing for systemd tmp files service. Check the wiki for Network Manager…and google the systemd service. Just out of curiosity, what does your /etc/fstab look like?

    Cheers!

  • Thank you for the further suggestions, Dustin – no problem about losing the thread. You are PROLIFIC around here, it’s amazing that you can juggle as many discussions as you do…

    Here are the contents of my /etc/fstab:

    \#   
    \# /etc/fstab: static file system information  
    \#  
    \# <file system\> <dir\> <type\> <options\> <dump\> <pass\>  
    UUID=0f0bd4ae-e6a2-4351-a677-c8e6823092fc swap swap defaults 0 0  
    UUID=2d2df877-eff2-49ae-ab63-ccd601ac0898 / ext4 defaults 0 1  
    UUID=4af6f11d-a361-4ee5-bb8e-7309c1459ce1 /home ext4 defaults 0 1
    

    I will do some research on Network Manager and systemd – there’s so much to learn!

  • Well, it’s what I do in my day job so I guess it gives me an advantage

    I noticed in your the output from systemd analyze there was a RAID device mounted but I dont see it in your fstab. Are you using any software RAID setup? One thing you could try is editing you fstab to this:

    \#   
    \# /etc/fstab: static file system information  
    \#  
    \# <file system\> <dir\> <type\> <options\> <dump\> <pass\>  
    UUID=0f0bd4ae-e6a2-4351-a677-c8e6823092fc none swap defaults 0 0  
    UUID=2d2df877-eff2-49ae-ab63-ccd601ac0898 / ext4 defaults 0 1  
    UUID=4af6f11d-a361-4ee5-bb8e-7309c1459ce1 /home ext4 defaults,noauto,x-systemd.automount 0 2
    

    Cheers!

  • Interesting find, Dustin. As far as I know, there is no RAID setup on this machine (especially since I don’t know what that is! – but who knows?). I will edit the fstab file as soon as the machine finishes compiling AUR’s silverlight package – in a few hours, lol… I’ll let you know how that works.

  • So… I went to open /etc/fstab, and it looks nothing like what I found yesterday – it’s possible that I wrote to you from another machine…? (I’m in the Newbie Corner for a reason!!!)

    Anyway, here’s what it looks like now:

    \# /etc/fstab: static file system information.  
    \#  
    \# Use 'blkid' to print the universally unique identifier for a  
    \# device; this may be used with UUID= as a more robust way to name devices  
    \# that works even if disks are added and removed. See fstab(5).  
    \#  
    \# <file system\> <mount point\> <type\> <options\> <dump\> <pass\>  
    \#  
    UUID=ec1c995b-2e64-4e0b-86cb-999f18203d48 / ext4 rw,defaults,noatime,discard 0 1  
    UUID=1c178ec7-d647-4f9f-b3af-1a99ee459bb4 /home ext4 rw,defaults,noatime,discard 0 0  
    tmpfs /tmp tmpfs defaults,noatime,mode=1777 0 0
    

    Should I still edit the /home line per your suggeston, Dustin?

  • Yes go ahead and try that for the /home but keep what you have existing also…so basically just add noauto,x-systemd.automount. You can leave the double zero at the end.

    Best Regards,
    Dustin

  • Okay – I added the two items to the /home line, but boot still crawls along, maybe a bit slower now. Once I get past the sign-in screen, however, everything is as snappy as ever.

  • How slow are we talking here. Try to time it either with a watch or by counting yourself and let me know.]

    Cheers!

  • Good question!

    From GRUB to sign-in screen:

    Antergos KDE: 1 minute, 40 seconds
    Netrunner Rolling (dual-booted on same machine): 17 seconds

  • That weird that you are well over a minute in boot time but systemd doesnt show any process taking up the extra time…hmmm…are you using lightdm? Grab /var/log/lightdm/lightdm.log & x-0-greeter.log

Posts 27Views 7004
Log in to reply