• Waking from suspend issues


    I’ve recently installed Antergos on my Dell XPS 15 (9550) and have noticed that it doesn’t always wake from sleep when I open the lid and is often starting from fresh.

    How can I diagnose this and fix it?

    I went with Gnome and the power settings on Tweak utils points that suspend is active when lid close.

  • Hey. I was having the same problem. Did you try to turn off the option of energy saving when closing lid in Gnome Tweak? For me that solved the problem.

  • What DE are you using.

  • My DE is Gnome

  • @schuenne Did you disable the lightdm or are you still using it.

  • @phone-wilson I didn’t actively disable lightdm. Not sure though if it is still running on my machine. How can I find out?

  • @schuenne
    Use (any of) commands

    systemctl list-units | grep -i "display manager"
    systemctl list-units | grep -i "lightdm"
    

    I’m not so sure lightdm has anything to do with the problem.
    But could you show the output of command

    journalctl -b -0
    
  • Also checking file /var/log/Xorg.0.log for issues might reveal something.

  • @manuel Seems like I am using lightdm. It says :
    systemctl list-units | grep -i “display manager”
    lightdm.service loaded active running Light Display Manager

    To be more precise: Turning off energy saving when closing lid in Gnome Tweak just helped to turn the screen back on after closing lid and reopening it. With energy saving turned on I wasn’t able to get the screen back on and hat to hard shut down the machine and reboot to use it again.

    The output of journalctl is quite large. I saved it to a txt file. Are there any parts in particularly that you are interested in?

  • @schuenne
    See my tips below the answer? ;)
    URL from any file: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1

  • @schuenne said in Waking from suspend issues:

    My DE is Gnome
    I went with Gnome and the power settings on Tweak utils points that suspend is active when lid close.
    Seems like I am using lightdm

    • Gnome+Lightdm+Lightlocker

    • Gnome+GDM+Gnome-Control-Center energy settings

    If you want to use GNOME energy option you will need to use GDM, if not see this Wiki:

    https://antergos.com/wiki/desktops/gnome/working-solution-to-use-lightdm-and-lightlocker-under-gnome/

  • @manuel Sorry for being a dumb beginner😉
    I Just send the file. Hope it helps. Thanks for looking into this!

  • @joekamprad Thanks. I am going to try that out and let you know if it worked out for me.

  • @schuenne any respond is welcomed, so may i can add it to the wiki!

  • @schuenne said in Waking from suspend issues:

    @manuel Sorry for being a dumb beginner😉
    I Just send the file. Hope it helps. Thanks for looking into this!

    you will need to provide the url here to get @manuel taking a look onto;)
    Or do you send it via chat to him?

  • @joekamprad O.K. this worked for me so far as the screen turns off after some minutes and I can get it back on. But it’s just a bit painful that I am not able to use the power saving mode from GNOME tweak. Because if I turn this on again, my screen stays black after reopening the lid and as mentioned above I can’t do anything. As my machine is pretty old and weak it still generates quite some heat even with the lid closed and screen off. Therefore the power saving mode would be great.

  • As i mentioned before, most of the GNOME internal energy related stuff will work only together with GDM instead of Lightdm.

    And depending on if you have a swap partition and added it as resume device inside grub…
    As suspend to swap is what Antergos providing by default …

  • @joekamprad I just entered cat “file” | curl -F [email protected] https://ptpb.pw/?u=1
    with “file” =“path/to/my/file” from the command line. Hope that is correct. How would I do it otherwise? Providing a link to some kind of cloud service where uploaded the file to?

  • @joekamprad Mhh… seems like now I can’t control the screen brightness from the keyboard anymore which I was able to do before. So if I get this right, I would have to disable Lightdm and only use GDM to get a chance of the power saving mode working. True?

  • @schuenne
    That “cat “file” …” returned a short web address, please show the address here. :)

suspend46 sleep18 wakeresume2 Posts 25Views 961
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.