• Antergos & Windows 10 - Win10 Update Failure


    Hey, just making a post because I’ve run into an issue on PCs where Antergos/Win10 are installed.

    After Antergos is installed, cumulative updates for Windows 10 stop installing properly. They will download and begin the installation, reboot, and then fail consistently (Windows gives me the “We couldn’t complete the updates, undoing changes” message), no matter what I’ve done on the Windows side of things to get it working.

    This has happened on 3 PCs of mine within the past half year or so of varying ages/hardware, and has started happening again after I freshly installed Win10 and Antergos on my main PC.

    Has anyone run into this, and been able to resolve the issue? Anything else I could try to do besides running far far away from Windows?

  • @shortopock I have also run into the problem and have not been able to resolve it. I use windows very rarely and have stopped updating it as a result of this problem. I tried any number of solutions suggested on windows forums without success.

  • @jonpaul
    As a proper Antergos install should not cause these problems, some questions come to my mind:

    • Do you have EFI or legacy boot system(s)?
    • How did you install Antergos? In particular partitioning and possible EFI partition usage is interesting.
    • Have you tried Windows rescue systems and other Windows troubleshooting possibilities?
  • I have this too on 3 different Bios systems, seems to be related to the fact that MBR is overwritten by grub.
    If I reset MBR with win rescue, update wents fine.

    So as a hacky workaround I backup the win10 MBR, so can recopy it for the update, and afterwards I recopy grub MBR… (dd can do so)

dual boot24 windows 1011 windows107 windows 10 dual3 Posts 5Views 461
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.