• Screensaver not working, alternatives?


    My screensaver isn’t working., Are their any Deeping alternatives or do I need to try a different DE session?

    Thanks!

  • Is screensaver enabled in your settings?

  • @bryanpwo Yes it is and it’s the darndest thing. The settings won’t stick.

  • Since your new to Antergos, I’m assuming your using the default Antergos greeter.
    Don’t get me wrong, there’s nothing wrong with that one, but Deepin doesn’t play that well with settings that isn’t Deepin related.
    If you want the full Deepin experience, so also a smooth working screensaver, then do the following:

    Open your terminal and type the following command:

    sudo nano /etc/lightdm/lightdm.conf

    Then go with your arrow key down to the line:

    greeter session=lightdm-webkit2-greeter

    and change it into:

    greeter session=deepin-session-ui

    Then go to the end of the text and save it. (underneath the screen you’ll see how you can do that and ^ is the control key, in case you don’t know)
    Restart and your system will start with the official Deepin greeter.

  • @bryanpwo Wow Bryan, thanks for taking the time to give me this information. I will do it. I’m used to XFCE and Enlightment (back in the late 90s, believe it or not), as well as MATE and Gnome. Gnome is my favorite o far. I’ll switch this afternoon and see how it goes.

    Again thanks for your kind help!

  • This post is deleted!
  • I’ve read your deleted post, does this mean you’ve figured it out?

  • must be there inside

    [Seat:*] erea of the file /etc/lightdm/lightdm.conf

    greeter-session=lightdm-webkit2-greeter

    and it is greeter-session= not greeter session=

  • @bryanpwo Nope, even with the following suggestions, which it spelled correctly after all in my .conf file.

    I’m feeling ready to go back to Gnome and get it over with. I’ll look into how to do that. Tx!

  • Hello, I wanted to follow up on this topic, I’m having the same issue as stated in the OP, and was looking into switching to deepin.

    However, the package manager wants to remove clutter and cogl in order to install deepin-session-ui, which google search reveals is a big part of gnome shell.

    Thoughts?

  • @NonDScript
    It will be replaced by the Deepin version of cluttere ang cogl, don’t worry Gnome will work with those too.

  • @bryanpwo said in Screensaver not working, alternatives?:

    @NonDScript
    It will be replaced by the Deepin version of cluttere ang cogl, don’t worry Gnome will work with those too.

    Hmmm, well I just did the install, changed the line in the config, did sort super + L to see what the lock screen looks like, it was the same, so I just rebooted, and I’m looking at a black screen where the login screen should be.

    Could it be caused I’m using a non default theme?

    How can I fix this?

  • Well this sucks, lol what I feared happened, I can’t get back into the distro.

  • @NonDScript
    Can you get in tty or have you tried it with the lts kernel?

  • what’s a TTY?

  • @nondscript said in Screensaver not working, alternatives?:

    what’s a TTY

    Early user terminals connected to computers were electromechanical teleprinters or teletypewriters (TeleTYpewriter, TTY), and since then TTY has continued to be used as the name for the text-only console although now this text-only console is a virtual console not a physical console.

    There are 6 virtual consoles in linux accessed by the keyboard shortcuts Ctrl+Alt+F1 to Ctrl+Alt+F6. You can move away from a virtual console (move the console to the background) by using the keyboard shortcut Ctrl+Alt+F7.

  • Very informative, thank you.

    I guess i’ll have to figure out how to get to a console prompt .

  • @nondscript there are two options:

    • boot without starting graphical environment, by accessing grub menu and edit entry by pressing “e” and adding a 1 right after “quiet” and boot with this parameter by pressing [ctrl+X]

    • boot till it is booted and failed to start graphical environment and press [ctrl+alt+F2]

    then you should be able to login and run commands from text console terminal.

  • Alright, I’ll give that a try, any commands or guides I should type or read that I can do try right away?

    I’m asking so hopefully I can have something to try right away.

  • do you have this exactly inside /etc/lightdm/lightdm.conf ?

    greeter-session=lightdm-deepin-greeter
    

    or what do you have done?

deepin60 screensaver12 Posts 24Views 863
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.