• Question: How to set default DE in login manager


    I’ve got multiple DE’s installed, Gnome, XFCE etc but I want to make one the default selection.

    Also is there a way to enable auto-login, I tried it in Gnome’s User Accounts settings but it seemed to have no affect.

  • I’ve got multiple DE’s installed, Gnome, XFCE etc but I want to make one the default selection.

    Also is there a way to enable auto-login, I tried it in Gnome’s User Accounts settings but it seemed to have no affect.

  • I’ve been wondering this myself. I’ve tried the user-session setting in lightdm.conf, but it seems to be ignored. I’ve also checked the .dmrc file in my home directory, and it shows the last session I logged in with, but it doesn’t seem to ‘stick’ for the next time I login. It’s kind of frustrating having to pick a DE every time I login because lightdm doesn’t seem to remember my last choice.

  • Hi,

    The issue of session not being retained upon reboot will be corrected in the next update. If you use one DE more often than the other you can set it as the default session in lightdm.conf. That is what will be selected at each boot until the fix is released.

    To enable auto-login see the instructions here: [https://wiki.archlinux.org/index.php/LightDM#Enabling_autologin][0]">[https://wiki.archlinux.org/index.php/Li][1] … _autologin

    Cheers

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/Li

  • @“lots.0.logs”:2vqcu8ih said:

    If you use one DE more often than the other you can set it as the default session in lightdm.conf. That is what will be selected at each boot until the fix is released.[/quote:2vqcu8ih]

    How? I’ve tried the user-session=gnome/xfce/etc. option in /etc/lightdm/lightdm.conf, but it appears to do nothing. Every time I logout / reboot I’m always given the DE that was setup when I first installed Antergos from CD, Cinnamon.

  • Each field in the config file appears twice. The one that is used is always the second appearance. Make sure you changed it in the correct place. Let me know if that helps.

    Best Regards,
    Dustin

  • @“lots.0.logs”:3tswxibv said:

    Each field in the config file appears twice. The one that is used is always the second appearance. Make sure you changed it in the correct place. Let me know if that helps.

    Best Regards,
    Dustin[/quote:3tswxibv]

    Confirmed, I have been changing the second instance of the field and it doesn’t appear to be working.

Posts 7Views 1512
Log in to reply