• xauth: file /home/myself/.serverauth.XXXX does not exist


    Hi,

    After the last updates (yesterday) of the packages listed below I get the ( .serverauth.XXXX does not exist) warning after every auto startx (xinit).

    [2018-03-13 21:21] [ALPM] upgraded smbclient (4.7.5-1 -> 4.7.6-1)
    [2018-03-13 21:21] [ALPM] upgraded xorg-xbacklight (1.2.1-1 -> 1.2.2-1)
    [2018-03-13 21:21] [ALPM] upgraded xorg-xrdb (1.1.0-2 -> 1.1.1-1)
    [2018-03-13 21:21] [ALPM] upgraded xorg-xinit (1.3.4-4 -> 1.4.0-1)
    [2018-03-13 21:21] [ALPM] upgraded xorg-xlsclients (1.1.3-1 -> 1.1.4-1)
    [2018-03-13 21:21] [ALPM] upgraded xorg-xprop (1.2.2-1 -> 1.2.3-1)
    [2018-03-13 21:21] [ALPM] upgraded xorg-xrefresh (1.0.5-1 -> 1.0.6-1)
    [2018-03-13 21:21] [ALPM] upgraded xorg-xset (1.2.3-1 -> 1.2.4-1)
    [2018-03-13 21:21] [ALPM] upgraded xorg-xsetroot (1.1.1-2 -> 1.1.2-1)
    [2018-03-13 21:21] [ALPM] upgraded xorg-xwininfo (1.1.3-1 -> 1.1.4-1)
    

    I don’t use a DM but auto startx with bash_profile which contains this :

    #
    # ~/.bash_profile
    #
    
    [[ -f ~/.bashrc ]] && . ~/.bashrc
    
    #if [ -z "$DISPLAY" ] && [ -n "$XDG_VTNR" ] && [ "$XDG_VTNR" -eq 1 ]; then
    #   startx > /tmp/xsession-errors 2>&1
    #fi
    
    if [[ ! $DISPLAY && $XDG_VTNR -eq 1 ]]; then
       startx -- > /tmp/xsession-errors 2>&1
    fi
    

    And my .xinitrc :

    #!/bin/sh
    
    userresources=$HOME/.Xresources
    usermodmap=$HOME/.Xmodmap
    sysresources=/etc/X11/xinit/.Xresources
    sysmodmap=/etc/X11/xinit/.Xmodmap
    
    # merge in defaults and keymaps
    
    if [ -f $sysresources ]; then
    
    
    
    
    
    
    
        xrdb -merge $sysresources
    
    fi
    
    if [ -f $sysmodmap ]; then
        xmodmap $sysmodmap
    fi
    
    if [ -f "$userresources" ]; then
    
    
    
    
    
    
    
        xrdb -merge "$userresources"
    
    fi
    
    if [ -f "$usermodmap" ]; then
        xmodmap "$usermodmap"
    fi
    
    # start some nice programs
    
    if [ -d /etc/X11/xinit/xinitrc.d ] ; then
     for f in /etc/X11/xinit/xinitrc.d/?*.sh; do
      [ -x "$f" ] && . "$f"
     done
     unset f
    fi
    
    #twm &
    #xclock -geometry 50x50-1+1 &
    #xterm -geometry 80x50+494+51 &
    #xterm -geometry 80x20+494-0 &
    #exec xterm -geometry 80x66+0+0 -name login
    export DE="xfce"
    exec startxfce4
    

    It was working properly before the updates and as far as I remenber the file serverauth.XXXX was stocked in /tmp and not in my /home like it’s trying to do now.

    I have deleted ~/.Xauthority without success and the warning is still occuring.

    Even with this error, X sounds to work without problems.

    Any help is apprecieted.

    Thanks.

  • I found the culpit ! It’s /usr/bin/startx. Here are the lignes that makes the difference :

    In the previous version :
    
    # create a file with auth information for the server. ':0' is a dummy.
        **xserverauthfile=`mktemp -p /tmp serverauth.XXXXXXXXXX`** 
        trap "rm -f '$xserverauthfile'" HUP INT QUIT ILL TRAP KILL BUS TERM
        xauth -q -f "$xserverauthfile" << EOF
    add :$dummy . $mcookie
    EOF
    
    And the new version which sucks in the head :
    
    # create a file with auth information for the server. ':0' is a dummy.
        **xserverauthfile=$HOME/.serverauth.$$**
        trap "rm -f '$xserverauthfile'" HUP INT QUIT ILL TRAP KILL BUS TERM
        xauth -q -f "$xserverauthfile" << EOF
    add :$dummy . $mcookie
    EOF
    

    I don’t know why they changed it but the result is crapy.

    I’ll test to the previous /tmp place and report te result.

    A second error is showing up with the new version :

    sed: -e expression n°1, caractère 54: option inconnue pour `s'
    

    Which sounds related to this lines :

    Previous version :
    
    # Automatically determine an unused $DISPLAY
    d=0
    while true ; do
        [ -e /tmp/.X$d-lock ] || break
        d=$(($d + 1))
    done
    defaultdisplay=":$d"
    unset d
    
    New version :
    
    # Automatically determine an unused $DISPLAY
    d=0
    while true ; do
        [ -e "/tmp/.X$d-lock" -o -S "/tmp/.X11-unix/X$d" ] || break
        d=$(($d + 1))
    done
    defaultdisplay=":$d"
    unset d
    

    Any comment is welcome.

  • After this morning xinit update, the second error is gone.

    To avoid your /home to be spamed with .severauthXXXX files, you can change the place where they are stocked like in the above exemple (/tmp) as it was before the update.

  • Third update in 5 days, sounds like it has been coded with a spoon and feet…!

    P.S. With the previous update, the /home/.serverauth.XXXX are removed automaticaly (a progress !) , so no need to change the /usr/bin/startx to get rid of ~/.severauth.XXXX spams !

    Let see what news will this last update introduce…

  • Edit : Last but not list, the .serverauth.XXXX is again stored in /tmp like before all this updates.

    One step forward one backward and so on… 🤕

exist4 xauth1 Posts 5Views 1174
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.