• Error al actualizar el sistema


    Al hacer un pacman -Syu me da este error y no actualiza.

    error: error al realizar la transacción (archivos en conflicto)
    filesystem: /bin existe en el sistema de archivos
    filesystem: /sbin existe en el sistema de archivos
    filesystem: /usr/sbin existe en el sistema de archivos
    Ocurrieron errores, no se actualizaron paquetes

    La verdad es que no se como solucionarlo, he estado mirando el foro de Archlinux pero no me aclaro con el ingles.

  • Al hacer un pacman -Syu me da este error y no actualiza.

    error: error al realizar la transacción (archivos en conflicto)
    filesystem: /bin existe en el sistema de archivos
    filesystem: /sbin existe en el sistema de archivos
    filesystem: /usr/sbin existe en el sistema de archivos
    Ocurrieron errores, no se actualizaron paquetes

    La verdad es que no se como solucionarlo, he estado mirando el foro de Archlinux pero no me aclaro con el ingles.

  • Buenas

    Por lo general, con estos 3 comandos bastaran

    # pacman -Syu --ignore filesystem,bash
    # pacman -S bash
    # pacman -Su

    con sudo.

    Si falla es porque hay algun paquete externo a los repos de arch/antergos que puede tenerte algo en los directorios que no son /usr/bin. Tendrias que eliminarlos

  • Ahora lo tengo claro, tengo que desinstalar todos los paquetes instalados desde AUR. y hacer el proceso de update como lo indicas.:

    # pacman -Syu --ignore filesystem,bash
    # pacman -S bash
    # pacman -Su

    Supongo que después podre instalar sin problemas todos los paquetes del AUR que desinstale para la actualización.

  • No es necesario que borres todos los paquetes que instalaste desde AUR,solo aquellos que usan directorios que no son /usr/bin, como por ejemplo /sbin

Posts 5Views 1827
Log in to reply