• After using it for a while, Antergos gets back to login screen


    Hi everybody,

    I’ve recently moved from Ubuntu to Antergos (which is very cool, btw!), but something strange is happening.

    Time to time, while using it, the OS gets unexpectedly back to the login screen.
    Once I’ve logged in again, every page I was working on is gone - as if I have just booted in.

    Can you help me with this please?

    Thanks everybody!

  • can you plz provid emore info and journal:

    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    

    this will automatic pastebin systemspecs and journal and give an url of it you can post here.

  • This post is deleted!
  • Hi,

    Sorry I couldn’t edit my post to paste the link.

    I have the same issue since today, here’s the log : https://ptpb.pw/Z6zk

  • @sodaformulas said in After using it for a while, Antergos gets back to login screen:

    Sorry I couldn’t edit my post to paste the link.

    that’s a forumbug ;)

  • @SodaFormulas

    Process 750 (Xorg) of user 0 dumped core.
    Stack trace of thread 767: ....
    

    Looks like xorg is crashing…

    and together with lightdm-webkit2 coredumping this is repeating lot a times inside your journal…

    you can try changing to GDM or using lightdm-gtk-greeter instead of webkit-greeter

    You are on GNOME ? as i can see lot of deepin stuff around?

    changing DM (GDM LIGHTDM SDDM): https://antergos.com/wiki/desktops/installing-display-managers/

    changing from webkit greeter to gtk greeter:

    sudo nano /etc/lightdm/lightdm.conf
    

    and change the line: greeter-session=lightdm-gtk-greeter

  • Thank you.

    I’m on Deepin. The crashes only appeared today, there was a Xorg update last night.

    I’ll try to install another desktop environment in the meantime, not Gnome though, I don’t like it.

    I hope a patch will fix the issue, I quite like Deepin.

    Thanks for the advice.

  • @sodaformulas said in After using it for a while, Antergos gets back to login screen:

    there was a Xorg update last night.

    what exactly was inside the update?

    2018-01-31 was last update for xorg-server and xorg-server-common

  • [2018-03-11 00:31] [ALPM] upgraded xorg-xdriinfo (1.0.5-2 -> 1.0.6-1)
    [2018-03-11 00:31] [ALPM] upgraded xorg-mkfontscale (1.1.2-1 -> 1.1.3-1)
    [2018-03-11 00:31] [ALPM] upgraded xorg-iceauth (1.0.7-1 -> 1.0.8-1)

  • @joekamprad

    I’ve just tried as you suggested.

    Changing to gtk actually didn’t help. Now I’ve just tried to change DM and so far it hasn’t crashed.

    Do you think I should get back to webkit since I’ve tried the other options or the two can work together?

    Many thanks!

  • @lucavax i would as allways revert to the state before when i try something out and it did not work for me, this keeps system clean! So revert settings for lightdm back to webkit greeter, uninstall gtk greeter.

  • @joekamprad

    Yes, you’re right!

    Anyway, today the OS has not crashed yet. So I guess I can say that the problem has been solved with changing DM (GDM LIGHTDM SDDM).

    Thank you very much!

  • …You wouldn’t believe it, but as soon as I posted this, it started crashing again. The only thing I’ve done is reverting settings for lightdm… so I guess I wasn’t right.

  • @lucavax

    Nothing. I reversed it and it started again anyway.
    Here some info as required on journal and so on: https://ptpb.pw/ZLS8

    (so sorry to post on and on, but I couldn’t edit my previous messages - everytime I try, it pops out that I have lost my connection to the Forum (which btw is pretty strange).

  • @lucavax said in After using it for a while, Antergos gets back to login screen:

    (so sorry to post on and on, but I couldn’t edit my previous messages - everytime I try, it pops out that I have lost my connection to the Forum (which btw is pretty strange).

    This is a unsolved forum bug…

  • By reverting settings I mean only settings, not reverting to lightdm!
    As you say GDM/SDDM is working use this, but keep settings for lightdm in original state to prevent from problems if you went back to it later!

  • @joekamprad

    I probably didn’t get it right…

    So revert settings for lightdm back to webkit greeter, uninstall gtk greeter.
    

    I just changed it back from “greeter-session=lightdm-gtk-greeter” to “greeter-session=lightdm-webkit2-greeter” as it was before, nothing else, but I let DM changed as you suggested, because I thought it worked it out.
    But so far it actually has not, so probably when I tried that out it didn’t crash immediately as before, but it also didn’t get fixed.

    Btw you say to “uninstall gtk greeter”. What do you mean exactly? I’m sorry, I really don’t know anything about this.
    I thought changing that line in “/etc/lightdm/lightdm.conf” was enough. Did I have to install something?

  • What @joekamprad meant was to change the Lightdm settings to the original settings (webkit2 instead of gtk greeter), in case you need it in future use.
    Now you went back to use Lightdm as the default DM by changing the line “greeter-session=lightdm-webkit2-greeter”
    Since this doesn’t work for you currently, just go back to the DM that didn’t crash for you (SDDM or GDM)
    And after that literally uninstall the gtk greeter.

  • This post is deleted!
  • Well, just to be sure that something didn’t go wrong during the installation process, I’ve re-installed Antergos with Deepin instead of Gnome.

    It still crashes back to the login page, so - as you probably already know - I guess it’s not an issue of the desktop environment.

    Any other suggestion?

    It’s really annoying - just because if it crashes in the middle of any work, you can’t get it back.

login120 gets3 Posts 37Views 1760
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.