• Install with ZFS mirror


    I have an Intel NUC and install (2) samsung SSD into it.
    they are 512gb and show as /dev/nvme0n1 and /dev/nvme1n1
    I’ve been trying to do a clean install of zfs creating a mirror of these two. I suspect the installer doesn’t work too well with this as it keeps failing with various random errors. I tried fdisk removing everything and starting from scratch but same random issues.
    I then tried just zfs to one disk without the mirror and it still failed. my thought now is to use the terminal to manually configure zfs via command line, install to that, then configure the pool and mirror after the fact. but can’t find the commands to accomplish this. anyone get zfs to install clean ? anyone get it with a mirror between 2 disks?

  • maybe @dtschmitz knows, you have a few posts regarding ZFS. otherwise i’ll just use ext4 and mdadm to make a raid 1 but that is way less exciting as a zfs mirror.

  • @bigboat said in Install with ZFS mirror:
    Hi,

    I’m afraid the installer has problems when using devices like /dev/nvme0n1 and /dev/nvme1n1

    Check your installer version. If it’s lower than 0.14.419 you could try to update it with a newer zfs.py file

    https://raw.githubusercontent.com/Antergos/Cnchi/0bffd131731b4fa17b672ffcd3663c1ba589ac78/src/pages/zfs.py

    It should go into /usr/share/cnchi/src/pages folder.

    Tell us if it helped.

  • Well that worked great! thanks! I was just giving up and using a btrfs install. But using this zfs.py it completed the install with no issues at all. Upon reboot I encountered this exactly: https://github.com/Antergos/Cnchi/issues/825
    but i ran zpool import -f Main and rebooted again and I’m in.
    running zpool list and zpool status everything looks decent.
    Thanks!☺

zfs40 mirror4 Posts 4Views 105
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.