• Installer Error KDE


    Hi, today I installed Antergos at work and liked it so much I thought I would at home too.
    I’ve done everything the same but when I go to complete the install I get an error (https://imgur.com/l2qSKlU).

    I would like to install the KDE version.
    Any help would be appreciated.
    Many thanks

  • Can you describe the error? The image of the screenshot is pixelated.

    Tip: Try rebooting the computer and installing it again, make sure you are connected to the internet, if the connection is bad try installing using a wired connection (that blue cable).

  • Hi,

    I have tried rebooting and re-installing but with no luck.
    The error reads, cannot create download package list (metalinks)
    Error 1007107.
    Strange because I didn’t have this problem today at work.
    I am currently using a wired connection and have been browsing the internet on the trial.

  • @JimJam
    Cnchi allows to vary mirrors used for installation. Try to use this feature, to use mirrors other than default ones.

  • @just Hi I have tried the “Let Cnchi sort the mirrors” and “leave mirrors list as they are” both giving metalink errors.

    I have not tried to manage them myself as I am newbie and not sure what ones I need.

  • Maybe it’s related to one of the software options chosen in the last steps of the installation, one thread here on the forum was having issues with the Flash option.

    Similar errors reported on GitHub:

    https://github.com/Antergos/Cnchi/search?o=desc&q=metalink&s=created&type=Issues&utf8=✓

    Maybe there’s a solution in one of the reported errors.

  • Tried without flash etc.
    I have just recreated my installer media. This time with rufus.
    Will see how I get on.

  • 2018-03-05 17:38:09 [ERROR] pac.py(567) cb_log(): could not open file /var/lib/pacman/sync/antergos.db: Unrecognized archive format
    2018-03-05 17:38:09 [ERROR] metalink.py(118) create(): Unable to create download queue for package antergos-mirrorlist. An exception of type TypeError occured. Arguments:
    ("‘NoneType’ object is not subscriptable",)
    2018-03-05 17:38:09 [ERROR] download.py(150) create_metalinks_list(): Error creating metalink for package antergos-mirrorlist. Installation will stop
    2018-03-05 17:38:09 [ERROR] download.py(182) create_metalinks_list(): Can’t create download set. An exception of type InstallError occured. Arguments:
    (‘Error creating metalink for package antergos-mirrorlist. Installation will stop’,)
    2018-03-05 17:38:09 [ERROR] process.py(130) run(): ‘Cannot create download package list (metalinks).’
    2018-03-05 17:38:09 [ERROR] process.py(135) run(): Traceback (most recent call last):
    2018-03-05 17:38:09 [ERROR] process.py(135) run(): File “/usr/share/cnchi/src/installation/process.py”, line 92, in run
    self.create_metalinks_list()
    2018-03-05 17:38:09 [ERROR] process.py(135) run(): File “/usr/share/cnchi/src/installation/process.py”, line 82, in create_metalinks_list
    raise misc.InstallError(txt)
    2018-03-05 17:38:09 [ERROR] process.py(135) run(): misc.extra.InstallError: ‘Cannot create download package list (metalinks).’

  • @jimjam said in Installer Error KDE:

    could not open file /var/lib/pacman/sync/antergos.db: Unrecognized archive format

    this mean one of the mirrors are not in sync, or have another error… or from your location there are banned countries, and one of the mirror is from one of the banned countries…

  • I am from UK, so what countries do you think would be banned?

  • @jimjam said in Installer Error KDE:

    I am from UK, so what countries do you think would be banned?

    i do not know that, as far as i know UK is blocking alot websides… so it is possible …

    this “Unrecognized archive format” mostly is caused by the fact that on ry to download the db file mirror shows an errorpage, or caused by banning the webside an notification is shown instead of the db file, and “downloader” see that this file is not the db…

  • so sorting the list by hand would be the best…

  • I went back.
    Set my DNS to Googles public DNS.
    I then tested all the mirrors to see if I had access and then proceeded to install.
    So far I have gotten further than previous attempts.

    Hopefully this is the solution.

  • Solution: Setting my DNS to 8.8.8.8 allowed me to install with no errors.

  • @jimjam so blame your ISP!
    I do change to other free DNS, and never use the ones from ISP.

    Good find Mr. !

error311 kde185 installer58 Posts 16Views 1114
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.