• Wi-fi disconnects on login


    Hey
    I’ve noticed that my wi-fi always disconnect itself on login. When I log in my system, I’m connected, but then it disconnects me from the network. I don’t know what it’s happening, tbh, and I don’t know if this is a problem with KDE, I never had a problem like this with other distros. It also happens on my university wi-fi, for whatever reason.

  • Hi. :)
    It is super hard to help diagnose this issue as you don’t tell us any information.
    Could you please
    rfkill list wifi
    iwconfig
    output those.
    Please ensure you use the correct coding for your output.
    There is a forum post that explains how to do this properly.
    Do you have lspci ? If so, output it.
    what kernel are you using? LTS or not?
    Also, do journalctl -xr Is there anything relevant to wifi?

    Have you had a look at the very well known and often, never read Arch Wiki?

    https://wiki.archlinux.org/index.php/NetworkManager#KDE_Plasma
    and
    https://wiki.archlinux.org/index.php/NetworkManager#Troubleshooting
    Also, maybe it’s a power drain that’s having your wifi disconnect.
    Have you done any preliminary research into this?
    https://wiki.archlinux.org/index.php/Power_management#Network_interfaces

    As a quick solution, see if this works
    systemctl disable dhcpcd.service
    systemctl stop dhcpcd.service
    then reboot.
    If no good solution, then return to default settings again as obviously those changes didn’t do anything.
    Post back here. :)

  • Sorry for not replying early, here’s the output.
    rfkill:

    rfkill list wifi
    1: phy0: Wireless LAN
            Soft blocked: no
            Hard blocked: no
    
    
    wlp3s0    IEEE 802.11  ESSID:"IFSP BRT"  
              Mode:Managed  Frequency:2.462 GHz  Access Point: 90:F6:52:D1:D3:B6   
              Bit Rate=1 Mb/s   Tx-Power=20 dBm   
              Retry short limit:7   RTS thr:off   Fragment thr:off
              Power Management:on
              Link Quality=37/70  Signal level=-73 dBm  
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:1  Invalid misc:4   Missed beacon:0
    
    lo        no wireless extensions.
    
    enp2s0    no wireless extensions.
    
    

    lspci:

    lspci
    00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v6/7th Gen Core Processor Host Bridge/DRAM Registers (rev 02)
    00:02.0 VGA compatible controller: Intel Corporation HD Graphics 620 (rev 02)
    00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller (rev 21)
    00:14.2 Signal processing controller: Intel Corporation Sunrise Point-LP Thermal subsystem (rev 21)
    00:15.0 Signal processing controller: Intel Corporation Sunrise Point-LP Serial IO I2C Controller #0 (rev 21)
    00:16.0 Communication controller: Intel Corporation Sunrise Point-LP CSME HECI #1 (rev 21)
    00:17.0 SATA controller: Intel Corporation Sunrise Point-LP SATA Controller [AHCI mode] (rev 21)
    00:1c.0 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #1 (rev f1)
    00:1c.4 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #5 (rev f1)
    00:1c.5 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #6 (rev f1)
    00:1f.0 ISA bridge: Intel Corporation Sunrise Point-LP LPC Controller (rev 21)
    00:1f.2 Memory controller: Intel Corporation Sunrise Point-LP PMC (rev 21)
    00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
    00:1f.4 SMBus: Intel Corporation Sunrise Point-LP SMBus (rev 21)
    01:00.0 3D controller: NVIDIA Corporation GM108M [GeForce 920MX] (rev a2)
    02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller (rev 07)
    03:00.0 Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 31)
    
    

    On journalctl -xr there was a lot of “suplicant interface” from network mananger.

    Right now I’m at the university, and looking at the system settings, my connection on the university (IFSP BRT) doesn’t have any security, while my wifi at home uses the standard WPA/WPA2, with a password. I started my system and it didn’t disconnected me, it just appeared the prompt to log on the firewall (to access the net).
    If I do this proccess at home, will the results be different? I’ll try it later and post it here. Thanks so far

  • @looking4afix said in [Wi-fi disconnects on login]

    Right now I’m at the university, and looking at the system settings, my connection on the university (IFSP BRT) doesn’t have any security, while my wifi at home uses the standard WPA/WPA2, with a password. I started my system and it didn’t disconnected me, it just appeared the prompt to log on the firewall (to access the net).
    If I do this proccess at home, will the results be different? I’ll try it later and post it here. Thanks so far

    Hi. First of all, don’t worry about being late to post. I"m late to post too many times. IT’s all good.
    Secondly, I don’t believe I understand what your’re saying here?
    Your’re asking / saying if it’ll be different if you logon at either at home or at your university?
    I understand there’s no security at one place and you’ve a password at the other place and that at one place (not sure which one) you didn’t get bumped off from your wifi.
    You’re also asking that if you logon at home if you’ll be bumped off the wifi?
    I don’t know.
    I guess there’s only one way to find out.

    Had you a look at the 3 Arch wiki links I provided earlier?

    Something else that comes to mind and that is that the firmware isn’t loaded for your machine that is one of the reasons why you have no wireless extension ; however, this wouldn’t make sense because you say you can connect to the wifi with your laptop at the university.

    Also, I see that from your output you have power management on. That is a good thing. So at least we’re clear there.

    Are you having connection time out issues?
    link text
    do this first journalctl [email protected]

  • Uh, I got confused in my own thoughts. Lemme try to explain better: For some reason, when I log into my machine in my home, the internet disconnects itself, show a message (which I didn’t had time to see yet), and show three little dots “…” on the wifi symbol (I’m using KDE, with Arc theme), it looks like I’m connected to the web, but I need to disconnect and connect my wifi, to navigate probably. however that doesn’t happen on the university. I’m wondering if 1) it’s because my wi-fi route is misconfigured, or 2) it’s a problem with my laptop to connect to the wifi because it has a password.

    If it’s the second case, it would be difficult, since I entered my password, and it’s saved on the network configuration menu on kde settings.

    I checked the links, I have plasma-nm installed, in the troubleshooting, nothing was looking similar to what I have.

    The command you asked:

    journalctl [email protected]
    -- Logs begin at Sun 2018-02-25 20:24:22 -03, end at Tue 2018-03-06 21:16:58 -03. --
    -- No entries --
    
    

    which is funny, because I connected to my house wifi in the saturday.

    I hope I clarified what I have been experiencing, sometimes I get stuck at the language barrier.

  • I can confirm this issue, it’s happening with me too, started a few days ago, maybe an upgrade that went south, probably a bug.

    I’m using KDE too, everytime I login now the wifi doesn’t connect automatically, I have to click on the icon and select my wifi then it connects.

  • log:

    mar 06 22:26:07 z NetworkManager[332]: <info>  [1520385967.0754] device (wlp7s0): supplicant interface state: disabled -> inactive
    mar 06 22:26:07 z NetworkManager[332]: <info>  [1520385967.0651] device (wlp7s0): supplicant interface state: scanning -> disabled
    mar 06 22:26:07 z NetworkManager[332]: <info>  [1520385967.0149] device (wlp7s0): set-hw-addr: set MAC address to MAC ADDRESS (scanning)
    mar 06 22:26:07 z NetworkManager[332]: <info>  [1520385967.0055] device (wlp7s0): state change: failed -> disconnected (reason 'none', sys-iface-state: 'managed')
    mar 06 22:26:07 z NetworkManager[332]: <warn>  [1520385967.0035] device (wlp7s0): Activation: failed for connection 'NAME OF MY CONNECTION'
    mar 06 22:26:07 z wpa_supplicant[376]: wlp7s0: Reject scan trigger since one is already pending
    mar 06 22:26:07 z kernel: IPv6: ADDRCONF(NETDEV_UP): wlp7s0: link is not ready
    mar 06 22:26:07 z kernel: IPv6: ADDRCONF(NETDEV_UP): wlp7s0: link is not ready
    mar 06 22:26:07 z NetworkManager[332]: <info>  [1520385967.0025] manager: startup complete
    mar 06 22:26:07 z NetworkManager[332]: <info>  [1520385967.0022] manager: NetworkManager state is now DISCONNECTED
    mar 06 22:26:07 z NetworkManager[332]: <info>  [1520385967.0014] device (wlp7s0): state change: need-auth -> failed (reason 'no-secrets', sys-iface-state: 'managed')
    

    Weird issue indeed, after login, the wifi icon keeps trying to connect(circle animation), then it changes to the “?” icon and 2 pop-ups show up:

    • password was not provided
    • connection was deactivated

    But if I manually click the wifi icon and connect, it works.

  • The error is being reported on the Manjaro Forums too by another KDE user: https://forum.manjaro.org/t/network-manager-megathread/37243/81

    Maybe there’s something wrong with networkmanager package.

  • Hi everyone.
    A couple of things interest me.
    Firstly, I understand that a bug at bugzilla has been stated.
    HOnestly, I really don’t know how to proceed from here as it’s obviously a scenario experienced by many others in the LInux world using KDE.

    What else interests me is this:
    failed (reason 'no-secrets', sys-iface-state: 'managed'

    If you like, you can all output journalctl -u NetworkManager and we can see a bit better.
    I don’t think solutions are working until a bit more emphasis on seeing what’s happening.

    Also, @looking4afix . Your output that you gave in normal.
    If you were getting something like this:

    -- Logs begin at Sun 2018-02-25 20:24:22 -03, end at Tue 2018-03-06 21:16:58 -03. --
    -- No entries --
    

    This is basically telling you that you have no logs.

    What you have is saying in your output that you have no logging entries.
    When you have output, try to engage yourself in understanding what your output is and if possible, see if it makes sense to you.
    So your output says that there’s no logging. That’s all.

    The other thing is that because it’s a bug, I hate to say it but if this problem is persistent throughout, would it help a bit if you folks were able to keep track of this issue and hopefully an update will be soon.

  • I was looking for ‘disconnected’ and found this on journalctl -u NetworkManager :

    mar 07 15:50:43 z NetworkManager[320]: <info>  [1520448643.8078] device (wlp7s0): state change: unavailable -> disconnected (reason 'supplicant-available', sys-if>
    
    .
    .
    .
    
    mar 07 15:50:49 z NetworkManager[320]: <info>  [1520448649.5291] sup-iface[0x55b3ad2ac220,wlp7s0]: wps: type pbc start...
    mar 07 15:50:49 z NetworkManager[320]: <warn>  [1520448649.5305] device (wlp7s0): No agents were available for this request.
    mar 07 15:50:49 z NetworkManager[320]: <info>  [1520448649.5478] device (wlp7s0): supplicant interface state: ready -> disconnected
    mar 07 15:50:49 z NetworkManager[320]: <info>  [1520448649.5490] device (wlp7s0): supplicant interface state: disconnected -> inactive
    mar 07 15:50:49 z NetworkManager[320]: <info>  [1520448649.5539] device (wlp7s0): supplicant interface state: inactive -> scanning
    mar 07 15:51:13 z NetworkManager[320]: <info>  [1520448673.2648] device (wlp7s0): state change: need-auth -> deactivating (reason 'user-requested', sys-iface-stat>
    mar 07 15:51:13 z NetworkManager[320]: <info>  [1520448673.2650] manager: NetworkManager state is now DISCONNECTING
    mar 07 15:51:13 z NetworkManager[320]: <info>  [1520448673.2652] audit: op="device-disconnect" interface="wlp7s0" ifindex=3 pid=540 uid=1000 result="success"
    mar 07 15:51:13 z NetworkManager[320]: <info>  [1520448673.2655] device (wlp7s0): state change: deactivating -> disconnected (reason 'user-requested', sys-iface-s>
    

    They are talking about some sort of race between kwallet and networkmanager on this thread, apparently this issue is going on for weeks and still there’s no solution upstream, some people are trying to patch it but no one is solving it.

    I have a very limited understanding about all of this and I can’t provide any further help. I guess I will just wait until someone figure it out and solve the bug, it looks like this is going to take a while.

  • @ssspacez said in Wi-fi disconnects on login:

    disconnected (reason ‘user-requested’

    Hi @ssspacez
    Can you disable kwallet if your’re not using it.
    Does it make much of a difference in doing so.
    I think I see what might be going on.
    Both apps are “fighting” each other.
    Much like if you were to have 2 network managers.

    I’m going to go out on a limb here but can you try

    systemctl stop dhcpcd.service
    systemctl disable dhcpcd.serviceg

    then:

    systemctl enable NetworkManager
    systemctl start NetworkManager

    If these don’t work, revert back to original settings.

  • @modisc these commands didn’t work(I know there’s a typo ‘serviceg’ but even removing the ‘g’… still no effect), after reboot the issue remains…

    I will be able to login after disabling kwallet?

  • @modisc said in Wi-fi disconnects on login:

    What you have is saying in your output that you have no logging entries.
    When you have output, try to engage yourself in understanding what your output is and if possible, see if it makes sense to you.
    So your output says that there’s no logging. That’s all.

    I understood that it had no logs, I said it was funny because I connected on my house network, got the “error”, but I didn’t returned any logs.

    @ssspacez said in Wi-fi disconnects on login:

    They are talking about some sort of race between kwallet and networkmanager

    The threads you gave date back from 2013, so it’s an old issue. In my case, it makes sense to be Kwallet, because everytime I tried to connect on my network, Kwallet showed a window asking for what type of cryptography I was going to use, I got really annoyed on the issue, and selected the default cryptography, even looked for ways of disabling it, but never did. I’m going to disable and test it.

  • Disabling kwallet solved the issue. I disabled, made my phone as router for internet, connected on it, rebooted the system, and it didn’t had showed any message.

    In this case, I would take issue as solved, but I do want to understand why it was interfering if it.

  • Hi @looking4afix
    I believe it’s because kwallet is holding the ‘secrets’ to release the password for the network until the user interrupts kwallet to release said information.
    Historically, I 've just set a blank password, select next or cancel and that was the end of the nagging kwallet.

  • Apparently they have fixed the bug upstream and some people are saying that it was solved, I can’t test it because I’m using another distro now, but some people are saying it didn’t work for them.

    This is the kind of issue that pushed me away from rolling release, assuming it was fixed, it took 3 months or so, that’s disappointing, essential things like wifi should be a priority.

  • Hi @ssspacez
    Terribly sorry for being tardy in replying.
    I have to agree with you on the statement that wifi is a priority. Could not agree more with you.

login121 wi-fi15 disconnects3 Posts 19Views 1435
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.