• Antergos not launching X server ( Watchdog stuck on #7 CPU )


    I am using Antergos on every PC I have but I bought new one and can not boot…

    Besides error in title is says nouveau: chipset not supported.

    Also a lot of msieport messages from kernel (but can be ignored by appending pci=nomsi to kernel cmd line)

    I tried nomodeset setting but no help.

    Can you try to help me get Antergos working on myy notebook?

    2.8GHz Intel Core i7-7700HQ processor
    Nvidia GeForce GTX 1050 Ti 2GB graphics
    16GB 2,400MHz DDR4 memory

    I am not a completely newbie in Linux so if you want to something know just fire at me!

    Thank you for helping me.

  • @howp
    Blacklist nouveau.

  • Woop my bad, I just tried turning off modeset. Thanks.

  • @howp and install Nvidia drivers

  • sudo pacman -S nvidia-Installer
    sudo nvidia-Installer -f
  • @joekamprad nvidia-installer make my system freeze. Since the logs are in ramdisk I can not get them because only way to shut it is holding powerbutton.

    Using Antergos with KDE

  • Very well this is weird :D I looked at sources of nvidia-installer and its calling lspci, which is freezing my system…


    It appears to be known bug.

  • I solved it (ot was caused again by nouveau even tho the system booted fine), but once the nvidia-installer finishes installation the Linux wont boot, Xserver could not be launched.

  • If it is a notebook I would check if it is an dualgraphics one, with Intel+Nvidia.


  • It is notebook, but still same problem after installing bumblebee :/

  • do you check the options onto graphics inside Bios? do you check

    lspci -vnn | grep '\''[030[02]]' 


  • Of course, I have no option regarding graphic in BIOS.

    And the output from the lspci was basically same as :

    00:02.0 VGA compatible controller [0300]: Intel Corporation Haswell-ULT Integrated Graphics Controller [8086:0a16] (rev 09) (prog-if 00 [VGA controller])


    01:00.0 3D controller [0302]: NVIDIA Corporation GK107M [GeForce GT 750M] [10de:0fe4] (rev ff) (prog-if ff)

    but the dedicated graphic did not have prog-if option

  • I think that only way for me is to force Linux to use just dedicated graphic with official nvidia drivers :/

    Bumblebee no commit for a yearm there is no way then to support new graphic like GTX 1050Ti with combination with Kaby Lake GPU :/

stuck46 cpu22 launching7 watchdog2 Posts 14Views 1226
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.