• WPS Font Rendering VS. LibreOffice


    Hi everyone. I can’t figure out why WPS Office is rendering Times New Roman font as if it’s bold all the time! Please see the picture included.

    WPS vs LO with Times New Roman

    It’s got me scratching my head. I’ve wanted to stay with WPS (compatibility is better than LO for MS Office Users), but I’m having to teach myself how to use the new LO 6.02, and I’m impressed but not really feeling the love.

    Any ideas?

  • I can’t help with fonts rendering in WPS, as I don’t use this suite.

    As for LibreOffice 6, this unusually enthusiastic Dedoimedo’s article might be of some interest:

    LibreOffice 6.0 - Goodness, Gracious, Great Fonts of Fire! February 28, 2018

  • Thank you, @just. I agree that the compatibility with LO is now much better. I guess I’ll have to get used to the work flow of LO if I can’t get the font thing for WPS figured out. Again; I don’t hate LO.

    Thanks for the link! It’s a good read with a lot of information.

  • This post is deleted!
  • I have also posted this question to the WPS Linux Forums. If I find an answer, I’ll link it here.

    If someone does have an answer before then, please let me know.
    TIA

  • And, oddly enough my question is not on their Forums boards any more. 🙄 Oh, well. Maybe it’s a problem with porting the application to Arch. It doesn’t do it in Linux Mint or in Windows. 🤷♂ Hahaha, it could also only be me having this problem.

  • May you need the right fontset installed, I can see ttf-wps-win / 10 on AUR.

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • Hi @joekamprad. I have tried, but I get errors saying the files can’t be found. I’ve been using the ms fonts in the AUR from way-back, and I’ve even downloaded the Windows Fonts from Major Geeks. Still renders the same way. I must have something wrong on my installation. But, thanks for the suggestion. Oh, and I’ve tried the others as well; they all show up weirdly in WPS, but not anywhere else.

  • @adam-worth Umm, out of interest if your WPS screen grab is showing TNR as bold instead of normal - what does it look like if set as bold?

  • Hi @odium-fenestrae. The font weight appears the same, however the kerning expands as if the font was set for bold. It’s weird. I think I must have installed something wrong, but after several uninstalls and installs of fonts and WPS, I don’t know what it could be.

  • @adam-worth I do not use WPS so this suggestion may be up the creek, but from what I can find the fonts for WPS might be installed in different place as for LO. ??

  • @adam-worth Is this not the same problem that you are having?

    WPS Community :
    http://wps-community.org/forum/viewtopic.php?f=34&t=68

    First post 2013, last post 2015 with font display problem still not fixed by WPS.

  • the two packages from AUR ( ttf-wps-fonts) try installing to /usr/share/fonts/wps-fonts/ (i say try as they both not building properly)

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • Hi @odium-fenestrae. Thanks, but that’s a problem with anti-aliasing. Mine was bold. I’ve bit the bullet and reinstalled Antergos, added the MS Fonts first and then installed WPS; what do you know? Everything works perfectly again.

    There’s a big “Go-Figure” for you!

    However, thank you everyone who chipped in to help! Great suggestions and ideas all. Now, to put everything back in it’s place…

  • Thank you, @joekamprad. I reinstalled Antergos, put the MS Fonts in first, then added WPS. Everything’s working perfectly. Thanks for the suggestion, though!!!

font25 rendering5 wps4 Posts 15Views 320
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.