• Application Java Error


    Hi again community, I installed Jdownloader and i have a java error. Someone know how repair it ?

    Copy and paste:

    A fatal error has been detected by the Java Runtime Environment:

    SIGSEGV (0xb) at pc=0x00007f9c6052d3b8, pid=4006, tid=0x00007f9c5e7ea700

    JRE version: OpenJDK Runtime Environment (8.0_162-b12) (build 1.8.0_162-b12)

    Java VM: OpenJDK 64-Bit Server VM (25.162-b12 mixed mode linux-amd64 compressed oops)

    Problematic frame:

    V [libjvm.so+0x6b73b8]

    Core dump written. Default location: /home/eresthorn/.jd/core or core.4006

    If you would like to submit a bug report, please visit:

    http://bugreport.java.com/bugreport/crash.jsp

    --------------- T H R E A D ---------------

    Current thread (0x00007f9c58022800): GCTaskThread [stack: 0x00007f9c5e6eb000,0x00007f9c5e7eb000] [id=4024]

    siginfo: si_signo: 11 (SIGSEGV), si_code: 1 (SEGV_MAPERR), si_addr: 0x0000000000000100

    Registers:
    RAX=0x0000000000000000, RBX=0x00007f9c5e7e9d30, RCX=0x00007f9c5e7e9d50, RDX=0x0000000000000000
    RSP=0x00007f9c5e7e9670, RBP=0x00007f9c5e7e96a0, RSI=0x00007f9c5e7e9d30, RDI=0x0000000000000000
    R8 =0x0000000000000000, R9 =0x0000000000000001, R10=0x0000000000000000, R11=0x0000000000000206
    R12=0x0000000000000000, R13=0x0000000000000000, R14=0x0000000000000000, R15=0x00007f9c5e7e9d30
    RIP=0x00007f9c6052d3b8, EFLAGS=0x0000000000010202, CSGSFS=0x002b000000000033, ERR=0x0000000000000004
    TRAPNO=0x000000000000000e

    Top of Stack: (sp=0x00007f9c5e7e9670)
    0x00007f9c5e7e9670: 0000000000000000 00007f9c5e7e9d30
    0x00007f9c5e7e9680: 00007f9c58ae7000 00007f9c5804de60
    0x00007f9c5e7e9690: 0000000000000000 00007f9c5e7e9d50
    0x00007f9c5e7e96a0: 00007f9c5e7e9d20 00007f9c608acea8
    0x00007f9c5e7e96b0: 00007f9c58022800 00007f9c5e7e96c0
    0x00007f9c5e7e96c0: 00007f9c3b1bfa20 00007f9c490004e7
    0x00007f9c5e7e96d0: 00007f9c490003d0 0000000000000000
    0x00007f9c5e7e96e0: 00007f9c3b1bfa90 00007f9c3b1bfa28
    0x00007f9c5e7e96f0: 00007f9c3b1bfa20 00007f9c490004e7
    0x00007f9c5e7e9700: 00007f9c490003d0 0000000000000000
    0x00007f9c5e7e9710: 00007f9c3b1bfa90 00007f9c3b1bfa28
    0x00007f9c5e7e9720: 00007f9c3b1bbc68 00007f9c3b1bbc6c
    0x00007f9c5e7e9730: 00007f9c3b1bbc60 00007f9c3b1bbc64
    0x00007f9c5e7e9740: 00007f9c3b1bbc58 00007f9c3b1bbc5c
    0x00007f9c5e7e9750: 00007f9c3b1bbc50 00007f9c3b1bbc54
    0x00007f9c5e7e9760: 0000000000000000 0000000000000000
    0x00007f9c5e7e9770: 00007f9c3b1bfa10 00007f9c3b1bfa10
    0x00007f9c5e7e9780: 00007f9c3b1bbc38 00007f9c3b1bbc3c
    0x00007f9c5e7e9790: 00007f9c3b1bbc30 00007f9c3b1bbc34
    0x00007f9c5e7e97a0: 00007f9c3b1bbc28 00007f9c3b1bbc2c
    0x00007f9c5e7e97b0: 00007f9c3b1bbc20 00007f9c3b1bbc24
    0x00007f9c5e7e97c0: 00007f9c3b1bbc18 00007f9c3b1bbc1c
    0x00007f9c5e7e97d0: 00007f9c3b1bbc10 00007f9c3b1bbc14
    0x00007f9c5e7e97e0: 00007f9c3b1bbc08 00007f9c3b1bbc0c
    0x00007f9c5e7e97f0: 00007f9c3b1bbc00 00007f9c3b1bbc04
    0x00007f9c5e7e9800: 00007f9c3b1bbbf8 00007f9c3b1bbbfc
    0x00007f9c5e7e9810: 00007f9c3b1bbbf0 00007f9c3b1bbbf4
    0x00007f9c5e7e9820: 0000000000000000 0000000000000000
    0x00007f9c5e7e9830: 0000000000000000 0000000000000000
    0x00007f9c5e7e9840: 0000000000000000 0000000000000000
    0x00007f9c5e7e9850: 0000000000000000 0000000000000000
    0x00007f9c5e7e9860: 0000000000000000 0000000000000000

    I have this

     [[email protected] ~]$ archlinux-java status
     Available Java environments:
      java-8-openjdk/jre (default)
    

    Ty friends.

    Eresthorn

  • I think i have the solution in this forum but i dont know how use it. Any Idea?

    https://bbs.archlinux.org/viewtopic.php?id=71634

     java -Dsun.java2d.opengl=true  -jar JDownloader.jar
  • @eresthorn
    Hi and welcome to Antergos! 🙂

    You could use an environment variable JAVA_TOOL_OPTIONS, something like:

    export JAVA_TOOL_OPTIONS+=" -Dsun.java2d.opengl=true"
    

    in your ~/.bashrc

    An alternative to the above is to edit the scripts that start JDownloader.jar.
    I believe the scripts are in folder /opt/JDownloader.

    I didn’t test these, so they may or may not work, but worth a try.

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • Or you could simplify the variable setting:

    export JAVA_TOOL_OPTIONS="-Dsun.java2d.opengl=true"
    

    if there are any problems with the previous line.

    Note that using this variable requires that you start your downloader from the terminal.

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • Ty for help. Yesterday with the new java upgrade in the repositories , and jdownloader upgrade, the problem was resolved.

    Ty Manuel 🙂

error281 application26 java12 Posts 5Views 266
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.