• Lightdm problem? - boot to black screen


    Hello,

    I did a fresh install (antergos 18.2 xfce), but the installation boot to a black screen and only the mouse pointer shows up. If I do ctrl+alt+delete the graphical login window appear and I can log in and use the system. Can anybody help?

    sudo systemctl status lightdm:

    
    Feb 27 17:00:46 box systemd[1]: Starting Light Display Manager...
    Feb 27 17:00:46 box systemd[1]: Started Light Display Manager.
    Feb 27 17:00:46 box lightdm[658]: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
    Feb 27 17:00:47 box lightdm[671]: pam_unix(lightdm-greeter:session): session opened for user lightdm by (uid=0)
    Feb 27 17:00:54 box lightdm[757]: pam_unix(lightdm:auth): authentication failure; logname= uid=0 euid=0 tty=:0 ruser= rhost=  user=>
    Feb 27 17:01:03 box lightdm[658]: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
    Feb 27 17:01:03 box lightdm[758]: pam_unix(lightdm:session): session opened for user user by (uid=0)
    
    
  • @dazzled said in Lightdm problem? - boot to black screen:

    systemctl status lightdm

    i get the same error on installed system, and lightdm starts without an issue…
    But i find this hack on ARCHWIKI:

    LightDM does not appear
    It may happen that your system boots so fast that LightDM service is started before your graphics drivers are properly loaded. If this is your case, you will want to add the following config to your lightdm.conf file:

    [LightDM]
    logind-check-graphical=true
    

    This setting will tell LightDM to wait until graphics devices are ready before spawning greeters/autostarting sessions on them.

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad said in Lightdm problem? - boot to black screen:

    @dazzled said in Lightdm problem? - boot to black screen:

    systemctl status lightdm

    i get the same error on installed system, and lightdm starts without an issue…
    But i find this hack on ARCHWIKI:

    LightDM does not appear
    It may happen that your system boots so fast that LightDM service is started before your graphics drivers are properly loaded. If this is your case, you will want to add the following config to your lightdm.conf file:

    [LightDM]
    logind-check-graphical=true
    

    This setting will tell LightDM to wait until graphics devices are ready before spawning greeters/autostarting sessions on them.

    Thanks for reply @joekamprad!

    Uncommented the line in /etc/lightdm/lightdm.conf and edited value from “false” to “true” and still the same problem.

  • @dazzled can you provide logs ans specs then?

    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    

    and post the url it gives out…

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • Issue is fixed.

    In addition to uncomment this line in /etc/lightdm/lightdm.conf and changing the value:

    [LightDM]
    logind-check-graphical=true
    

    I uncommented the line and “set the default greeter by changing the [Seat:*] section of the LightDM configuration file, like so”: https://wiki.archlinux.org/index.php/LightDM#Greeter

    /etc/lightdm/lightdm.conf
    
    [Seat:*]
    ...
    greeter-session=lightdm-webkit2-greeter
    
  • @joekamprad

    Thanks for your pointer to the arch wiki and efforts. I seems to be working out now 🙂

boot249 lightdm121 black62 Posts 6Views 1227
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.