• Deepin randomly mounting partitions at login


    Newly installed deepin - on login deepin wants to mount partitions that are not in fstab on /run/media/… and is asking for a password. I cannot find out why/where it is trying to mount these partitions. It does not do so in my gnome session.

    Umuntu Ngumuntu Ngabantu
    a person is a person through other people

  • @jonpaul I added the partitions to file/etc/fstab and disabled automount. Fixed the problem.

  • Is this right because it’s still trying to mount the disk
    blkid
    /dev/sda5: UUID=“2db21f39-2946-4bf4-b0f6-dce19b0131fa” TYPE=“ext4” PARTLABEL=“Arch” PARTUUID="ac10471e-7038-4a1a-b32c-4bd8aad4be86"
    fstab
    UUID=2db21f39-2946-4bf4-b0f6-dce19b0131fa /run/media/paul/2db21f39-2946-4bf4-b0f6-dce19b0131fa ext4 noauto 0 0

    Umuntu Ngumuntu Ngabantu
    a person is a person through other people

  • @jonpaul partition I mean!

    Umuntu Ngumuntu Ngabantu
    a person is a person through other people

  • @jonpaul
    Maybe these will help:
    https://wiki.archlinux.org/index.php/Systemd#Mounting
    https://wiki.archlinux.org/index.php/Fstab#Automount_with_systemd

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL here.

  • @manuel - they don’t help. and it really is completely random. one boot it’s /dev/sda4 which has windows 10. next boot /dev/sda5 which has arch. next boot /dev/sdb3 which is spare. it happens after the deepin desktop has loaded in a small white window.

    Umuntu Ngumuntu Ngabantu
    a person is a person through other people

  • Found it! The ‘problem’ was in deepin file manager (which handles the desktop) which had automount set on!

    Umuntu Ngumuntu Ngabantu
    a person is a person through other people

  • That’s good to know you’ve managed to fix your problem. Your solution seems to be simpler than mine.
    Anyway, I tried once again my way to fix the issue to see if it works. Looks like it’s fine.

    I ran following command:

    $ sudo blkid /dev/sdaX # X - your partition
    

    and added this line to /etc/fstab file:

    UUID=23C76A604A0E2B5 ntfs noauto # Replace the UUID with yours generated by blkid
    
deepin58 randomly11 partitions11 mounting6 Posts 8Views 358
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.