• Hibernate or suspend doesn't log me out on gdm


    Hi, I don’t like lighdm very much, i installed gdm and enabled it everything is fine except that i made my laptop’s power button suspend my os and lightdm was fine but while using gdm i suspend(or hibernate) and when i get back i’m at exactly where i left of, without being logged out, how can i fix that :D

  • cat /proc/acpi/wakeup
    Also, there is a plethora of info on the all too well known Arch Wiki:
    Power Management

  • Are you using Wayland or Xorg? GDM uses Wayland by default and not everything works under Wayland as well/smooth, try a session with Xorg and see if it functions. There’s a fairly big chance that suspension and hibernate work under Xorg.

  • @modisc
    output of cat /proc/acpi/wakeup

    S-state	  Status   Sysfs node
    USB1	  S3	*disabled
    USB2	  S3	*disabled
    USB3	  S3	*disabled
    USB4	  S3	*disabled
    USB5	  S3	*disabled
    USB6	  S3	*disabled
    USB7	  S3	*disabled
    RP01	  S4	*disabled  pci:0000:00:1c.0
    PXSX	  S4	*disabled
    RP02	  S4	*disabled  pci:0000:00:1c.1
    PXSX	  S4	*disabled  pci:0000:05:00.0
    RP03	  S4	*disabled
    PXSX	  S4	*disabled
    RP04	  S4	*disabled  pci:0000:00:1c.3
    PXSX	  S4	*disabled  pci:0000:09:00.0
    RP05	  S0	*disabled  pci:0000:00:1c.4
    PXSX	  S4	*enabled   pci:0000:0b:00.0
    RP06	  S4	*disabled
    PXSX	  S4	*disabled
    RP07	  S4	*disabled
    PXSX	  S4	*disabled
    RP08	  S4	*disabled  pci:0000:00:1c.7
    PXSX	  S4	*disabled
    PEG0	  S4	*disabled  pci:0000:00:01.0
    PEGP	  S4	*disabled  pci:0000:01:00.0
    PEGA	  S4	*disabled  pci:0000:01:00.1
    PEG1	  S4	*disabled
    PEG2	  S4	*disabled
    PEG3	  S4	*disabled
    BR20	  S4	*disabled
    HDEF	  S4	*disabled  pci:0000:00:1b.0
    EHC2	  S0	*enabled   pci:0000:00:1a.0
    EHC1	  S0	*enabled   pci:0000:00:1d.0
    LID0	  S3	*enabled   platform:PNP0C0D:00
    
  • @bryanpwo I was using xorg and i just tried wayland also, non of them log me out when i hibernate or suspend. i tried lxdm it didn’t work either, only lightdm works :(

  • @hunar1997

    Hi. Only as reference, I give you mine.
    quite similar so not much difference.
    So nothing needs changing.

    Device	S-state	  Status   Sysfs node
    P0P1	  S4	*disabled
    PS2K	  S3	*enabled   pnp:00:02
    PS2M	  S3	*disabled  pnp:00:03
    EHC1	  S3	*enabled   pci:0000:00:1d.0
    XHC	  S3	*enabled   pci:0000:00:14.0
    RP01	  S4	*disabled  pci:0000:00:1c.0
    RP02	  S4	*disabled  pci:0000:00:1c.1
    RP03	  S4	*disabled  pci:0000:00:1c.2
    RP04	  S4	*disabled  pci:0000:00:1c.3
    PXSX	  S5	*disabled  pci:0000:09:00.0
    RP05	  S4	*disabled
    PEG0	  S4	*disabled
    PEGP	  S4	*disabled
    PEG1	  S4	*disabled
    PEG2	  S4	*disabled
    AWAD	  S4	*disabled  platform:ACPI000E:00
    

    Also, something just occurred to me.
    Settings > Power
    Have a look at your power settings.

  • PROBLEM SOLVED
    I forgot about this problem and did some stuff (removing lightdm&lightlocker) but nothing changed, today i searched google and found this there in the question i saw something that i didn’t do

    dconf-editor > org/gnome/desktop/screensaver/ubuntu-lock-on-suspend enabled
    

    i enabled it and everything is fine now :D

suspend46 gdm44 hibernate15 Posts 7Views 598
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.