• HOW TO: Install tar.gz that is not in the AUR


    Hey, I want to install a tar.gz file that is not in the AUR, I tried this for hours and still have not idea how. What I want to install is a crypto wallet, this one to be specific: https://github.com/B3-Coin/B3-CoinV2/releases/tag/v3.1.2.0

    How exactly do you install such a file? I have been looking thorough the wiki and read about pkgbuild etc. but not one is working.

  • @beswaax said in HOW TO: Install tar.gz that is not in the AUR:

    read about pkgbuild

    will not install anything, you will need to build it by hand, or create a PKGBUILD and let makeopkg build a installable package…

    https://github.com/B3-Coin/B3-CoinV2/blob/master/doc/build-unix.txt

  • Try to convert to the usual format pacman.
    Unzip the desired file, then open the terminal in that folder and execute the command: makepkg -sri
    (without root, not with root).
    The command will convert and install that file.

  • @tuxnot this will not work with sourcefile itself, what you think about is a PKGBUILD archive…

  • @joekamprad sorry. I thought that the file is aur, but it is not in the aur repository.

  • how exactly do I do all that? @joekamprad

  • @beswaax do what? creating a PKGBUILD? installing sourcefiles?

    I do not know that.

  • Install sourcefiles @joekamprad

  • every programm/app/script is different and created on different ways, there is not a single solution to install it.

  • i give you the instructios before directly from where you get it:

    https://github.com/B3-Coin/B3-CoinV2/blob/master/doc/build-unix.txt

    and it says read this first:

    https://github.com/B3-Coin/B3-CoinV2/blob/master/doc/readme-qt.rst

  • Easier could be to download the ZIP source code. Then use unzip it i.e. extract files from it to some directory. Then go to that directory.
    Install package qtcreator that brings many of the required packages.
    Now give the commands of the instructions:

    qmake
    make
    

    Note that the link’s instructions are for Debian, and may work not as such in Antergos. Especially the required packages do not all have the same names.

    Just try that and if something is missing, it will complain. :)

  • @manuel I did that and I got this error :

    src/txdb-leveldb.cpp:8:10: schwerwiegender Fehler: boost/version.hpp: Datei oder Verzeichnis nicht gefunden
    #include <boost/version.hpp>
    ^~~~~~~~~~~~~~~~~~~
    It’s in german, but it says it could not find the file or directory

  • As I can see here someone try to build for archlinux, but can not, caused by depending packages are not available in the right version’s:
    https://github.com/B3-Coin/B3-CoinV2/issues/19

  • I tried it too, but the compilation fails. Even though I got a bit further with installing package boost, the compilation failed within the boost code.
    So no luck here. :(

  • So how about trying other bitcoin apps? There are many of them in the official packages, and also in the AUR.
    I can’t recommend any of those apps since I haven’t used any of them.

  • Yeah, sad it does not work but thanks a lot for your help guys:)

  • @beswaax you are welcome ,😊

aur54 tar.gz3 Posts 17Views 1162
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.