• Wifi randomly stops working


    Every so often my computer will stay connected to the wifi network but won’t resolve adresses. This means that NetworkManager will say that I’m connected to a network, but trying to connect to any adress will produce a “cannot resolve” error.
    Specifically, trying to ping google will produce a “Name or service not known”, trying to curl it will produce a “Could not resolve host”, and trying to ping my nameserver will produce a “Network is unreachable”.
    I found that resetting the connection to the network (nmcli con <network-uuid> which essentially disconnects then reconnects to the network) remedies this issue, but I would like to find a more practical solution as this one can take time and be very annoying.

    Details:
    inxi -Fxzi
    http://termbin.com/n39i

    ifconfig
    http://termbin.com/jchn

    dmesg
    http://termbin.com/czlm

  • I am no expert on wifi dropping issues but I’ll go as far as my knowledge base can carry me to resolving this issue for you.

    modinfo iwlwifi

    then do

    cat /sys/module/iwlwifi/parameters/11n_disable

    there is also this arch wiki link: link text

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • modinfo iwlwifi

    https://ptpb.pw/RLlm

    $ cat /sys/module/iwlwifi/parameters/11n_disable
    1
    

    I’ll try to do modinfo again when it stops resolving addresses and see if anything changes.

  • Hi.
    Only as reference I give you mine:

    cat /sys/module/iwlwifi/parameters/11n_disable 0

    Your modinfo is fine. I didn’t catch anything wrong.
    So let’s go the next step
    systemctl list-unit-files --state=enabled
    then do
    ip addr
    Also please ensure that you’re using NetworkManager.
    It’s nm-applet for a GUI interface.
    If you’re using 2 different Network Mgr’s they will fight each other.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • I disabled it based on the Arch Wiki recommendation for general connection problems.

    systemctl list-unit-files --state=enabled
    https://ptpb.pw/_etw

    ip addr
    https://ptpb.pw/Am6g

    I’m pretty sure I’m using only one network manager.

    I’ll try those commands again when I have the network problem and see if anything changes.

  • Hi @Noammac
    Terribly sorry for this late reply.
    First off your systemctl list-unit-files --state-enabled is fine.
    No issues there.
    However, look at this:

    2: enp3s0: <NO-CARRIER,BROADCAST,MULTICAST,UP>
    

    The above is from your ip addr.
    This is basically telling you that your wifi is administratively up but no carrier.
    ONe thing that comes to mind is perhaps your wireless power saving configurations.

    Could you try to extend the timeout for your wifi? There’s a link from the wiki I"m going to supply:
    link text

    And another thing that comes to mind is also rfkill list wifi
    Could you post the output of that command?

    I’m going to give you a link on how to connect to wifi via cmd line: link text

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • Sorry for the late response time as well, I forgot to check the forums.

    rfkill list wifi
    https://ptpb.pw/EoeP

    And I don’t seem to have a /etc/systemd/system/[email protected]/ directory.

  • Are you using KDE? There’s a bug going on for weeks with networkmanager, check this thread:

    https://forum.antergos.com/topic/9359/wi-fi-disconnects-on-login

  • Hi @Noammac
    Your rfkill list wifi is fine. Nothing is blocked. And yes, as @ssspacez mentioned, apparently there is a wifi related bug having made it’s rounds. But that’s only if your using KDE.

    If not using KDE, then Let’s move on to the next step.
    Firstly, to see if you actually do or are using dhcp or dhclient, use htop and do a search.

    Use F3 and input either one or both to determine that your’re using dhcp and/or dhclient

    If you truly are not using it after checking, then the next following steps are useless to you and we’d have to stop there.
    But let me know in this thread regardless.

    If you do find out that you are using dhcp and it’s client, then do the following in this file.
    If you don’t have it, create it.

    in /etc/NetworkManager/NetworkManager.conf input this information

    [main]
    dhcp=dhclient

    then do the following:

    in /etc/resolv.conf. input the following.
    if you don’t have this file, create it:
    name_servers=<your name server>
    To find your name server, do the following and make comparisons to ensure correctness:
    ip addr
    and
    ip route
    and find your name server and input that value.
    into the /etc/resolv.conf. I just mentioned earlier.

    Then do the following:

    ensure that your systemd-resolved is enabled by doing the following:
    sudo systemctl enable systemd-resolved.service
    Hopefully you’ll have it.

    Then do the following:

    Check to see if your sudo systemctl disable systemd-networkd.service is running or not. If it is, disable it. YOu check by doing a systemctl status check on that particular service.

    Then do the following:

    REBOOT

    If none of the above steps have worked for you, revert back to the original settings as most obviously they haven’t worked.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • @modisc
    I don’t use KDE, and I tried your methods but I have a question.

    What you’re telling me is that if I have dhcpd running (found through ps aux | grep dhc), then I should put dhclient as my dhcp in NetworkManager.conf?

    Also, I already had a nameserver written in resolv.conf so I’m not sure if I need to change it. If I do, how do I correlate between the addresses given to me in ip addr and ip route?

    I understood everything after that.

  • Hi @Noammac .
    If you already have a name server, then change nothing.
    Leave as is.
    As for your first questioin, "yes"
    If nothing changes, then revert back to original / default settings as obviously those new changes had no effect.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • @modisc

    Your solution seemed to have worked for a day or so until I got those resolve issues once again until I rebooted. Perhaps it has something to do with kernel updates?

wifi126 Posts 12Views 742
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.