• I'd like to replace system screen locking with xsceensaver


    However, I cannot prevent the system locking the screen also. If I don’t have xscreensaver enabled, the system is not always even locked by the system, but when I have xscreensaver enabled, the system locks the screen too. This means I have to open first the system locking and then also xscreensaver.

    So how to disable the system screen locking? I like the good old xscreensaver more. I don’t want the screen blank, but show some random figures or animations.

    Thanks for all the help!

  • Hello, is this issue too easy or too difficult? I found one setting apparently controlling screen locking, but it didn’t affect this behaviour at all.

    All ideas are welcome!

  • @vpp21

    Which DE?

  • Sorry, what is DE?

  • @vpp21
    DE = Desktop Environment
    So it is Xfce, Gnome, KDE, … ?

  • Gnome, I think.

  • @vpp21 Ok. And sorry, I use Xfce, don’t know Gnome that well. But here we have Gnome experts that could answer your question.
    Probably there are newer alternatives than the old xscreensaver.

  • Ok, no problem, but I don’t know any more suitable screensavers. I happen to like the old one. But the issue really is that there seems to be another daemon shutting down the display, but even that does not do it reliably. So for the moment it only works reliably when xscreensaver is also activated.

    Hopefully someone knows Gnome well enough.

  • @vpp21 That other may be related to systemd AFAIK.

  • I wonder if that systemd behaviour can be affected somehow…

    In settings I found privacy settings and screen locking, but really that setting had no effect.

  • @vpp21 Sorry, maybe @joekamprad could help you? :)

  • I know he’s a very busy guy… may take some time.

  • @manuel said in I'd like to replace system screen locking with xsceensaver:

    I know he’s a very busy guy… may take some time.

    right ;) i’m busy on setting up my i3-xfce-hybrid DE … but looks like i almost get it ready…

    https://github.com/killajoe/i3-xfce4-antergos

  • @vpp21 said in I'd like to replace system screen locking with xsceensaver:

    xscreensaver

    xscreensaver and GNOME are not the best friends anymore, as GNOME is not implementing it anymore…

    I was long time GNOME user but i can not stand it anymore too… and switch to handcrafted DE…

    The idea to disable GNOME’s locking and also lightdm’s locking should work … but only with some hacking…

    As we investigate on the problem to get lightlocker work under GNOME… here:
    https://antergos.com/wiki/desktops/gnome/working-solution-to-use-lightdm-and-lightlocker-under-gnome/

    You will need to disable GNOME’s impact on this first. (disable gsd-power plugin)
    Then you should be able to use xscreensaver.
    Depending on the DM you are using they may be more to do…
    May it is enaugh to get xscreensaver starting as autostart file under ~/.config/autostart/

  • nano ~/.config/autostart/xscreensaver.desktop
    
    [Desktop Entry]
    Encoding=UTF-8
    Version=0.9.4
    Type=Application
    Name=xscreensaver
    Comment=oldshool
    Exec=/usr/bin/xscreensaver-command
    OnlyShowIn=GNOME;
    StartupNotify=false
    Terminal=false
    Hidden=false
    
  • Thanks a lot @joekamprad and @manuel! I will try these.

  • @vpp21 feel free to ask anything if you get into questions.

    I just implement xscreensaver into a testing environment with xfce4-power-manager and lightdm successful.

  • @vpp21 do you get it working?

  • @joekamprad , I will try tomorrow when I have free time to try.

  • @joekamprad , unfortunately I could not make anything better. xscreensaver does not start unless starting it manually and the system shuts down the display whenever xscreensaver activates.

system128 replace3 locking3 xsceensaver1 Posts 35Views 1630
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.