• Multiboot grub entry for antergos minimal ISO


    I’m trying to set a grub menuentry on a bootable external hardrive to boot the live minimal version of antergos ISO.

    I tried this menu entry found here https://github.com/thias/glim/blob/master/grub2/inc-antergos.cfg

    menuentry "Antergos Minimal 17.11 x86_64" --class antergos {
      set isoname="antergos-minimal-17.11-x86_64.iso"
      set isofile="${isopath}/antergos/${isoname}"
      echo "Using ${isoname}..."
      loopback loop $isofile
      #linux (loop)/arch/boot/vmlinuz img_loop=$isofile archisobasedir=arch archisolabel=ANTERGOS
      linux (loop)/arch/boot/vmlinuz img_dev=/dev/disk/by-label/GLIM img_loop=$isofile
      initrd (loop)/arch/boot/archiso.img

    But I get the following error when trying to boot from the iso, any ideas ?
    :![0_1519292199562_DSC_1685.JPG](Uploading 100%)

  • Didn’t manage to to edit the post above, I’ll post the image of the error here

  • You may change the name of the ISO file, or download the one that is on the example.

  • Will try this asap. On your example, what’s the value of $root ? $volumeLabel is the label of the partition holding the .iso ? In your example the .iso is directly at the root of the partition, right ?

    I’m curious about your remark :

    Naturally, this system requires an existing Linux system, and modification of its /boot/grub/custom.cfg. It should work on an Antergos system, and probably on an Arch system. Others I haven’t tested, but I suspect this example does not work e.g. on Debian based systems.

    I thought that boot/grub things was done before the the os is loaded, so I’m confused. The grub boot depends on which system it was configured ? I’m configuring the grub boot from a Lubuntu os.

  • @jptsetung
    The value of $root is the partition where the ISO file exists. In fact it should have been written as

    set isofile=/antergos-18.2-x86_64.iso

    to clarify that the file is in the root folder of that partition. It could be in another folder, but that would be reflected in the name, too. Thanks for the heads up! :)
    (Unfortunately I can’t correct it into the link post because this forum software is not allowing any editing of posts.)

    Yes, $volumelabel is the label of the $root partition.

    I’ve seen that grub is not well enough documented, and for some reason or other, grub in various systems do not always follow the same rules, especially when booting directly from the ISO file. And I’m no expert on grub, just have done my share of studying it, including some trial and error, and getting it work on my personal systems.

    But it doesn’t hurt to try, it could work in Lubuntu, too. Or may need some small modification…

  • @manuel Hey, thx a lot for the explanations. And your menu entry worked on lubuntu, that’s awesome. I’ll try to boot it in AZERTY keyboard mode now.
    Here is the menuentry taht worked for me which is basically the same as yours except I used my own iso file path.

    set isofile=/ISOs/antergos-minimal-18.2-x86_64.iso
    search --set --file $isofile
    probe -l $root --set=volumelabel
    set img_dev=/dev/disk/by-label/$volumelabel
    loopback loop $isofile
    linux (loop)/arch/boot/vmlinuz img_dev=$img_dev img_loop=$isofile setkmap=fr bootkbd=fr console-setup/layoutcode=fr
    initrd (loop)/arch/boot/archiso.img
  • Splendid! :)
    And interesting that it works on Lubuntu, too.

  • @manuel said in Multiboot grub entry for antergos minimal ISO:

    Splendid! :)
    And interesting that it works on Lubuntu, too.

    Any ideas how to boot the iso in AZERTY keyboard mode ?
    These options worked for L/Ubuntu ISOs, but they don’t work for the other kind of ISOs I tried

    setkmap=fr bootkbd=fr console-setup/layoutcode=fr
  • @jptsetung Sorry, never needed that. But Arch wiki (the holy grail of all Arch based distros) may contain useful tips.

  • @jptsetung
    Did some searching and found that kernel parameter pkeys=<countrycode> did the trick in my small test. The <countrycode> can be e.g. us or de for the US or Germany, respectively, so I suppose pkeys=fr should work.

    Didn’t test it much though, so it may not be a full solution…

  • @manuel Thx a lot, will try this asap

  • @jptsetung
    Maybe start a new thread for a new issue?

    And while at it, if you feel the original problem is solved, would you mark it as such? There’s a button below for that.

  • @manuel Solved, the pkeys option didn’t work according to my tests. I’ll open another topic. Thx a lot.

grub127 minimal10 entry7 multiboot3 Posts 14Views 1238
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.