• Laptop Lid Closed = Odd Behavior with Cursor

    Before I swapped my old HDD for an SSD, I had an installation of Antergos (up-to-date). I use an external monitor and not my laptop monitor. I had set the config file to ignore the lid switch. I was able to open the lid, press the power button and then close the lid without any issues. I could work right away with the lid down and the external monitor running.

    When I installed the SSD, I ran a clean install using the same version I had used before (latest from the Antergos website), and with the config file settings just as before the monitor stays on, but I get weird activity with my cursor!

    When I close the lid, the cursor seems to “quiver” for lack of a better word. When I move the cursor around using a mouse, it is like I am clicking and dragging as I begin to highlight areas instead of simply passing over them. I have to prop the lid of the laptop open just enough to stop the behavior. However, that doesn’t really solve the problem of being able to keep the lid shut.

    Since it seems that the settings for the switch and monitor are correct, is there another setting for using a mouse that I might be unaware of? It’s the only thing that doesn’t seem to work right. (I know, if this is my biggest problem, I should stop obsessing about it.)

    Any help will be greatly appreciated.


  • Hi.
    This is only an idea. This is could be only thought of as a quick fix or so.
    But what about unplugging the mouse from USB if you are using usb mouse and then reinserting.

    Also, I had a look within man xset.
    Didn’t find anything there but on the offchance I missed something, you may find something.
    The closest that I came across in man xset was for the s switch.
    But it’s not related. Again, it’s the closest that I came across.
    xset is used mainly for configuration purposes so it won’t really offer much help.

    If you have xinput installed, then I’d suggest having a look in there.

    link text

    You would of course start off with xinput --list
    Use either --short or --long
    The ID is what you’d be looking for.
    May also want to try with --get-feedbacks of-your-device
    I am none too sure if xinput list-props might offer any help. But it’s what I can think of, off one of the commands to help you out.
    I believe in the end you would be editing /etc/X11/xorg.conf

    That’s about it for about an hour or so of researching this issue for you.
    Don’t know what else there might be but again, I’m no expert on mouse issues.

    HOpe that some of this has been of some help.
    Other wise, you’d have to wait till hopefully someone else might be able to pop into this thread to help you out.

  • Thank you, @Modisc

    I tried your suggestions, and unplugging/plugging in the USB Mouse had no effect. While unplugged, the cursor was still quivering, which leads me to think it might have something to do with the trackpad and the lid being closed? I’m very uncertain about this. And, the USB Mouse would not start back up once plugged in and the lid was closed.

    When looking into the xinput --list, the USB Mouse with id=11 shows up, but when I try to get the feedback of this device the system says it can’t find it. Maybe I’m using the wrong term for the device?

    Oddly enough (?) I don’t have an /etc/X11/xorg.conf file. I do have an xintrc.d folder within the X11 folder. Inside that I have 3 conf files. One is for the keyboard, one is for synaptics (touchpad) and one for killX.

    This honestly isn’t a “must have” option, but it would certainly be helpful. The cat likes to reach in and press keys when I’m not at the desk. Mucked up an article I was working on. 😆

  • Hi again. :)

    Ok, so the USB mouse was unplugged and the screen cursor was quivering? That’s odd.
    To me it suggests that there is something residual left over of the mouse after being unplugged.
    that means, some native script, systemd unit, or lib file within your system was not stopped.

    If the lid was closed that means you have no direct physical access to it with your fingers so I can’t see that existing.

    If the USB mouse is not actualizing after being plugged in that, to me, might suggest that there is possibly hibernation or suspension issues and hardwares are not being actualized immediately after said suspension or hibernation is ended.

    To get feedback of your device you have to enter xinput --get-feedbacks YOURDEVICEID
    From the man pages of xinput: device can be the device name as a string or the XID of the device
    Also, from the Wiki, It is found in the xorg-xinput package.
    that means it comes from that.

    I wonder that you have not enabled acpi after wake up as being one of your issues. Though again, it’s only an esitmation or a guess at best.

    Could you please have a look at this Arch Wiki link.
    Read carefully because you may have to write a script (systemd unit file) to enable it permanently.

    It starts here:


    Trouble shooting near the bottom is where your interest would lie.

    then go to this link here about writing systemd files:

    link text
    I suspect that you’ll be doing these for user mode. Not root mode.

    I need to tell you that doing something like this is way beyond my knowledge base and if it comes to this, there isn’t much I can offer to help you within that realm.

    I’d encourage you to also visit some of the links within that particular wiki page that I’ve directed you to as there is relevant info.
    IT’s a lot of reading. I know I"ve had to dwell within that Wiki too, many times.

    I’m still hopefull thtat there’s someone much more adept then myself to come there into this thread.
    I’ve only just given you starters on where to look and potential troubleshooting.

    but still , post here again nevertheless :)

  • @modisc said in Laptop Lid Closed = Odd Behavior with Cursor:

    I wonder that you have not enabled acpi after wake up as being one of your issues. Though again, it’s only an esitmation or a guess at best.

    And a great guess it was! I installed “acpi” and “acpi-call-lts” from the Repositories, and voila! No cursor quiver!!! Thank you very much, @Modisc . I’m a very happy guy! 😁

    Yes, by far my experience so far with Antergos is the best I’ve run into with Linux; both OS and Community wise. Glad I found you!

  • Hi :)
    So glad I was able to help you out @Adam-Worth

laptop55 lid15 closed4 odd4 Posts 6Views 475
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.