• curl ssh wrong version


    Hallo All. I just installed Antergos. Then I installed few packages with pacman. Now after a restart I am getting ssl errors while trying to clone git.

    fatal: unable to access 'https://[email protected]/xxx/yyyy.git/': error:1408F10B:SSL routines:ssl3_get_record:wrong version number
    

    also curl to any https doesn’t work.

    curl https://google.com
    curl: (35) error:1408F10B:SSL routines:ssl3_get_record:wrong version number
    

    What is the solution ?

  • @neel-basu-z

    Hi!
    Could you show the output of command:

    pacman -Qm
    

    And does command

    wget https://google.com
    

    show any problems?

    One thing to check if you have your system properly updated:

    pacman -Syu
    

    or even

    pacman -Syyuu
    

    System info commands:
    lsblk -fm
    lspci
    sudo blkid
    sudo fdisk -l

  • pacman -Qm returns nothing. wget works fine. pacman -Syu output is in the pastebin. Pasting that output flags the reply as spam

    https://pastebin.com/T1AkBTBs

  • @manuel

    $ ldd `which curl`
    	linux-vdso.so.1 (0x00007ffdccee9000)
    	libcurl.so.4 => /usr/lib/libcurl.so.4 (0x00007fe06a5a5000)
    	libpthread.so.0 => /usr/lib/libpthread.so.0 (0x00007fe06a387000)
    	libc.so.6 => /usr/lib/libc.so.6 (0x00007fe069fd0000)
    	libnghttp2.so.14 => /usr/lib/libnghttp2.so.14 (0x00007fe069dab000)
    	libidn2.so.0 => /usr/lib/libidn2.so.0 (0x00007fe069b8e000)
    	libpsl.so.5 => /usr/lib/libpsl.so.5 (0x00007fe069980000)
    	libssl.so.1.1 => /usr/lib/libssl.so.1.1 (0x00007fe069716000)
    	libcrypto.so.1.1 => /usr/lib/libcrypto.so.1.1 (0x00007fe069299000)
    	libgssapi_krb5.so.2 => /usr/lib/libgssapi_krb5.so.2 (0x00007fe06904b000)
    	libkrb5.so.3 => /usr/lib/libkrb5.so.3 (0x00007fe068d63000)
    	libk5crypto.so.3 => /usr/lib/libk5crypto.so.3 (0x00007fe068b30000)
    	libcom_err.so.2 => /usr/lib/libcom_err.so.2 (0x00007fe06892c000)
    	libz.so.1 => /usr/lib/libz.so.1 (0x00007fe068715000)
    	/lib64/ld-linux-x86-64.so.2 => /usr/lib64/ld-linux-x86-64.so.2 (0x00007fe06aa4a000)
    	libunistring.so.2 => /usr/lib/libunistring.so.2 (0x00007fe068393000)
    	libdl.so.2 => /usr/lib/libdl.so.2 (0x00007fe06818f000)
    	libkrb5support.so.0 => /usr/lib/libkrb5support.so.0 (0x00007fe067f82000)
    	libkeyutils.so.1 => /usr/lib/libkeyutils.so.1 (0x00007fe067d7e000)
    	libresolv.so.2 => /usr/lib/libresolv.so.2 (0x00007fe067b67000)
    
    $ pacman -Q | egrep 'ssl|curl'
    curl 7.58.0-1
    openssl 1.1.0.g-1
    openssl-1.0 1.0.2.n-1
    python-pycurl 7.43.0.1-1
    
  • @neel-basu-z

    Your ‘pacman -Syu’ gives the same error when downloading Antergos database, so your system probably is not up to date.

    Maybe you could download the database manually from e.g. http://mirrors.antergos.com/antergos/x86_64/antergos.db and copy it into /var/lib/pacman/sync. Note that I’ve never done that myself so it may not work properly, so you probably want to backup old antergos.db first.
    But if that works, try also

    pacman -Syyuu
    

    By the way, I get this output:

    $ pacman -Q | egrep 'ssl|curl'
    curl 7.58.0-1
    openssl 1.1.0.g-1
    openssl-1.0 1.0.2.n-1
    perl-io-socket-ssl 2.055-1
    perl-net-ssleay 1.81-4
    python-pycurl 7.43.0.1-1
    

    System info commands:
    lsblk -fm
    lspci
    sudo blkid
    sudo fdisk -l

  • @manuel I downloaded that with wget and copied it to /var/lib/pacman/sync. Then ran pacman -Syyuu Got the same error

    Also my version of curl and openssl matches yours

  • Confirming this is necessarily a curl issue. I turn off proxy and connect directly curl https works. I set any other proxy server ip and port from https://free-proxy-list.net/ and then try to connect curl through proxy. I get the same error. So either this curl version has a bug or so many proxy servers are wrongly configured.

  • @neel-basu-z
    AFAIK, you can use wget with pacman by editing /etc/pacman.conf, enable variable XferCommand with the wget variant.
    Hope that helps.

    System info commands:
    lsblk -fm
    lspci
    sudo blkid
    sudo fdisk -l

  • @neel-basu-z
    I’ve always used pacman with the default settings, and curl has never caused any such problems, at least nothing that I’d have noticed.

    System info commands:
    lsblk -fm
    lspci
    sudo blkid
    sudo fdisk -l

ssh8 curl2 Posts 9Views 140
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.