• How to configure light-locker to auto lock when inactivity?


    I use light-locker + lightDM + i3 as my working environment. Basically light-locker is running without a problem (Checking with pidof light-locker shows process id exists), and I can lock the screen by light-locker-command -l. But my problem is when leaving it for a while (for the purpose inactivity) and waiting it to lock my screen. However, after half an hour, it still doesn’t lock the screen. Setting is configured using xfce4-power-manager as https://imgur.com/a/ZiA9v

    How can I set light-locker to lock my screen once my desktop goes inactivity (e.g. after 5 mins without any keyboard, mouse movement)? Thanks

  • @jtodd
    Hi,
    can you use command

    light-locker-settings
    

    ?

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • needs to be setup with light-locker-settings, as xfce-power-manager is not usable without xfce running in some way… and i do not know if locking the screen is not better to do with i3 itself:
    i3lock is doing this

    # Lock the system
    bindsym $mod+l exec i3lock -i ~/.config/i3/i3-lock-screen.png -t -f
    

    where ~/.config/i3/i3-lock-screen.png is the path to the image sown as lockscreen

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @manuel said in How to configure light-locker to auto lock when inactivity?:

    light-locker-settings

    That’s the problem. Was trying to configuring with light-locker-setting, but the dialogue within setting asked me to use xfce power manager - https://imgur.com/a/d74Ma

  • @joekamprad

    Can i3lock auto lock without using command? The reason why I use light-locker is because I need auto lock feature; otherwise I am pretty happy with manual command execution e.g. dm-tool lock

  • As I do use a hybrid i3-xfce4 Desktop I do load xfce4-power-manager as a daemon together with xfce4-power-manager. May you can just load it alone…

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • It seems to work now, but I am not sure if the change I note down here is correct or not. Anyway the biggest difference is I accidentally find the state when launched should be ‘inactive’ (by light-locker-command -q). So the setting in light-locker-settings or xfce4-power-manager-setting (security tab) should be configured to when the screensaver is deactivated.

    Thanks for all your help and advice!

  • @jtodd If you feel this thread is solved, could you mark it as such? There is a button below for that. 🙂

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

lock27 auto11 configure5 light-locker4 Posts 8Views 534
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.