• Wireless card does not appear - Broadcom BCM43142


    Does anyone know how do I install the drivers for this adaptor…

    Thanks

  • https://aur.archlinux.org/packages/bcm43142-firmware/
    Is may needed to get this device working.

    @eliottthales please give me this:

    inxi -Fxxc0 > log.txt && journalctl -b -0 >> log.txt && cat log.txt | curl -F [email protected] https://ptpb.pw/?u=1
    
  • Card-1: Broadcom Limited BCM43142 802.11b/g/n
    bus-ID: 01:00.0 chip-ID: 14e4:4365
    IF: N/A state: N/A mac: N/A

    bluetooth hci0: Direct firmware load for brcm/BCM.hcd failed with error -2

    i see two wireless adapters… but broadcom-wl should work… try installing the firmware:

    yaourt -S bcm43142-firmware
    
  • Thank you for the help @joekamprad ,
    I did as you said and apparently the firmware has been installed, however when I run the command inxi, the same info returns (IF: N/A state N/A mac: N/A). It had two adaptors on the list cause I was using an usb stick wifi to connect to the internet.

  • [ 3.788681] bluetooth hci0: Direct firmware load for brcm/BCM.hcd failed with error -2
    [ 4.191703] platform regulatory.0: Direct firmware load for regulatory.db failed with error -2

    This is the error showing…

  • So looks like no driver fitting for the wifi…
    Can you check:

    pacman -Qs broadcom
    
  • I think I found your issue! Do you have the proper headers installed? My wifi didn’t work until I went and installed the updated headers for the current kernel. I’m running the stock 4.15 kernel with the 4.15 headers. My wifi wasn’t working at all until i did that and rebooted. We have the same wifi card. Open up the add/remove packages app and do a search for headers and find the one that matches your current kernel version. Then reboot and install the broadcom-wl-dkms module and reboot again.

  • @Sparkz56 just saw it now, ill check and post the result here.

  • @sparkz56 said in Wireless card does not appear - Broadcom BCM43142:

    broadcom-wl-dkms

    can do the trick, it will build the modules each time kernel gets updated and on first install too !

  • I was having issues with my broadcom adapter on install. Turns out the driver wasn’t being loaded, so I had to load it manually. You can check out this thread for more info:
    https://forum.antergos.com/topic/8694/broadcom-wifi-adapter-troubles-on-install/6

    I’m not sure if it will help, but if nothing else works, give it a try? ¯\_(ツ)_/¯

  • @mando0975-0 oh i do not remember this one! I need to post less …

    So this is something i totally forget about…

    sudo rmmod wl
    sudo modprobe brcmfmac
    

    or oppisite:

    sudo rmmod brcmsmac
    sudo modprobe wl
    
  • @Sparkz56 sorry for taking so long. I just tried and it worked perfectly. Thank you very much for your help guys!!!

  • @eliottthales said in Wireless card does not appear - Broadcom BCM43142:

    @Sparkz56 sorry for taking so long. I just tried and it worked perfectly. Thank you very much for your help guys!!!

    No problem!!

wireless34 broadcom21 appear4 bcm431423 Posts 14Views 1026
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.