• Yestedays updates broke stuff


    libical.so.3 was uninstalled during yesterdays update, evolution won’t start, because of it. I don’t know what else is all broken, but evolution is set to start automatically on boot, and today it didn’t:

    Tried to start it from terminal and got a message that libcal.so.3 is missing. I searched the repos for it and it is not there! I tried to reinstall evolution and evolution data center, but instead of reinstalling it told me they were up to date, so that doesn’t sound right either, because it should reinstall, up to date or not.

    Evolution is my email program, and I need it for my business!

  • @zoidmo said in Yestedays updates broke stuff:

    libcal.so.3 is missing

    as fa as i know this should be included inside evolution itself…

    try to force reinstall:

    sudo pacman -Scc clean packages from cache

    sudo pacman -S evolution

  • pacman -Qo /usr/lib/libical.so.3
    /usr/lib/libical.so.3 is owned by libical 3.0.1-1
    
    pacman -Qs libical
    local/libical 3.0.1-1
        An open source reference implementation of the icalendar data type and serialization format
    
  • libical is a dependency from evolution-data-server and this dependency from evolution itself…

    So make sure evolution-data-server is installed!!

  • @joekamprad

    Well I force reinstalled both evolution, and evolution-data-server and the problem persists. I looked for libical 3.0.1-1 and it is nowhere to be found.

  • @zoidmo said in Yestedays updates broke stuff:

    libical

    as it is a true dependency of evolution-data-server it should be reinstalled with it…

    but try install itself too:

    sudo pacman -S libical

  • @joekamprad said in Yestedays updates broke stuff:

    sudo pacman -S libical

    [[email protected] ~]$ sudo pacman -S libical
    [sudo] password for rde: 
    resolving dependencies...
    looking for conflicting packages...
    :: libical and libical2 are in conflict. Remove libical2? [y/N] y
    error: failed to prepare transaction (could not satisfy dependencies)
    :: kdepimlibs4: removing libical2 breaks dependency 'libical2'
    
  • Well I uninstaled Libical2, and it took all kind of stuff with it, including evolution. Then I had to install evolution, evolution-data-server, and spamassassin again, and viola! I now have evolution back, and running.

    Now I don’t think I can call this solved though, because I am sure it broke other stuff, and I will have to find out what, the hard way.

    To be bluntly honest: THIS SH!T SHOULD NOT HAPPEN IN THE FIRST PLACE!!! I have no idea how exactly it happens (it’s more frequent than ever), or who is at fault, but all of this dependency stuff needs to be sorted out big time, and needs to have more attention payed too by developers. If I wanted stuff to break with updates, I would be using M$ Windows!

    Oh and thanks again to @joekamprad for his prompt service and dedication: You Rock!

  • @zoidmo said in Yestedays updates broke stuff:

    libical2

    this is from AUR and you had it installed, so the dependency error is caused by something you was installing from AUR before? (kdepimlibs4=AUR libical2=dep of it and also from AUR)

    AUR PKGBUILDS are not supported by Archlinux or Antergos itself, they are maintained by users like you and in his responsibility, and yours :)

    If you want highest stability do not install from AUR!

  • if you feel issue is solved , do not forget to marked as solved plz ;)

updates61 broke24 yestedays1 Posts 10Views 960
Locked
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.