• Mate-Compiz Window Border is not being displayed properly

    Hello, so I installed Compiz to get rid of the screen tearing but it messed the window border up. 0_1518951048249_border.png.

    I like the numix theme and I was wondering if there is a fix for this.

  • is’nt so that you will need to use compiz-configuration then to set theme?

  • @pulse said in Mate-Compiz Window Border is not being displayed properly:

    …so I installed Compiz…

    What window manager is running? Is it Marco or Compiz?

    If you’ve installed compiz pkg only, then Compiz WM won’t start automatically. It must be started by hand or thru Autostart.

  • Hello, I am currently running it.

    This is what I get when I type mate-tweak in the terminal (I changed the manager using dconf Editor):

    Window Manager is: compiz
    Current layout: default

    Everything seems to work just fine at the moment expect the Window Border.

  • @pulse said in Mate-Compiz Window Border is not being displayed properly:

    …(I changed the manager using dconf Editor)…

    Neither mate-tweak nor dconf-editor are needed to start and configure Compiz. It is completely cntrolled thru Compiz Config Settings Manager (CCSM).

    To start Compiz, replacing Marco, add to Autostart:

    compiz --replace

    To start Marcp, replacing Compiz, add to Autostart:

    marco --replace

    Antergos maintains its own Mate version. It has some inconguences with mainline Mate currently. In particular, CCSM won’t start in Antergos Mate, due to problems with protobuf package.

    The solution is to downgrade protobuf to a previous version:

    wget https://archive.archlinux.org/packages/p/protobuf/protobuf-3.4.1-1-x86_64.pkg.tar.xz
    sudo pacman -U protobuf-3.4.1-1-x86_64.pkg.tar.xz


    Try to start CCSM from menu, from terminal, from Alt+F2 command dialog. Does CCSM start?

    To avoid protobuf upgrade to the current, higher and not working version, add it to IgnorePkg = in the /etc/pacman.conf file:

    IgnorePkg = protobuf
  • Well ccsm worked before but after the downgrade, I receive the following error:

    Traceback (most recent call last):
    File “/usr/bin/ccsm”, line 93, in <module>
    import compizconfig
    ImportError: libprotobuf.so.15: cannot open shared object file: No such file or directory

    But the window border problem still remains. I tried to use another theme but the border problem remains. Only the default themes seem to work.

  • @pulse Try to run the command, from Alt+F2 dialog (or Run Application applet in the panel):

    gtk-window-decorator --replace

    Does it change something?

    HHonestly, I immediately uninstall all Numix themes from Antergos, and don’t use any of default themes:


    Window border themes work without a problem here.

  • Well, it did not change anything but I installed a new theme and it works now.

  • @pulse said in Mate-Compiz Window Border is not being displayed properly:

    …but I installed a new theme and it works now.


    A few more things.

    • compiz --replace and marco --replace commands may be used at any moment, even in the same X session. Window manager will be changed on the fly, logout-login isn’t needed

    • instead of using compiz --replace and marco --replace commands you may install aur/fusion-icon package. Add fusion-icon command Autostart, and disable compiz --replace and marco --replace commands, if you’ve added any.

    • fusion icon is not strictly tied to one or another Compiz version, and may be used with both

    • fusion icon utility manages Compiz, Marco, Metacity window managers, Gtk and Emerald window decorators, allows to call CCSM, restart the current WM. Fusion icon resides in the panel.

    • fusion icon activates the last used window manager on startup

    • fusion-icon command may be executed at any moment, not from Autostart only. The command will simply start the utility and will place its icon in the panel.

    It’s better to start up Compiz either with compiz --replace or with fusion-icon commands, than do it by manipulating DConf database. Two commands set many additional Compiz settings, contained in the CCSM.

  • Hello, thanks again for your help!
    I installed fusion icon but when I try to run it I get the following error:

    • Detected Session: unknown
    • Searching for installed applications…
      compizconfig - Error: error occurred during scandir: No such file or directory
      compizconfig - Info: Backend : ini
      compizconfig - Info: Integration : true
      compizconfig - Info: Profile : default
    • Using the GTK+ Interface
    • Namespace AppIndicator3 not available
      … Trying another interface
    • Using the Qt Interface
    • No module named PyQt5
      *** Error: All interfaces failed, aborting!
  • This error was new to me. It took some time to reproduce it in testing envoronment here, and to find a solution.

    Install python2-pyqt5 package:

    sudo pacman -Syu python2-pyqt5

    With python2-pyqt5 installed Fusion Icon starts up without a problem. No logout-login is needed.


window14 border4 displayed1 mate-compiz1 Posts 12Views 1021
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.